JoomlaCamp 2018 Essen - 03.02.2017 in Essen

mod_article_latest erzeugt links ohne category und berücksichtigt globale params nicht

    mod_article_latest erzeugt links ohne category und berücksichtigt globale params nicht

    Nun habe ich mal einen Effekt den ich nicht erklären kann. Ich sage aber nichts von Wald und Bäumen ...

    Ich habe meine Vereinsseite, die vor einiger Zeit von 2.5 auf 3.x umgestellt wurde und an der ich zur Zeit ziemlich viel arbeite.

    Nun gibt es eine große Beitragskategorie und darin viele Unterkategorien.
    Ich habe bei meinen Beiträgen als globale Option "Titel anzeigen" auf "ja" stehen.
    Bei den einzelnen Beiträgen ist nichts Besonders eingestellt. In den Content Blog Darstellungen sitmmt das, die globalen Params greifen.

    Die Beiträge der aktuellsten Unterkategorie sind Hauptbeiträge und ich lasse sie in einem mod_article_latest Modul anzeigen.

    Link zur Seite Hier seht ihr oben in der Mitte eine Box "Aktuelle Club-Post" das ist diejenige welche.

    Wenn ihr euch diese Links anschaut werdet ihr bemerken, dass sie keine Kategorien enthalten sondern nur die id des Beitrags selbst. Die Beiträge werden damit natürlich problemlos gefunden.
    Richtig ist das aber nicht, es müsste doch die Kattegorie mit im Link sein-

    Aber - die Parameter für die Beiträge sind nicht richtig gemerged. Eigentlich müsste die globale Einstellung "Titel anzeigen" wirksam sein. Tatsächlich werden die Titel nur gezeigt wenn ich jeden Beitrag einzeln aufrufe und dort "Titel zeigen" auf "ja" stelle.

    Hat jemand eine Erklärung?
    Grüße, Christiane
    ----------------
    JUG München | Auch ich bin ein Joomler
    Hilfreich!
    es müsste doch die Kattegorie mit im Link sein-

    ICh hab mit dem Modul bisschen rumprobiert und schaffe es nicht ohne Kategorie.
    Was mich auch wundert, ist, dass bei dir die Artikel-Slugs unaufgelöst sind also mit Doppelpunkt statt Bindestrich.
    Eigentlich sollte das diese Zeile in der helper.php abfangen(?)

    Quellcode

    1. $item->link = JRoute::_(ContentHelperRoute::getArticleRoute($item->slug, $item->catid, $item->language));

    ((Glaube nebenbei, dass es konsequenterweise $item->catslug statt $item->catid sein sollte. Egal. Joomla kommt wohl mit beidem klar.))

    Bist du sicher, dass dein Modul-Override oder Alternatives Layout mit dem im helper erzeugten $item->link arbeitet und nicht vielleicht mit $item->slug o.ä.?


    Und kleine Fundsache. In den BODY-Tags ist eine Fehlermeldung drinnen:

    Quellcode

    1. <body class="site <br />
    2. <b>Notice</b>: Undefined variable: option in <b>/.../webseiten/cbf-muenchen-2015/templates/cbf2015/index.php</b> on line <b>44</b><br />
    3. itemid-215 ">

    firstlady schrieb:

    Wenn ihr euch diese Links anschaut werdet ihr bemerken, dass sie keine Kategorien enthalten sondern nur die id des Beitrags selbst. Die Beiträge werden damit natürlich problemlos gefunden.
    Richtig ist das aber nicht, es müsste doch die Kattegorie mit im Link sein-


    Eine Lösung kann ich leider nicht anbieten. Mir ist nur aufgefallen, dass die Links dieses Moduls bei mir nur mit Firefox funktionieren. Google Chrome zeigt nach einem Klick eine leere Seite an und in der Omnibox steht als Adresse: "about:blank". Im Internet-Explorer folgt die Fehlermeldung: " Die Webseite kann nicht angezeigt werden...".
    --
    Gruß HaPott
    Ferienwohnung Norderney

forum.joomla.de is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.