JoomlaCamp 2018 Essen - 03.02.2017 in Essen

Warning: fopen(): Unable to find the wrapper "buffer

    Warning: fopen(): Unable to find the wrapper "buffer

    Hallo, nach einem Update auf Joomla Version 3.8 erhalte ich folgende FehelermeldungWarning:
    fopen(): Unable to find the wrapper "buffer" - did you forget to enable it when you configured PHP? in /home/u585554736/public_html/libraries/src/Client/FtpClient.php on line 1160Warning: fopen(buffer://cache): failed to open stream: No such file or directory in /home/u585554736/public_html/libraries/src/Client/FtpClient.php on line 1160Warning: fwrite() expects parameter 1 to be resource, boolean given in /home/u585554736/public_html/libraries/src/Client/FtpClient.php on line 1161Warning: rewind() expects parameter 1 to be resource, boolean given in /home/u585554736/public_html/libraries/src/Client/FtpClient.php on line 1162Warning: fclose() expects parameter 1 to be resource, boolean given in /home/u585554736/public_html/libraries/src/Client/FtpClient.php on line 1172

    Kann jemand sagen, was zu tun ist?
    Habe nur rudimentäre PHP-Kenntnisse....
    Verwunderlich ist , dass die Meldung nur erscheint nach Upload auf den Servr des Providers.
    Lokal unter Xampp ist die nicht zu sehen.
    Sicher bin ich nicht:

    Wenn du in deiner Joomla-Konfig NICHT FTP aktiviert hast, dann schlägt bei dir vermutlich ein Joomla-Bug zu, der leider noch nicht gelöst ist. Kannst ja mittesten:

    github.com/joomla/joomla-cms/pull/18075

    Oft ist daran eine Erweiterung wie Wettermodul schuld, aber es gab auch schon Meldungen, dass andere betroffen sind. Leider ohne exakte Nennung derselben.

    Ggf. reicht Fehler berichten in der Joomla-Konfig auf Keine zu setzen. Wenn die Seite dann aber extrem langsam ist bzw. manche Seiten nach mehrfachem Laden nicht angezeigt werden, solltest du erst mal ein Backup rückspielen.
    Joomla-Fachmann: ghsvs.de
    Danke für die Antwort.

    Das hat nicht geholfen. Ftp ist eingeschaltet.
    Die Seite habe ich lokal (Xampp) entwickelt und dann hoch geladen. Ist ein erster Entwurf: K2 und Kunena sind installiert.
    (youngsixties.de)
    Hatte den gleichen Bug auch schon bei einer anderen Seite ( na-hamburg.de ), die ich mal für eine gemeinnützige Organistaion gebaut hatte und immer noch betreue. Hier ist weder K2 noch Kunena installiert. Da habe ich es gemacht, wie von Dir vorgeschlagen: ein Backup von 3.75 eingespeilt.
    Beie der neuen seite habe ich das Problem, das ich vieles erst nach dem Update auf 3.8 gemacht habe und das eben unter Xampp ( = lokal) nicht auftaucht.
    Dennoch ddanke, werde dann wohl in den sauren Apfel beißen müssen.
    Hilfreich!
    Hallo,
    die Lösung war nun denkbar einfach, wenn ich auch nicht verstanden habe, was genau passiert ist.
    Bei Update auf 3.8. erschien auch immer noch folgende Meldung ( bei gleichzeitiger Erfolgsmeldung für das Update auf 3.8) :
    Warnung
    Aktualisierung des Manifest-Caches fehlgeschlagen: Erweiterung ist noch nicht installiert.
    ---------
    Die FTP Einstellungen mussten stimmen, da das ein per Kickstart hochgeladenes Paket war.
    ----------
    Was habe ich gemacht ?
    Nur unter Konfiguration -- > Server FTP einmal deaktiviert und danach wieder aktiviert uuuuund.....?????
    ALLES GUT!
    MELDUNG WEG!
    Habe das jetzt bei den beiden Websites gemacht, die beide komplett unterscheidliche Extensions haben und beide bei verschiedenen Providern liegen - hat beide Mal funktioniert.

forum.joomla.de is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.