JoomlaCamp 2018 Essen - 03.02.2017 in Essen

Template Kopie sieht im Frontend anders aus

    Template Kopie sieht im Frontend anders aus

    Hallo liebes Forum,

    schon lange lese ich hier im Forum immer mal wieder mit und habe auch schon öfters eine Antwort auf meine Joomla-Fragen /Probleme bekommen. Danke dafür!

    Heute habe ich das Standart - Template Protostar kopiert.
    Ich möchte die Startseite farblich anders gestalten, als die anderen Seiten.
    Doch leider sieht die Kopie im Fronten anders aus, also zum Beispiel werden in der Sidebar die klassischen .well -Einstellungen, also dieses Runde mit den Abständen usw.

    Ich finde einfach keine Lösung dafür.
    In den FAQ "Joomlaeigene Templates anpassen/ändern (z.B. Protostar, Beez3). Vorher eine Template-Kopie anlegen!"
    steht der Hinweis : "Gelegentlich muss man noch die Einstellungen des alten Template-Stils in den eigenen durch "abspicken" übernehmen, damit es im Frontend identisch aussieht."
    Doch wo kann ich hier irgendwas "abspicken" bzw. übernehmen??

    Schon mal ein Danke!
    Ich weiß nicht irgendwie stehe ich auf dem Schlauch...

    Meinst du unter "Templates: Stil bearbeiten" --> erweitert ? , da habe ich alle möglichen Einstellungen wie Template-Color und Background-Colour angepasst.

    Mein Problem ist allerdings, dass zum Beispiel der Stil der Side-bar nicht übernommen wird. Meine Änderungen aus der Css sind ja da, aber das Runde, die graue Unterlegung und die Abstände wie sie in der klassischen Protostar - Sidebar sind, werden nicht übernommen....

    lisa schrieb:


    Meinst du unter "Templates: Stil bearbeiten" --> erweitert ? , da habe ich alle möglichen Einstellungen wie Template-Color und Background-Colour angepasst.


    Ja genau, das meinte ich! Damit wäre deine letzte Frage beantwortet.

    Du hast den Stil auch als "Standard" gesetzt?
    Und dann schau mal in den Modulen, auf welcher Position diese so liegen. Da muss ja nun auch eine andere Template-Position (deine Kopie) drin stehen.
    Hast du verschiedene Module, wo teils der Modulklassenpräfix fehlt?

    Link zur Seite, damit man sieht, was genau das Problem ist?
    Gruß!
    JoomlaWunder
    Ich danke euch vielmals :thumbsup:
    Ja es lag an den erweiterten Menüeinstellungen.
    Dort musste ich den Modulstil dem richtigen Template anpassen.

    Was mich jetzt allerdings zu dem Problem führt, dass die Menüs in den Sidebars nicht auf allen Seiten gleich angezeigt werden, sonder nur bei dem zugehörigen Template *aarrgh*

    Achja, hier mal ein Link, dann könnt ihr besser verstehen was ich meine
    Jetzt funktioniert alles so wie ich es wollte.

    @time4mambo: Mit dem Kopieren der Module und sie dann jeweils im passenden Template anpassen funktioniert auch. Ist aber recht umfangreich.

    Jetzt habe ich bei den entsprechenden Moduklassenpräfix " well" eingetragen und den Modulstil auf "vererbt"gestellt und es wird richtig überall angezeigt 8) .

    Danke chr-hl auch für den Hinweis der Bildgrößen in der Slideshow. Das habe ich ebenfalls geändert.

    Vielen lieben Dank EUch!!
    Hallo lisa,

    lisa schrieb:

    Jetzt habe ich bei den entsprechenden Moduklassenpräfix " well" eingetragen und den Modulstil auf "vererbt"gestellt und es wird richtig überall angezeigt

    soweit OK, " well" übernimmt die Rahmen und Hintergrundfarbe des Moduls - aber nicht die "border" der Links.

    chr-hl schrieb:

    das wird sicher an den vorhandenen bzw. nichtvorhandenen Menü- bzw. Modulklassenpräfixen liegen (beispiel bei "Gemeinde")

    Du hast z.B. bei: "Vereine" > Suffix: ul.nav.menue_vereine. Fehlt z.B. bei "Gemeinde", wie schon Christian schreibt. Also: ...menue_gemeinde.
    Auch bei "Feuerwehr" & "Sportverein".

    Willst Du auch dort wie bei "Vereine" einen roten "border" haben, dann auch bei den anderen Menüs den Suffix reingeben.
    Danach in der CSS weiter "ausbauen". Z.B, so:

    Quellcode

    1. .nav.menu_vereine, .nav.menu_gemeinde, .nav.menu_sportverein, .nav.menu_feuerwehr li a {
    2. line-height:2.0em;
    3. border-bottom: 1px solid #e30000; }

    In der template.css /Zeile 2185 hast Du obige Anweisung schon (nur für vereine). Wegen einer user.css wurde schon geschrieben.

    Sehe aber keine protostar Kopie (?) Also anderer Name.

    Seitenklassen-Suffix für die Startseite > ja, wär ich auch dafür, wie Tom. Was willst Du denn dort anders haben?

    Liebe Grüße, Christine

    Indigo66 schrieb:

    Hätte ein Seitenklassen-Suffix für die Startseite nicht ausgereicht?


    Mit Seitenklassen-Suffix habe ich noch nicht gearbeitet. Ich bin mir auch nicht sicher, ob das gereicht hätte. Die Startseite soll mit dem Slider laufen, auf allen anderen Seiten möchte ich nur das Logo/Banner. Ich denke dies funktioniert nur mit einer Protostar - Kopie...


    @ Christine: Das Menü "Vereine" sollte gezielt anders dargestellt werden, als die anderen Menüs. Daher nur hier der Suffix.
    Das hätte gereicht, denn der Slider ist ein Modul welches Du dann nur dem Menüpunkt Startseite zugeordnet hättest und keinen anderen.
    Mit dem Sitenklassen-Suffix hast Du eine eigenständige CSS-Klasse nur für die Startseite und kannst sie so anders Stylen als den Rest.
    Gruß Tom - JUG-München
    Keinen privaten Support

    "Wir werden nicht größer, wenn wir andere kleiner machen." Phil Bosmans

forum.joomla.de is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.