JoomlaCamp 2018 Essen - 03.02.2017 in Essen

Erweiterungen in Joomla 3.8.3 können nicht auf Deutsch geändert werden

    Erweiterungen in Joomla 3.8.3 können nicht auf Deutsch geändert werden

    Hallo geschätzte Forums-Mitglieder,

    ich bin neue hier, und darf mich kurz vorstell, mein Name ist Klaus und ich versuche mich seit kurzem mit Joomla.
    Ich hoffe ich bin hier richtig bzw. war meine Foren suche bis jetzt erfolglos.

    Eigentlich klappt alles sehr gute, mit Hilfe von Yotube und Foren habe ich mir schon mal was gebastelt. - Leider ist mir aufgefallen das ich im meiner Joomla 3.8.3 die Erweiterungen nicht auf Deutsch umstellen kann.
    Ich installiere zwar die Sprachdatei, die Installation ist auch erfolgreich nur die Sparche bleibt in Englisch???
    Lediglich die Reiter (Schieber) werden Deutsch - die Ausgabe im Frontend ist aber Englisch??

    Hat vielleicht jemand einen Tipp.


    Danke im Voraus
    Hi,
    welches deutsche Sprachpaket für Joomla! verwendest Du?
    Language: German (de-DE) ?
    Language: German, Austria (de-AT) ?
    Language: German, Switzerland (de-CH)?

    Zumindest von dem Phoca Gallery Sprachpaket weiß ich, dass es nur in de-DE funktionieren wird.
    Das aktuelle Paket zu PG findest Du in meiner Signaur.

    Freundliche Grüße,
    Benno
    Hi,
    es gibt zwei Möglichkeiten:
    1.) de-DE installieren und als Standard verwenden
    2.) Die Spachpakete lokal auf Deinem Pc entzippen und die darin enthaltenen Sprachdateien (als Beispiel):
    de-DE.com_phocagallery.ini
    de-DE.com_phocagallery.sys.ini
    in:
    de-AT.com_phocagallery.ini
    de-AT.com_phocagallery.sys.ini
    umbenennen und per FTP in die Verzeichnisse:
    /language/de-AT/
    /administrator/language/de-AT/
    kopieren.

    Freundliche Grüße,
    Benno

    FrankG schrieb:

    das Problem ist das die Erweiterungen zu 99% kein DE-AT kennen... nimm einfach DE-DE... und lösche DE-AT wieder. Eine andere Lösung wäre du baust alles auf DE-AT um... wäre jedoch zu umständlich.

    Na ja, bei de-AT natürlich, dann auch nicht kärntnerisch, oder tirolerisch, oder, oder vergessen :)

    Hallo Benno - kannst ja auf Schweizer-Deutsch mal umtun rofl

    Bin auch dafür: Nimm de-DE - und gut ist. Denn: Man kann auch nach Probleme suchen (die keine sind) > "Lämpe sueche" :)

    Liebe Grüße, Christine
    So habe jetzt einiges probiert, leider ohne Erfolg.
    Die Inhaltssprache kann ich nicht neu hinzufügen - da entweder Img. oder Kürzel schon vorhanden.
    Gefunden habe ich unter /administrator/language habe ich noch einen Ordner de-AT - wenn ich diesen Ordner lösche ist das ganze Backend auf Englisch und ich kann es nicht mehr auf Deutsch stellen - ich bin Ratlos!
    Mache ich da was falsch - habe sowohl die de-De für Seiten als auch für Admin händisch installiert????????

    Kann ich eigentliche eine neue Joomla Installieren ohne das ich meine komplette Homepage neu machen muss (Beiträge, Menüs, Aussehen,....) vielleicht würde das was bringen????

    Danke für die Hilfe.

    Gruß Klaus

    @ nachtrag - ich habe jetzt schnell einen Testseite lokal installiert - da bei der Installation die Sprache Deutschland gewählt - da gehts - jetzt ist die Frage wie bekomme ich die Server-Installation so hin???

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „rcklaus“ ()

    Da steht nur de-DE und en-GB drinnen!
    Bei Inhaltssprachen steht nur noch en-GB drinnen!

    Wie kann ich die Inhaltssprache nachinstallieren - es kommt immer die Meldung Bild oder Kürzel existieren bereit in einer anderen Sprache.

    Oder - wie bekomme ich einen neue Jommla auf den Server ohne alle Berichte Menüs und Tamplets Änderungen neu machen zu müssen???
    Gruß Klaus
    Hallo Klaus,

    i versteh jetzt leider gar nix mehr.

    rcklaus schrieb:

    Da steht nur de-DE und en-GB drinnen!

    na passt ja, wolltest ja von de-AT weg.

    Bei Inhaltssprachen steht nur noch en-GB drinnen!

    ja eh. Die Threadanfrage betraf doch: Sprachpakete bei Erweiterungen.
    Inhaltssprachen ist ja für Mehrsprachigkeit.

    Wie kann ich die Inhaltssprache nachinstallieren - es kommt immer die Meldung Bild oder Kürzel existieren bereit in einer anderen Sprache.

    darf ja nicht 2 x verwendet werden, wenn System eh deutsch & englisch z.B. hat.
    Neu wäre z.B: docs.joomla.org/J3.x:Setup_a_M…eating_a_Content_Language

    Oder - wie bekomme ich einen neue Jommla auf den Server ohne alle Berichte Menüs und Tamplets Änderungen neu machen zu müssen???

    warum willst Du neu machen? Mach auf jeden Fall mal ein backup. Strengstensfalls müsstest Datenbank exportieren und wieder importieren.

    Betreffend Template: Hast Du das Standardtemplate? Wenn ja, eine Kopie davon machen. Steht in den FAQs.

    Sorry, hab schon den Faden verloren :)

    Liebe Grüße, Christine
    Also - die ganzen Erweiterungen kann ich nicht auf Deutsch stellen - das ist Punkt eins.
    wie schon vorher geschrieben - habe ich im Verzeichnis administrator/language noch einen Ordner mit de-AT - wie schon beschrieben, sobald ich diesen Ordner lösche ist alles auf Englisch (komplette Backend) und ich kann eine Deutsche Sprache installieren ohne Erfolg.

    Der Fehler am ganzen ist das ich bei Installation von Joomla bei den ersten Einstellungen die Sprache auf de-AT gestellt habe - mache ich das nicht geht alles wie gewünscht!!!

    Also wie bekomme ich die de-AT schnipsel weg und die de-DE so rein das das passt?

    Sorry ich kann das leider nur so Laienhaft erklären.
    Gruß Klaus

    rcklaus schrieb:

    Also wie bekomme ich die de-AT schnipsel weg und die de-DE so rein das das passt?


    Das ist schwierig zu erklären, da niemand wie du davor sitzt und sich ein genaues Bild von dem Problem machen kann. Ist möglicherweise nur eine Kleinigkeit, kann aber auch einen Eingriff in die DB erfordern.
    Backendzugang, FTP-Zugang und eventuell auch DB-Zugang könnten erforderlich sein.

    Ansonsten: Wie umfangreich ist denn deine Seite?
    Kannst ja ein frisches Joomla installieren, die Menüstruktur anlegen, die Beiträge z.B. mittels Copy&Paste übernehmen..... usw.
    Wenn es viele Beiträge sind, kannst du auch ein Ex- und Import-Tool verwenden. Komm gerade nicht auf den Namen.
    Gruß!
    JoomlaWunder

    rcklaus schrieb:

    wie schon vorher geschrieben - habe ich im Verzeichnis administrator/language noch einen Ordner mit de-AT - wie schon beschrieben, sobald ich diesen Ordner lösche ist alles auf Englisch (komplette Backend) und ich kann eine Deutsche Sprache installieren ohne Erfolg.


    Das spricht dafür, dass Joomla! noch nicht richtig auf de-De umgestellt ist. Vielleicht gibt es hier noch ein Problem. Unter System | Kontrollzentrum und dann links Sprache findest du alle Einstellungen. Wichtig ist, dass du links "installiert" auswählst und dann für den Bereich Site und Administrator die deutsche Sprache aktivierst. Im Bild habe ich rot markiert wo Site und Administrator nacheinander ausgewählt werden muss und der gelbe Stern bei de-DE erscheinen muss.
    Ich hatte beim Lesen den Eindruck, dass du installierte Sprache und Inhaltssprache verwechselst. Die Inhaltssprache ist aber nicht für die Übersetzung von Joomla! oder von Erweiterungen verantwortlich. Vereinfacht ausgedrückt ist Sie dafür verantwortlich zu beschreiben in welcher Sprache der Inhalt steht. Dies ist wichtig bei mehrsprachigen Websites oder damit Suchmaschinen Inhalte besser zuordnen können.

    rcklaus schrieb:

    Oder kennt jemand eine Möglichkeit - Meine Page in eine neu installierte Joomla zu integrieren oder umzuziehen!


    Ich glaube das ist aufwendiger als nach der richtigen Lösung zu suchen. Ich tue mich auch schwer "Meine Page" zu definieren. Deine Joomla!-Website besteht aus den Dateien und der Datenbank und deinen Inhalten im Zusammenspiel.
    Bilder
    • Sprachen Installiert Site test Administration .png

      67,14 kB, 1.284×629, 6 mal angesehen
    ---
    Don't push the river ... it flows by itself ...
    ---
    JUG Koblenz | Ich bin Joomler | astrid-guenther.de
    Hallo zusammen - es hat geklappt - das war der Fehler
    Ich habe bei installieren Sprachen nur im Reiter Site umgestellt und völlig übersehen das ich da auch noch auf Administrator umschalten kann.

    Vielen Dank für Eure Hilfe.

    Die Seite ist noch im werden - habe eine kleine Hobby-Imkerei und möchte auch in Zukunft die Page unseres Vereins machen - deshalb dieser Test.
    Wer mal schauen will, hier der Link.
    www.imkerei-seewald.at
    Bitte um Kritik und Anregungen was fehlt, falsch oder nicht richtig ist!

    Danke

    rcklaus schrieb:

    Die Seite ist noch im werden - habe eine kleine Hobby-Imkerei und möchte auch in Zukunft die Page unseres Vereins machen - deshalb dieser Test.
    Wer mal schauen will, hier der Link.
    www.imkerei-seewald.at
    Bitte um Kritik und Anregungen was fehlt, falsch oder nicht richtig ist!Danke


    Hallo Klaus,

    den Cookiehinweis und besonders eine Datenschutzerklärung würde ich einbauen. Letztere wird spätestens in drei monaten zur Pflicht. Da deine Seite Cookies speichert, solltest du zur Sicherheit beide Hinweise schnellstens Umsetzen.
    Hallo Klaus,

    ja, der Gesetzgeber schreibt hier "leider" ganz klar vor, dass beim betreten egel welcher Unterseite einer Webseite, ein Hinweis auf die Cookies sichtbar gesetzt werden muss.

    Auch müssen deine Hinweise über Cookies, Google Map, Youtube usw. in eine extra Datenschutzerklärung eingefügt werden. Ins Impressum gehören sie nicht rein.

    Nur als Tipp :)

forum.joomla.de is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.