JS Skript wird nicht ausgeführt... Warum?

  • Hallo ihr Lieben,

    derzeit versuche ich ein JS Snippet in die Ferienhaus Seite eines Bekannten einzubauen. An sich keine große Sache. Das JS soll eine Ferienhauskalender (kann auch noch anderes darstellen. Wird aber alles nach dem selben Prinzip dargestellt) aus von dem Hersteller vOffice darstellen. Dieser bieten dafür besagte Snippets an. Diese sehen so aus:


    Dieser Snippet soll an die Stelle an welcher der Kalender dargestellt werden soll:

    Code
    1. <div v-switch="layout"></div>


    Dieser Snippet soll vor den </body> Tag:

    Den Body-Snippet habe ich per Custom Modul eingefügt. Javascript ist erlaubt und das Snippet finde ich auch im Quellcode meiner Seite.


    Ich habe auch mal den Code lokal in eine Html Datei geschrieben und in Firefox geöffnet, hier wird alles dargestellt. In Joomla sieht man jedoch gar nichts.

    Weiß jemand woran das liegen könnte?


    Zur Testseite, auf der der Kalender testweise eingebunden werden sollte: http://www.ferienhaus-schoeneferien.de/index.php/test123

  • Den Body-Snippet habe ich per Custom Modul eingefügt

    In der Regel filtert Joomla bzw. der Editor JS im Content aus Sicherheitsgründen aus.


    Stell in Deinem Benutzeraccount de Editor kurzzeitig auf "Kein Editor" und versuche es nochmal.


    Oder schau in unsere Anleitungen: Wie iFrame- oder JavaScript-Code in einen Beitrag ohne das Code bereinigt wird.

  • Hallo Tom,

    Das habe ich versucht. Hat nicht funktioniert. Wie gesagt, der Javascript Snippet ist auch im Quelltext im Frontend zu finden (Ich implementiere regelmäßig Maps mit dieser Methode).... Der Javascript Code scheint nicht richtig ausgeführt zu werden. Ich habe das Gefühl, dass Joomla die Verbindung zu vOffice nicht zu lässt. Haben Sie da eine Idee?

  • Geh in die Konsole der Entwicklerwerkzeuge und prüfe auf JS-Fehler. Da ist einiges Dramatisches zu sehen, dass die weitere Ausführung verhindert.


    Geladen wird die Datei, was du ebenfalls in den Werkzeugen sehen kannst unter "Netzwerk" bzw. dann mit Gegenprüfung unter "Konsole" > "Warnungen", wo auch Hinweise erscheinen, ob dein Browser ggf. was blockiert. Bei mir z.B. die Google-Map, weil ich das so eingestellt habe ;-)