C:\xampp\htdocs\joomla\libraries\joomla\session\handler\native.php on line 260

  • Hallo an Alle,

    erstellte die Website mit Joomla Paket 3.9 am Localhost auf den Server hochladen. Konnte die configuration.php nicht richtig adaptieren. Daraufhin habe ich alles wieder vom Server gelöste und die configuration.php auf den Stand vor dem Hochladen zurückgestellt. Konnte mit Hilfe eines Forummitglieds die configuration.php wieder repararieren. Kann Joomla jedoch nicht auf dem Localhost mehr laden. Erhalte die Meldung



    Warning: session_start(): Failed to read session data: user (path: C:\xampp\tmp) in C:\xampp\htdocs\joomla\libraries\joomla\session\handler\native.php on line 260

    Error: Failed to start application: Failed to start the session


    Hat jemand bitte eine Lösung für mich. Konnte im Forum leider für mich keine passende Lösung finden.


    Danke und lg Emma

  • Hallo,


    bitte überprüfe ob die Datenbank mit den Zugangsdaten aus der configuration.php erreichbar ist.


    Ist mysql als service im xampp gestartet, kann via phpmyadmin auf die Datenbank zugegriffen werden?

  • Hallo!

    Ich habe das gleiche Problem:

    Warning: session_start(): Failed to read session data: user (path: C:\xampp\tmp) in C:\xampp\htdocs\zauberflora\Bereich01\libraries\joomla\session\handler\native.php on line 260

    Error: Failed to start application: Failed to start the session


    Ich finde in der configuration.php 2 Passwort-Einträge:

    public $password =

    und

    public $secret =


    Ist eines davon oder sind beide das Datenbankpasswort?

    LG Streethawk68

  • hast du (bestenfalls) ein Backup? Ich kenne das Problem nicht, aber hilft vielleicht eine weitere Installation auf deinem PC mit exakt den Einstellungen, bis auf DB vielleicht oder DB_prefix und wenn das funktioniert kopierst du PW und secret aus der configuration.php in die Seite mit dem Fehler?search


    Rechner mal rebooten?pardon


  • Die DB-Zugangsdaten sind diese:



    Ich vergebe unter /localhost kein DB-PW.

    Deshalb ist dieses Feld leer bei mir.


    Und kontrolliere auch mal die /log und /tmp -Pfade:


  • Hallo!

    Das hat bis zu einem gewissen Grad ganz prima funktioniert, danke. Ich bin jetzt schonmal so weit, dass der Titel der Seite und die korrekte Farbe angezeigt wird. Jedoch wird auch noch angezeigt:


    The requested page can't be found.



    An error has occurred while processing your request.

    You may not be able to visit this page because of:

    • an out-of-date bookmark/favourite
    • a mistyped address
    • a search engine that has an out-of-date listing for this site
    • you have no access to this page

    Error: Table 'usr_web892_1.#__viewlevels' doesn't exist: Table 'usr_web892_1.#__viewlevels' doesn't exist


    Ich habe schon

    public $sef = '0';

    public $sef_rewrite = '0';

    gesetzt und die Kollation der DB geändert, beides ohne Erfolg.


    Was ist hier zu tun?

    LG Street

  • Error: Table 'usr_web892_1.#__viewlevels' doesn't exist: Table 'usr_web892_1.#__viewlevels' doesn't exist

    das sieht irgendwie so aus, als hättest du dir ein Backup einer Datenbank vom Webserver gezogen und möchtest die Webseite nun lokal "nachbilden" ... ist selbstverständlich möglich ...

    hast du denn mal in deiner lokalen Datenbank geschaut, wie die Tabellen zu deiner lokalen Joomla installtion/Webseite aussehen? Heißt die Datenbank auch "usr_web892_1"?

  • wenn das Backup nicht all zu groß ist, würde ich die mysql.tar.gz mal entpacken und mir die Datei im Editor anschauen und die Tabelle suchen. ABER Achtung: wenn das Backup sehr groß ist >50MB sollte der PC viel RAM haben, damit das System nicht kollabiert... und alles löschen, bis auf die Tabelle "viewlevels" und dann bspw. mit phpmyadmin einspielen.


    Alternativ: eine Standard Joomla Neuinstallation mit dem Datenbanknamen und dann nach erfolgreicher Installation die Dateien in dem Verzeichnis mit den Dateien aus dem Backup überschreiben und die Datenbank wieder einspielen. Aber auch da muss man schauen, wie das MySQL-Backup aussieht. Wenn darin noch "drop" Befehle stehen (meistens einmal am Anfang, der eine glecihnamige DB löscht), muss man diese erst entfernen.


    Vielleicht kannst du die Tabelle auch händisch anlegen und die Levels händisch einpflegen, sofern keine weiteren Berechtigungen hinzugefügt wurden...