Menüeinträge können nicht bearbeitet werden

  • Guten Tag zusammen,

    ich habe gestern das erste Mal Joomla auf meinem Webhosting Paket installiert. Das hat alles soweit auch funktioniert. Zur Zeit habe ich allerdings das Problem, dass ich keine Menüteinträge bearbeiten oder neu anlegen kann. Es erscheint je nach Brwoser immer eine weiße Seite oder der Hinweis Fehler 500.


    Installiert habe ich die Joomla-Version 3.9.11 von der offiziellen Seite heruntergeladen. Die PHP-Version ist 7.2. Das Problem tritt bei den beiden standardmäßig installierten Templates Beez3 und protostar auf. An der Menüstruktur habe ich noch nichts verändert. Es gibt also nur das MainMenü.


    Welche Inforamtionen wären noch erforderlich, um mir zu helfen?


    Vielen Dank im Voraus

    Peter

  • Hallo Indigo66,

    das habe ich ausprobiert, hat aber leider nicht geholfen.

    Trotzdem vielen Dank.


    Beste Grüße

    Peter


    Hallo Pascal,


    danke für den Tipp. Das Problem liegt im Backend. Ich habe es trotzdem versucht, hat aber leider nichts gebracht


    Beste Grüße

    Peter

  • Da sind ein paar widersprüchliche Angaben.


    Du schreibst;

    Zitat

    Problem tritt bei den beiden standardmäßig installierten Templates Beez3 und protostar auf.

    Welches Problem?


    Es sind die Frontend Templates, du sagst aber, dass das Problem im Backend auftritt.

    Gib einen link zur Seite oder poste Screenshots, bitte.

  • Hallo,

    ja das war mißverständlich von mir ausgedrückt. Das Problem besteht tatsächlich im Backend. Auf der Seite selbst gibt es bisher nur das Standardmenü Home, da ich keine weiteres Menü anlegen kann. Und auch das Menü Home kann ich im Backend ja nicht bearbeiten.

    Das mit den Templates habe ich nur gesagt, weil ich als absoluter Neuling nicht weiß ob nicht eventuell ein Zusammenhang bestehen könnte. Hat aber scheinbar nur mehr Verwirrung gestiftet.


    Ich werde nun versuchen die Installation noch einmal vollständig neu vorzunehmen. Wobei ich bei der Installation keine Fehlermeldung bekommen habe.


    Beste Grüße

    Peter

  • Und warum versuchst nicht zuvor meinen Tipp? Als Orientierung.

    Das habe ich gemacht. Dabei bekomme ich 31 Datenbankabfragen.


    Am ehesten sind diese interessant denke ich:

    SQL
    1. SELECT `id`,`menutype`
    2. FROM jml_menu_types
    3. WHERE client_id = 0
    4. ORDER BY title


    SQL
    1. SELECT `id` AS `id`,`menutype` AS `value`,`title` AS `text`,`client_id` AS `client_id`
    2. FROM `jml_menu_types`
    3. WHERE client_id = 0
    4. ORDER BY client_id, title


    SQL
    1. SELECT *
    2. FROM jml_menu_types
    3. WHERE menutype <> ''
    4. AND client_id = 0
    5. ORDER BY title, menutype
    SQL
    1. SELECT title, menutype
    2. FROM jml_menu_types
    3. WHERE client_id = 1
    4. ORDER BY title ASC
    SQL
    1. SELECT m.*,e.element
    2. FROM jml_menu AS m
    3. LEFT JOIN jml_extensions AS e
    4. ON m.component_id = e.extension_id
    5. WHERE m.menutype = 'main'
    6. AND m.client_id = 1
    7. AND m.id > 1
    8. AND (e.enabled = 1 OR e.enabled IS NULL)
    9. ORDER BY m.lft


    Wobei ich nicht weiß welche von Bedeutung ist und mit den jeweiligen CallStack kann ich als Anfänger leider noch nichts anfangen. Daher meine Idee alles noch einmal zu machen, da ich eh bis her nur die Installation gemacht habe. Vielleicht ist es noch interessant wie ich es gemacht habe. Ich habe auf meinem loklaen Rechner zunächst die zip-Datei entpackt und diese dann per FTP auf den Server übertragen. Dann habe ich dort die Installation ausgeführt.


    Vielen Dank für die Unterstützung bis hierhin. Da ich heute abend nicht mehr dazu komme, die Installation neu zu machen, werde ich es auf morgen verschieben. Ich hoffe, dass es danach auch mit der Bearbeitung von Menüs und Menüeinträgen funktioniert.


    Beste Grüße

    Peter

  • peter

    Es sieht eigentlich alles richtig aus und du hast auch alles richtig gemacht.


    Der Debug Bericht der Datenbank sieht soweit auch korrekt aus,


    Ich versteheh nun so:

    Du gehst ins Backend, in die Übersicht Menüs, dort gibt es nur den Punkt Home.

    Wenn du einen Menüpunkt anklickst, erhältst du ein Formular um den Menüpukt zu ändern.

    Du ändertst dor etwas, klickst auf "Speichern" und bekommst einen Fehler 500.


    Hast du im Reiter "system" Das Fehelr berichten auf "Maximum" gestellt?
    Normalerweise wird dann bei einem Fehler 500 eine größere Meldung ausgegeben, mit einem Callstack.

    Kannst du davon einen Screenshot hochladen?


    Damit könnten wir was anfangen, aber es ist sehr ungewöhnlich.


    Eventuell sind beim File Transfer ein paar Dateien nicht korrekt angekommen. Also spricht nichts gegen einen neuen Versuch mit einer Installation.

  • Welchen Hoster hast du? Und ist dieser joomla-tauglich?

    Hast du die Dateien erst entpackt und dann alle einzeln hochgeladen, oder direkt auf dem Server entpackt? Letzteres wäre weniger Anfällig bzgl. Übertragungsfehlern.

    Hast du eventuell schon irgendwelche Drittanbieter-Erweiterungen installiert?

    Poste mal die configuration.php, aber mache die wichtigen Zugangsdaten unkenntlich!

  • Mein Hoster ist Biohost. Es gibt dort schon mehrere Joomla-Installationen.

    Ich habe die Dateien lokal entpackt und dann hochgeladen. Drittanbieter-Erweiterungen habe ich noch nicht installiert.

    Im Anhang ist die configuration.php als Textdatei


    Beste Grüße

    Peter

  • Ich habe endlich einen Ansatz gefunden. In einer error.log Datei habe ich folgendes gefunden:

    [Wed Sep 11 07:46:23.306738 2019] [proxy_fcgi:error] [pid 9431:tid 140211556185856] [client 212.93.4.130:33407] AH01071: Got error 'PHP message: PHP Warning: Class '\\Joomla\\CMS\\Table\\Nested' not found in /home/m2075/Sites/ofuture.de/libraries/loader.php on line 663\nPHP message: PHP Fatal error: Class 'Joomla\\CMS\\Table\\Nested' not found in /home/m2075/Sites/ofuture.de/libraries/src/Table/Menu.php on line 22\n', referer: https://ofuture.de/administrat…enus&view=items&menutype=