Cronjob-Anbieter für EJB gesucht

  • Hallo zusammen,


    ich würde gerne das Plugin EJB - Easy Joomla Backup von Kubik-Rubik nutzen. Leider kann es mein bisher genutzter Cronjob-Anbieter cron-job.org nicht ausführen. Je nach verwendeter Request-Methode bekomme ich die Fehlermeldung 301/303. Solches Verhalten ist auch auf der Projekt-Homepage beschrieben.


    Nutzt jemand von euch das Plugin mit welchem Cronjob-Anbieter? Ein händisches Komplett-Backup dauerte so ca. 30 sek, die Ausführungszeit sollte also entsprechend sein. Ich bin auch gerne bereit etwas dafür zu zahlen, wenn es dann zuverlässig funktioniert. Der Anbieter webcron.org bietet eine entsprechende Ausführungszeit für einen vertretbaren Preis an. Ich habe mich dort in den letzten Tagen bereits mehrfach mit unterschiedlichen Mailadresen registriert - leider bekam ich keinen Aktivierungscode. Auch eine Mitteilung über das Kontaktformular blieb bis jetzt unbeantwortet.


    Über einen Tipp würde ich mich sehr freuen

  • Ich versteh das Problem mit der "Request-Methode" nicht ganz. Für das Plugin schickt man einen stinknormalen HTTP-Seitenaufruf ab, den man auch per Browser-Adresszeile machen könnte. So was in der Art:

    Code
    1. https://example.org/?ejbtoken=bEc7L9635aA39eB0c3Bx55F782fG2662

    Viele Webspace-Provider haben solcherlei "Cronjob"-Features eh schon im Paket mit drinnen.


    Und, wenn 301/303 der Rückgabe-Statuscode der aufgerufenen Webseite ist, ist das kein "Fehler".


    Wunder mich nur ;-) Bist denn sicher, dass EJB den Job nicht doch gemacht hat?

  • Vielen Dank für eure Antworten!


    Leider habe in meinem Webhosting-Paket keine Möglichkeit für einen Hoster-Cronjob.


    Ich habe es jetzt nochmal frisch probiert:


    Ein fast jungfräuliches Joomla 3.9.11 auf PHP 7.3. EJB mit Crobjob-Script installiert, aktiviert und ein Token für ein kleines Datenbankbackup vergeben. Testweise auch die Administrator-.hatccess deaktivert.

    Dann bei cron-job.org einen Testcronjob angelegt und los..


    Ergebnis: Fehlgeschlagen 301 Moved Permanently Laut Backend wurde auch kein Backup gemacht. Wenn ich die URL aus dem Cronjob in mein Browserfenster kopiere und aufrufe, läuft das Script einen Augenblick und leitet mich dann auf die Frontend-Startseite weiter. Ein Blick ins Backend zeigt, dass ein Backup gemacht wurde.


    Anbei auch auch ein Screenshot von cron-job.org


    Die Komponente probiere ich mal aus - Vielen Dank!

  • Hallo winterman,


    danke für die Nutzung meiner Erweiterung.


    Der Statuscode 303 ist in dem Fall korrekt, weil nach einem erfolgreichen Backupprozess die Aufruf auf die Startseite umgeleitet wird. Prüfe doch bitte mal, ob das Backup nicht doch korrekt erstellt wurde!


    PS: Der Aufruf über das mitgelieferte CLI-Skript (siehe ejbCli.php im cli-Ordner) sollte die präferierte Art der automatischen Backuperstellung sein. Wenn du dich Möglichkeit hast, über SSH auf den Server zuzugreifen (Stichwort crontab) oder Cronjobs über deinen Hoster anlegen kannst, dann solltest du diese Methode bevorzugen.


    Gruß

  • Kubik-Rubik Die Ergänzung meines Posts #5 und deine Antwort haben sich überschnitten.


    Das Backup wurde laut Backend nicht erstellt. Im Ordner /administrator/components/com_easyjoomlabackup/backups/ finde ich auch nichts.


    Leider habe in meinem Webhosting-Paket keine Möglichkeit für einen Hoster-Cronjob.


    Das Problem bei cron-job.org ist, dass der Cronjob nach einigen fehlgeschlagenen Versuchen automatisch deaktiviert wird. Selbst wenn das Backup doch erstellt wurde.


    Ich habe jetzt testweise einen Cronjob bei my-cronjob.de angelegt und dort funktioniert es!


    Dort liegt die maximale Ausführungszeit bei 60 Sekunden. Ich hoffe das reicht auch bei einem Komplettbackup einer voll ausgebauten Seite, mal sehen.


    Ich beobachte das mal weiter und stelle dann hier ggfl. auf gelöst.


    Ich habe es jetzt mit einer anderen großen Seite probiert. Mit dem Anbieter my-cronjob.de funktioniert "Easy Joomla Backup" auch dort problemlos.


    Ich habe auf dieser Seite allerdings in den Backup-Einstellungen das Verzeichnis /images/bildergalerie herausgenommen. "Easy Joomla Backup" hatte sich dort schon bei einem händischen Test-Backup Wahrscheinlich aufgrund der dortigen Dateigrößen verschluckt.


    Vielen Dank nochmal an alle Tippgeber!


    -Thread gelöst-