Fehlermeldung phpVersion 5.6 im Backend

  • Wenn ich in der .htaccess alles mit php auskommentiere, bleibt im Configtool die Zeile mit der aktiven php Version frei, ebenso der Ordner:











    Und beim Aufruf des Backend kommt:


    Parse error: syntax error, unexpected '[' in /home/radgngxc/www.radclub-pielachtal.at/plugins/quickicon/akeebabackup/akeebabackup.php on line 240


    Wenn ich dann diese Datei deaktiviere - bei in der .htaccess auskommentierten php Befehlen ist die Seite wieder auf php 5.3.x - und die Zeile wie hier oben im Screeshot wieder leer.

  • Wieso 7.4 ist doch noch im Beta-Status? PHP 7.3 wäre derzeit zu empfehlen.

    Kann ich nicht sagen, war vom Hoster so eingestellt. Ich habs jetzt im Configtool auf 7.3 gesetzt, aber es ist völlig egal, was dort steht. Wenn in der htaccess auf die 5.6 verwiesen wird, dann funktioniert die Seite mit der Fehlermeldung im Backend, wenn diese auskommentiert wird, fällt die Version auf php 5.3.29 zurück - wie wenn im configtool gar nix bewirkt würde.

  • wie wenn im configtool gar nix bewirkt würde.

    Leg eine phpinfo.php in Deinem Stammverzeichnis an mit dem Inhalt

    PHP
    1. <?php
    2. phpinfo();
    3. ?>

    und rufe die mal über den Browser auf. Wir dort auch nicht die korrekte PHP-Version angezeigt, solltest Du mal dem Hoster auf die Füße treten.

    BTW: Nicht vergessen, danach die Datei wieder zu löschen.

  • und rufe die mal über den Browser auf. Wir dort auch nicht die korrekte PHP-Version angezeigt, solltest Du mal dem Hoster auf die Füße treten.

    BTW: Nicht vergessen, danach die Datei wieder zu löschen.


    Naja: http://radclub-pielachtal.at/phpinfo.php liefert das untige. Versteh ich jetzt richtig, dass ich ihm auf die Füße steigen kann, nur wenn ja, was soll ich ihm konkret sagen?




  • Danke schon mal, Tom!


    Noch eine Frage, bevor ich den Provider nochmal anschreibe: wenn ich in der htaccess alles auskommentiere, kann ich im Providertool die php 5.6 anwählen und alles funktioniert - außer die ominöse Fehlermeldung im Backoffice. Bei jeder anderen Auswahl im Providertool bekomme ich diese Fehlermeldung:


    Error: Failed to start application: Could not connect to MySQL server.

    Warning: session_write_close(): Failed to write session data (user). Please verify that the current setting of session.save_path is correct () in /home/radgngxc/www.radclub-pielachtal.at/libraries/joomla/session/handler/native.php on line 194


    Kann dort der Hund begraben liegen - weil der Provider wird mir das sicher entgegenhalten.


    LG


    Johann

  • Ergänzung: in dieser native.php findet sich das:


    {

    throw new RuntimeException('Failed to start the session: already started by PHP.');

    }


    // Fallback check for PHP 5.3

    if (version_compare(PHP_VERSION, '5.4', 'lt') && !$this->closed && isset($_SESSION) && $this->getId())

    {

    throw new RuntimeException('Failed to start the session: already started by PHP ($_SESSION is set).');

    }


    // If we are using cookies (default true) and headers have already been started (early output),

    if (ini_get('session.use_cookies') && headers_sent($file, $line))


    Ist das beachtlich? Weil Fallback check for PHP 5.3 erinnert mich daran, dass bei fehlendem Verweis in der htaccess die 5.3.29 aktiv wird

  • Nur so am Rande, scheint deine Installation viel Ballast mitzuschleppen.In der von dir geposteten Datei zum Systeminfo sind jede Menge deaktivierte Dinge, die vielleicht besser deinstalliert als deaktiviert worden wäre,.

    Ggf. ist so eine Altlast der Grund für dein Problem.

    Vielleicht macht es Sinn ein Backup zu erstellen, lokal unter xampp oder uwampp eintzuspielen und den Auftritt mal aufzuräumen.

  • Hallo,

    Nur so am Rande, scheint deine Installation viel Ballast mitzuschleppen.In der von dir geposteten Datei zum Systeminfo sind jede Menge deaktivierte Dinge, die vielleicht besser deinstalliert als deaktiviert worden wäre,.

    Ggf. ist so eine Altlast der Grund für dein Problem.

    Vielleicht macht es Sinn ein Backup zu erstellen, lokal unter xampp oder uwampp eintzuspielen und den Auftritt mal aufzuräumen.

    Da ich so ähnlich (vorhin) schon schreiben wollte, nun ergänzend:


    Der extplorer, brauchst Du den wirklich? Ist veraltet: https://www.radclub-pielachtal…m_extplorer/extplorer.xml

    Die com_weblinks auch: https://www.radclub-pielachtal…com_weblinks/weblinks.xml


    Kurz: Auch alle anderen Erweiterungen durchschauen, de-installieren bzw. updaten, welche gebraucht werden.


    Liebe Grüße

    Christine

  • Bei jeder anderen Auswahl im Providertool bekomme ich diese Fehlermeldung:


    Error: Failed to start application: Could not connect to MySQL server.

    Warning: session_write_close(): Failed to write session data (user). Please verify that the current setting of session.save_path is correct () in /home/radgngxc/www.radclub-pielachtal.at/libraries/joomla/session/handler/native.php on line 194


    Kann dort der Hund begraben liegen

    Nein!


    Im Config-Tool deines Webhosters gibt es

    Allgemeines -> PHP-Einstellungen -> Konfiguration

    Welche PHP-Versionen stehen dort zur Auswahl ?

    Stell dort mal Version 7.3 ein.


    Bis das dort auch angezeigt wird

    Allgemeines -> PHP-Einstellungen -> aktive Version -> PHP-Version

    wenn ursprünglich keine PHP-Version dort als aktiv angezeigt wird ?

  • Das hab ich schon durchgespielt. Voreingestellt ist dort 7.4:


    forum.joomla.de/core/attachment/4506/


    Die Auswahl von Versionen ist umfangreich:



    Und 5.6 ist die einzige Einstellung, in der die Webseite richtig dargestellt wird, ohne diese weiße Seite mit der Fehlermeldung aus Posting #46.

  • Zuvor mußt du die .htaccess umbenenen oder die Zeilen die mit AddHandler darin beginnen auskommentieren.

    Ja, das hab ich schon gemacht, wie erwähnt, alles auskommentiert aus der htaccess, jetzt hab ich sie nochmal umbenannt, gleiches Ergebnis: im Providertool kann ich alles einstellen, aber nur bei 5.6 funktioniert die Seite. Sonst die Fehlermeldung mit der Datei native.php - oder sogar noch zusätzliche Meldungen, wenn ich 7.4 im Tool anwähle.

  • Eins nach dem anderen.

    Die Fehlermeldung in #46 kommt ja wegen Fehler bei der Verbindung mit der Datenbank.


    Zuerst solltest du aber klären ob die im Config-Tool deines Webhosters eingestellte und angezeigte PHP-Version

    tatsächlich auch im Verzeichnis http://www.radclub-pielachtal.at zum Einsatz kommt, wenn du keine .htaccess dort hast.


    Du kannst dann durch aufrufen der http://radclub-pielachtal.at/phpinfo.php nachschauen welche PHP-Version tatsächlich zum Einsatz kommt, wenn du diese Datei phpinfo.php wieder benutzt.

  • Falls das noch nicht ausreicht um eine PHP 7.x Version zum Einsatz zu bringen.

    Zusätzlich die .htaccess verwenden und darin

    AddHandler php-fastcgi7.x .php

    benutzen.


    Das x durch die im Config-Tool deines Webhosters eingestellte PHP-Versions-Nr. ersetzen.


    Du kannst dann durch aufrufen der http://radclub-pielachtal.at/phpinfo.php wieder nachschauen welche PHP-Version tatsächlich zum Einsatz kommt, wenn du diese Datei phpinfo.php wieder benutzt.


    Eigentlich kann dir aber nur dein Webhoster sagen was du wie genau konfigurieren mußt um die gewünschte PHP-Version zu verwenden.

    Nur dein Webhoster hat die erforderlichen Informationen,

    da man einen Webserver sehr individuell konfigurieren kann und wir

    nicht wirklich wissen können wie dein Webserver im Detail konfiguriert ist.

  • Eventuell mußt du statt

    AddHandler php-fastcgi7.x .php

    eben

    AddHandler application/x-httpd-php7x .php

    oder

    AddType application/x-httpd-php7x .php

    verwenden.


    Siehe z.B. auch:

    https://www.variomedia.de/faq/…on-auswaehlen/article/193


    https://jweiland.net/know-how/…-verzeichnis-aendern.html


    z.B.:

    Zitat

    Außerdem darf für die Domain kein Fast-CGI aktiviert sein.

  • Jetzt hab ich überlauert, was genau Du meinst - und das führt uns, denk ich, einen Schritt weiter.


    Ich hab jetzt im Tool 7.3 eingestellt und dann wie schon gefühlt 100 Mal die weiße Seite mit diversen Fehlermeldungen erhalten. Ich hab aber nicht die phpinfo.php unter dieser Konfiguration getestet - jetzt dank Dir schon. Das Ergebnis:




    Offenbar liefert mein Provider ja richtig an, oder? - deine weiteren Tipps test ich gleich im Anschluss ...

  • Mit AddHandler application/x-httpd-php7.3 .php kommt bei Aufruf der HP dann dieses:



    Mit AddType application/x-httpd-php7.3 .php steh ich wieder auf 5.3.29