Hinweistext in der Registration

  • Hallo


    In der Datei default.php der Registration, möchten wir Text einfügen.


    Bei dem Text handelt es sich um Hinweise zum Passwort.


    PHP
    1. <tr>
    2. <td height="40">
    3. <label id="pw2msg" for="password2">
    4. <?php echo JText::_( 'Verify Password' ); ?>:
    5. </label>
    6. </td>
    7. <td>
    8. <input class="inputbox required validate-passverify" type="password" id="password2" name="password2" size="40" value="" /> *
    9. </td>
    10. </tr>


    Zwischen den beiden Felder soll der Text eingefügt werden.


    Drei oder vier Zeilen Text sollen dazwischen angezeigt werden.


    Aber wie ?

  • Das ist eine simple HTML-Tabelle.
    Du kannst also eine neuen Tabellenzelle machen oder in einer bestehenden das

    PHP
    1. <?php echo JText::_('MEINE_SPRACHVARIABLE'); ?>

    einsetzten.


    Im Backend unter Sprachen / Overrides / Neu kannst Du für MEINE_SPRACHVARIABLE den Text erstellen.

  • Hallo


    Ich habe einen Versuch gestartet und lief wie folgt ab:


    PHP
    1. <td height="40">
    2. <label id="pwmsg" for="password">
    3. <?php echo JText::_( 'Password' ); ?>:
    4. <?php echo JText::_( 'PASSWD_HINWEISTEXT' ); ?>:
    5. </label>
    6. </td>


    weiter ging es mit der Erstellung einer Sprachvariable

    klappte auf Anhieb dancedancedance

    dann die Datei default.php im Ordner /components/com_user/views/register/tmpl/ sichern und löschen, danach die geänderte Datei per ftp hochgeladen.


    Leider kein sichtbarer Erfolg unter: https://www.vapke.de/component/users/?view=registration


    Verstehe nicht warum aber eventuell einer von euch?

  • Wenn ich mir den Codeschnipsel in deinem ersten Post und den Pfad zu deiner geänderten Datei (/components/com_user/views/register/tmpl/) etwas genauer ansehe, dann scheinst du in einer uralten Datei aus Joomla 1.5.x herumzuwerkeln. Dieses Verzeichnis dümpelt wohl immer noch vor sich hin, obwohl es seit Joomla 2.5.x gar nicht mehr verwendet wird.


    Du musst ein Overreide von der Datei /components/com_users/views/registration/tmpl/default.php (mit einem s) erstellen. Nur das Ändern der Datei ist übrigens kein Override. Diese Änderung wird beim nächten Update wieder überschreiben. Für ein korrektes Override musst du die Datei ins folgende Verzeichnis kopieren und danach entsprechend ändern:


    /templates/protostar/html/registration/default.php

  • Hallo


    Aber nun die richtige Datei roflroflrofl



    Aber das Problem bleibt das gleiche.


    Wir haben auch hier keinerlei Ahnung wie wir die Textzeilen in die Datei bekommen.hmmhmmhmm


    Wir bitten erneut um Hilfe.


    *peinlich mit roten Kopf langsam weg schleicht*

  • Wenn du den Text tatsächlich zwischen die beiden Felder für das Passwort einfügen willst, dann muss ich hier leider passen. Ein einfaches Datei-Override reicht hier nicht. Aber vielleicht kommt noch jemand vorbei, der das besser kann als ich ;)


    Reicht es nicht, den Hinweis als Tooltipp anzuzeigen? Dann könntest du ein Sprach-Override von COM_USERS_PROFILE_PASSWORD1_LABEL oder COM_USERS_PROFILE_PASSWORD2_LABEL erstellen und dort den Text reinpacken.


    (Es muss dir übrigens nix peinlich sein, und wegschleichen musst du dich deswegen auch nicht :D)

  • Ich finde, das ist klar und übersichtlich. Du kannst bei der Bezeichnung "Passwort" noch ein Info-Icon einfügen, so dass wirklich jeder merkt, dass er da noch Zusatzinfos gibt ^^. Dazu müsstest du foldender Override erstellen:


    COM_USERS_PROFILE_PASSWORD1_LABEL="Passwort <span class="icon-info-circle"></span>"


    Evtl. muss es auch so aussehen (musst du mal testen):

    COM_USERS_PROFILE_PASSWORD1_LABEL="Passwort <span class=\"icon-info-circle\"></span>"

  • Guten Mittag Patrick,


    muss sagen, Kompliment, Du hat das mit den Overrides wunderbar gemacht 8)


    Zu Deiner Frage: Bist Du ja, siehe oben u.a. dort gewesen:

    Erweiterungen > Sprachen > Overrides bzw. dann > Neu usw.



    Daher würde mir jetzt nur einfallen & dabei habe ich gerade vorhin beim Ausprobieren, Mist gebaut ....


    System > Konfiguration > System > Sprache debuggen > Ja. Hat(te) auch funktioniert - und wie ...

    Es debuggte was das Zeug hält .....


    Dann wollte ich wieder retour, fand eh wo man auf > Nein schalten konnte, aber: Oben wo normalerweise "Speichern" ist > da kam ich nicht hin. Wird verdeckt. Entweder hab ich was falsch gemacht oder es ist ein bug.


    Meine Lösung war dann halt:

    In der configuration.php das hier:

    public $debug_lang = '1'; auf:

    public $debug_lang = '0'; zu stellen.


    Dies mal als Vorwarnung, falls auch Dir das passiert (?). Werde dem noch nachgehen.


    Liebe Grüße

    Christine

  • Kurz als Ergänzung dazu: Wie christine2 schreibt, kannst du entweder den Text, den du ändern möchtest, beim Anlegen eines neuen Sprachoverrides suchen.


    Die zweite (neue?) Möglichkeit ist, in der Konfiguration "Sprache debuggen" zu aktivieren und den Schalter darunter auf "Konstante" zu stellen. Da kann es aber sein, dass im Adminbereich der Text im oberen Menü so viel wird, dass das Menü die Leiste mit den Buttons überdeckt. Das ist ein kleiner Bug, allerdings glaube ich, dass es mehr Aufwand macht, diesen zu beheben, als es Nutzen hätte. In Version 4 sieht dann sowieso wieder alles anders aus und da funktioniert es auch wieder.

    Um Abhilfe zu schaffen, kann man über die Webentwicklertools des Browsers das Menü zurechtstutzen oder temporär entfernen oder die Einstellung wie von Christine beschrieben direkt in der configuration.php wieder zurückändern.

  • ...Um Abhilfe zu schaffen, kann man über die Webentwicklertools des Browsers das Menü zurechtstutzen oder temporär entfernen oder die Einstellung wie von Christine beschrieben direkt in der configuration.php wieder zurückändern.


    oder alternativ:


    ...Zuvor aber am besten ein weiteres Browsertab öffnen mit

    example.com/administrator/index.php?option=com_config

    und darin schon auf den System-Tab wechseln, womit dort ein einfaches und schnelles abschalten von Sprache debuggen möglich ist.