Phoca Galerie - Fehler 500

  • Hallo zusammen,


    ich habe seit kurzem folgendes Problem mit der Phoca Galerie:


    Wenn ich auf Komponenten - Phoca Galerie - Bilder gehe, wird die Seite nicht geladen und nach ca. 15 Sekunden Wartezeit kommt ein Fehler 500.


    Es wurde in letzter Zeit nichts an den Einstellungen geändert.


    Wenn ich die Miniaturbilderstellung abschalte, kommt der Fehler nicht mehr.

    Wenn ich diese jedoch wieder einschalte, ist der Fehler wieder da.


    Des Weiteren habe ich festgestellt das ich in Joomla keine Erweiterungen mehr aktualisieren kann. Es kommt immer der Fehler: Fehler beim Aktualisieren von COM_INSTALLER_TYPE_TYPE_.


    Wäre Klasse wenn mir da jemand weiter helfen könnte.


    Vielen Dank schon mal.


    Joomla 3.9.13

    PHP 7.2.24

  • Guten Abend,


    vielen Dank für die vielen hilfreichen Antworten.


    Nachdem ich die Seitenweise Miniaturbilderstellung aktiviert hatte hat alles in der Phoca Galerie wieder funktioniert! Klasse!


    Das reparieren der Datenbank hat leider nichts gebracht, es kommt beim installieren von Erweiterungs-Aktuallisierungen immer noch der Fehler:

    COM_INSTALLER_TYPE_TYPE_.


    j!-n : was meinst du mit: Edit: ein Erweiterungen --> Überprüfen schadet auch nie.?


    Und ich habe noch ein weiteres Problem festgestellt:

    Über das Kontaktformular können keine Emails mehr versendet werden.

    Es kommt immer der Fehler:


    Hinweis

    Mail-Funktion konnte nicht gestartet werden!


    Ich habe schon gehört das es bei php Version 7.2. Probleme mit der Mailfunktion geben soll.

    Kennt das schon jemand eine Lösung dafür?


    Vielen Dank schon mal für Eure Hilfe.


    Gruß Tim

  • Das reparieren der Datenbank hat leider nichts gebracht, es kommt beim installieren von Erweiterungs-Aktuallisierungen immer noch der Fehler:

    COM_INSTALLER_TYPE_TYPE_.

    Generell: tmp/logs Verzeichnis beschreibbar?


    Aktualisierungen von Erweiterungen: Nicht jede Erweiterung hat einen automatischen Updateserver. Diese muss man dann manuell aktualisieren.


    Schau mal bei:

    Erweiterungen > Verwalten > Aktualisierungsquellen > Phoca Gallery > Da sollte diese .../xml sein:

    https://raw.githubusercontent.…llery/master/manifest.xml


    ... und die anderen Erweiterungen auch überprüfen.


    Erweiterungen > Verwalten > Verwalten > Versionen

    j!-n : was meinst du mit: Edit: ein Erweiterungen --> Überprüfen schadet auch nie.?

    Schauen, was dort so steht.

    Über das Kontaktformular können keine Emails mehr versendet werden.

    Es kommt immer der Fehler:

    Hinweis

    Mail-Funktion konnte nicht gestartet werden!


    Ich habe schon gehört das es bei php Version 7.2. Probleme mit der Mailfunktion geben soll.

    An der PHP Version sollte es nicht liegen.

    Überprüfe: Globale Konfiguration (System > Konfiguration, Tab "Server") ob korrekt konfiguriert ist (dort z.B. die Absenderadresse fehlt) bzw. smpt oder PHP Mailer.


    Liebe Grüße

    Christine

  • Hallo Christine,


    laut den Systeminformationen sind die Verzeichnisse Tmp und Log beide beschreibbar.


    Die Aktualisierungsquelle habe ich überprüft, da steht bei Phoca Galerie tatsächlich:


    https://raw.githubusercontent.…llery/master/manifest.xml


    Unter Erweiterungen - Warnungen habe ich nun folgendes gefunden:



    Leider kenne ich mich mit der php.ini nicht aus.

    Könnt ihr mir sagen was ich dort genau eintragen muss um den richtigen Pfad für das temporäre Speichern zu bekommen und wo muss ich den Wert für die maximale Uploadgröße ändern?


    Wenn ich es richtig deute, müsste dies die Hauptursache meiner restlichen Probleme sein.

    Vielen Dank schon mal.


    Gruß Tim

  • ich kann in der php.ini eintragen was ich möchte, da ich einen eigenen vServer habe.

    Aber ich weiß leider nicht wie dieser Pfad aussehen muss.


    Wenn es für euch ok ist, würde ich gerne einen neuen Beitrag eröffnen, gezielt mit diesem Problem.

    Ich denke mit der bisherigen Überschrift "Phoca Galerie Fehler 500" gehen viele nicht davon aus das mittlerweile ein ganz anderes Problem behandelt wird.


    Vielen Dank nochmal für eure gute Hilfe bisher.

  • genau, aber die Frage ist was ich da für einen Pfad angeben soll?

    Die php.ini gilt ja für alle Websites auf dem vServer und nicht speziell für die eine Website die derzeit Probleme bereitet.

    Kann ich da einen beliebigen Ordner auf dem Server angeben, welcher die nötigen Schreibrechte besitzt?

  • genau, aber die Frage ist was ich da für einen Pfad angeben soll?

    Ich verstehe immer noch nicht, warum Du dafür einen Pfad brauchst?
    Alles Wichtige erfähsrst Du über phpinfo().

    Die php.ini gilt ja für alle Websites auf dem vServer

    Nein!


    Vielleicht solltest Du Deine Serverfragen besser in einem Serverforum stellen.