Installation einer Entwicklungsumgebung: Could not connect to MySQL Server

  • Hi,

    Ich habe auf meiner lokalen Entwicklungsumgebung in einem der Webs die Meldung erhalten, dass die vorhandenen Version php 7.1.x nicht mehr upgedatet wird.

    Brav habe ich meine 7.1 deinstalliert, Neustart und dann zuerst die neueste Version von Xampp 7.3.x danach die Version 7.2.x installiert.

    dazwischen immer Neustart, nach Deinstallation der vorangegangenen Version auch Neustart durchgeführt.


    In beiden Fällen habe ich unter dem 2. Tab "Datenbank" immer die Meldung erhalten: .. keine Verbindung zur Datenbank herstellen....


    Ich habe Windows 10 Pro 1909 mit den aktuellsten Updates.

    Ich habe Joomla .3.9.13 installiert


    Meine bisherigen und leider erfolglosen Maßnahmen:

    1. scf scannow
    2. chkdsk
    3. registry gereinigt mit jv16, dabei die defekte nicht blind entfernt sondern hinterfragt, ob sie mit xampp zusammenhängen.
    4. festgestellt, dass in allen Fällen phpMyAdmin läuft, sich starten ließ und arbeitete (localhost/phpMyAdmin oder auch localhost:88/phpMyAdmin)
    5. Den Apache-Server mit Listen:80 und listen 88 probiert, dabei bei Port 80 den www.publisher-Dienst von MS vorher deaktiviert
    6. wenn die Meldung kam, das der Connect zur Datenbank nicht klappt, versucht, den Servernamen zu ändern: Eingabe mit localhost, localhost:80 und localhost:88 probiert
    7. immer dann, wenn etwas anderes als localhost beim Servernamen eingetragen wurde, kam die Aufforderung im Installationsverzeichnis unter /installation die Sicherheitsdatei zu löschen gemacht.
    8. ließ ich "Servername" localhost stehen, kam der Verbindungsfehler.
    9. Die Sicherheitsdatei (Besitzer des Servers) dort gefunden und dann gelöscht.
    10. mit "weiter" kommt eine Endlosschleife der Installation..
    11. Alle Kombinationen auch dann gemacht, wenn ich den PC vom Netz genommen und den Virenscanner McAfee deinstalliert habe , die Firewall abgeschaltet war und nicht auf der Systempartition C (UAC - Warnmeldung) die Installation gemacht.
    12. Darüber hinaus das System von Acronis - True Image deaktiviert, (in der Taskleiste stand oft der Zugriff 127.0.0.1)
    13. Festgestellt, dass im Taskmanager unter Dienst Xampp aufgeführt war aber immer auch mit zwei apache-Servern mit null % Auslastung, permanent null!
    14. mit msconfig alle "Nicht Windows - dienste" deaktiviert und wie oben alle Varianten durchprobiert.
    15. dazwischen natürlich immer wieder Neustarts gemacht


    Wenn der Installationsprozess die Datenbank nicht erreicht, übersehe ich jetzt was? Muss ich irgendwo einen Parameter ändern?

    Nebenbei: In der Config.inf zum Apache steht weiter unter "name des Servers: localhost:80, So installiert mir der Installationsprozess von Xampp den apache.


    Was ist der klassische Eintrag unter "Servername" localhost, loalhost:80 oder angepasst an Listen dann localhost:88?

    Immer dann, wenn ich auf dem TAB "Datenbank" zu localhost was schreibe, kommt die Sicherheitsmeldung, die Datei im Installationsordner zu löschen und nach dem Löschen der Datei die Endlosschleife!


    wie stelle ich es an, Verbindung zur Datenbank zu bekommen?


    die Produktiv-Webs auf den Servern arbeiten korrekt, wie gesagt, mein PC lokal streikt jetzt :-(


    Für Tipps bin ich sehr dankbar!!

  • Wenn Du für die DB keine Zugangsdaten vergeben hast, ist das immer, root ohne PW.

    Kannst Du mit phpmyAdmin auf die DB Umgebung?

    Wenn ja, dann erstelle mal eine in phpMyAdmin eine neue DB für Joomla und nicht über die Installationroutine.

    Datenbankserver ist immer nur "localhost", den Port benötigst Du nicht.

    Could not connect to MySQL Server bedeutet eigentlich immer, dass entweder Host, DB-Name, Benutzer oder PW nicht stimmt.

  • Vermutlich hattest du im alten Xampp ein DB-Passwort vergeben und dieses in Joomla eingestellt.

    Installierst du ein neues Xampp, dann ist das DB-Passwort nun sehr wahrscheinlich leer (Standardeinstellung). Also ändere es in der configuration.php deiner Joomlas (leer lassen) oder setze das entsprechende DB-Passwort in Xampp und lass es in Joomla unverändert!

  • heiligs bleche, :Pbeerbeer


    habt ihr die Erschütterung bemerkt? mir ist ein Stein vom Herzen gefallen, nein nicht Stein, sondern ein Gebirge!!

    alles gut, die Lösung kam von Indigo66 und joomlawunder, herzlichen Dank allen für eure Infos!

    Es war "root" ohne Passwort für meinen lokalen Server, der auf XAMPP steht. firstlady :)


    Was für mich besonders ärgerlich ist: ich bin an der Stelle in der Vergangenheit schon mal hängen geblieben. Als ich eure Tipps las, fiel es mir wie Schuppen von den Augen …