Backend Login funktioniert nicht - Benutzer Plugin gelöscht/deaktiviert

  • Hallo ihr Lieben,


    ich habe ein Problem mit dem Backend-Login auf die Joomla-Seite, auf welcher ich etwas bearbeiten soll. Wenn ich mich einloggen möchte, wird kurz geladen und dann bricht der Vorgang ab.

    Ich habe recherchiert und durch die zuvor getätigten Vorgänge feststellen können, dass wohl das Benutzer-Plugin gelöscht oder deaktiviert wurde.


    Da ist natürlich klar, dass Joomla nicht weiß, wer sich einloggen darf und wer nicht. Wenn man die Webseite direkt in Joomla erstellt hat, ist ja auch das Problem, dass der Zugriff auf die Datenbank nicht vorhanden ist und man

    somit auch das Plugin nicht einfach wieder aktivieren kann.


    Die Frage ist nur, kann man da noch was machen, oder ist das ein hoffnungsloser Fall? Und wenn Letzteres, kommt man irgendwie an die Domain, um sozusagen neu anzufangen?


    Bin jetzt ein wenig verzweifelt, aber vielleicht kann mir von euch einer helfen? :)


    Vielen Dank schon einmal im Voraus.


    Liebe Grüße

    Sabrina

  • Es ist kein hoffnungloser Fall und Deine Domain wird nicht von Joomla verwaltet. Somit könntest auch jederzeit mit einem neuen Projekt beginnen.


    Aber wenn Du Dich mit der Datenbank (Zugang über Hoster mit phpMyAdmin) nicht auskennst wird es schwierieg den passenden Eintrag zu finden. Es könnte auch das Joomla-Autentifizierungs Plugin sein, welches deaktiviert ist. Da sich dieses und das von Dir erwähnte Plugin über Joomla nicht deinstallieren lässt, wird es nur deaktiviert sein.


    Wenn sich hier im Forum niemand findet, der das für Dich macht, klick oben im Forum auf "Dienstleister", für die Du dann ein paar Euro in die Hand nehmen solltest.

  • Die Domain hat grds. nichts mit dem CMS zu tun.

    Du kannst normalerweise im Konfigurationstool deines Hosters einstellen, auf welches Verzeichnis im Webspace die Domain verwiesen wird. Da sollte dann dein CMS installiert sein. Innerhalb des Webspace kann man mehrere CMS für unterschiedliche Domains betreiben.

    Backup hat ggf. auch dein Hoster, so dass zu funktionierenden Stand zurück gegangen werden kann. Hier mal den Hoster kontaktieren.

    Auch im Konfigurationstool des Hosters kann zumeist irgendwie auf die DB von zugegriffen werden (oft über phpmyadmin) und dann ein deaktiviertes Plugin wieder angestellt werden oder auch mal umgekehrt.

    Bei welchem Hoster bist du?

  • Hallo,

    weiß nicht, obs für Dich die richtige Lösung ist, aber vielleicht hilfts. Ich hatte mich vor kurzem mal ausgesperrt.

    Eine Datenbank muß es ja geben.

    Wenn man Zugriff auf die Datenbank hat (über den Hoster), kann man die Benutzer resetten. Über phpMyAdmin die Datenbank öffnen und die Liste der Tabellen anzeigen lassen. Evt. muß man auf eine 2te Seite wechseln, je nach Länge der Liste. Recht weit unten steht eine Tabelle xxx_users . Diese Tabelle anklicken und öffnen. Rechts im Fenster sollte der Inhalt zu sehen sein. Dort ist auch eine Liste der Benutzer.

    Vor einem Benutzer (z.B. Super User) in der Zeile auf "Bearbeiten" klicken. Es erscheint eine Tabelle und so ca. an 5.ter Stelle steht Password.

    Diese Schritte in dieser Reihenfolge ausführen :

    - in der rechten Zelle den Zeichensalat löschen und ein neues Passwort im Klartext eintippen.

    - in der Zelle links daneben das Pulldownmenü öffnen und den Wert MD5 anklicken (das ist zumindest beim Hoster x&x so)

    - DANN ERST am Ende der Tabelle auf OK klicken.

    Danach sollte das neue Passwort gelten. Bei mir hats funktioniert mit telefonischer Unterstützung von x&x. Es sieht schwieriger aus als es ist.


    Es kann sein, dass das nicht die Lösung für Dich ist, ist aber mal einen Versuch wert. Und wenns mal so funktioniert hat, kommt so immer ins Backend :)