PHP aktualisieren - Jobbörse

  • Hallo,

    meine Interneseite wurde Mitte 2017 auf Joomla-Basis eingerichtet.

    Mitte Januar´20 ist mir aufgefallen, dass ich keinen Zugang mehr über /administrator/index.php zu Joomla habe. Es erscheint eine weiße Seite.

    Nach Rücksprache mit meinem Provider (alfahosting) liegt das vermutlich an der veralteten PHP 5.6. Version. Hinweise, diese Version zu aktualisieren, habe ich "dummerweise" lange Zeit ignoriert.

    Suche jetzt nach jemanden, der PHP und vermutlich ein paar Templates sowie Joomla 3.7 auf den aktuellen Stand bringt.


    Wenn ich mich richtig erinnere, gab es vor Jahren hier auch mal eine Verlinkung zu einer Jobbörse aber leider finde ich die nicht mehr. Meine nicht die Dienstleister auf dieser Seite.
    Kann mir da jemand weiterhelfen?


    gruss.fritz

  • Hast Du denn bereits bei Alfahosting bei den Experten-Einstellungen - Servereinstellungen die PHP Version erhöht?

    Oh, ich wage mich an so etwas nicht heran. Ein Bekannter von mir der etwas Ahnung hat, schrieb:

    In der Webseite ist in der besagten .htaccess-Datei eingetragen,dass php 5.6 verwendet werden soll UND wenn man php 7. aufwärts aktiviert, zerschießt es die Markt-Seite.


    Was wirklich eigenartig ist, das Alfahosting schreibt:

    die PHP Version (PHP Version 5.6.40) ist aktiv. Daher muss hier nichts umgestellt werden, nach Ihrem Update müssten Sie die Zeilen:<FilesMatch .php$>

    SetHandler x-httpd-php56

    </FilesMatch>aus Ihrer .htaccess-Datei löschen und mit folgender ersetzen: AddHandler x-httpd-opcache-php7.1 .php


    JoomlaWunder
    Danke für Dein Angebot.


    Kenne als Jobbörse bezüglich Web-Programmierung nur "Das Auge". Kennt Ihr andere Job-Portal für Webdesign/Programmierung?


    gruss.fritz

  • die .htaccess Datei geht über die Einstellungen die alfahosting vorgibt.

    löscht man den betrefende code, greifen die einstellungen von alfahosting.
    änderst du den code in der datei, wie alfahosting es angibt wird php 7 dann ausgeführt...
    (Die Änderungen auf php 7 ist bei alfahsoting in den Einstellungen relativ einfach)


    EINS ist klar. DEINE SEITE (DEIN JOOMLAVERSIO) ist nicht aktuell, eine erhöhung von php version kann sie tatsächlich zerschießen. Du solltest dir Gedanken um eine aktualisierung von Joomla machen, auf die neuste Version (stand heute 3.9.14).
    Danach "muss" auch die php Version angehoben werden.. auch da ist 5.6. nicht mehr aktuell und wird glaub ich schon nicht mehr supportet.. 7.2 ist glaub ich die aktuellste die überall laufen sollte..

  • Wichtig ist auch folgendes: Du kannst bei Alfahosting die PHP-Version und die Nutzung von OPCache global einstellen. Möchtest du für einzelne Projekte davon abweichen, kannst du dafür eine Eintrag in die .htaccess setzen.

    Die globale und lokale Einstellung muss unterschiedlich sein, sofern du die Einstellung lokal nutzen möchtest. Sonst führt das schnell zu Serverproblemen.

  • Vielen Dank für Eure Hinweise.
    Es hat sich jemand hier aus dem Forum bei mir gemeldet und das Problem und die Updates von Joomla und PHP ruckzuck behoben/durchgeführt. Das war echt klasse.


    Vor ungefähr 2-3 Jahren war ich in einem Joomla Forum unterwegs welches diesem Forum vom Design sehr änlich ist. Dort gab es u.a. auch eine Rubrik, wo man als gemeinnützige Vereine nach Hilfestellungen für lau anfragen konnte. Dort gab es auch wie bereits oben geschrieben ein extra Link zu einer Jobbörse.


    gruss.fritz