Installieren aus Webkatalog

  • Ich bin seit neusten an einer Joomla-Installation die auf einem Strato-Server liegt. Im Gegensatz zu den bisherigen Installationen wird beim Webkatalog nichts angezeigt

    ×Keine Verbindung zum Joomla!-Server. Bitte später erneut versuchen.

    Ich vermute die Servereinstellungen sind anders. Die Frage ist nur, was.

    Welche PHP-Einstellungen braucht Joomla, damit der Webkatalog funktioniert?

  • hilft dir das weiter, bzw ist dein problem so in etwa?

    ich habe derzeit kein SSL auf der Testdomain


    Ich würde den Webkatalog einfach mal deinstallieren und erneut installieren. Ich gehe von einem aktuellen Joomla aus.

    Selten könnte es aber auch mal vorkommen, dass der Server tatsächlich nicht erreichbar ist.

    das habe ich auch schon öfter gemacht und das Pakelt mit der Version 2.0.1 installiert.


    Hast du ein normales Hostingpaket oder ein Managed Server?

    Hast du Joomla selbst installiert oder hast du es über den Web-Installer gemacht?

    Vielleicht auch mal ein Link zur Seite.

    Es ist ein normales Hostingpaket von Strato, welches ich übernommen habe. Joomla habe ich selbst installiert.

    http://test.bruderschaft-beyenburg.de/


    Ich habe die Installation mit Akkeba Backup gesichert und mit dem Kickstart-Installer auf meinem VServer geworfen, hier läuft es ohne Probleme.

  • Ich habe nun alle PHP-Versionen, die mir von Strato angeboten werden (7.2, 7.3, 7.4) durchprobiert.

    Wenn ich das Debuggen einschalte bekomme ich folgendes Ergebnis:

    Erst kommt das Joomlazeichen, was für mich eine Sanduhr ist. danach geht die Weg. und die eingangs erwähne Meldung kommt. Aber für mich erkenntliche Fehlermeldung kommt nicht.

  • Schau mal bitte ob Dir Strato die Möglichkeit bietet, an die Log-Dateien zu Deiner Domain zu kommen. Rufst Du den Webinstaller auf und es liegt ein Fehler vor, dann sollte es auch einen Eintrag mit Nummer im Log geben von dem man das Problem wahrscheinlich ableiten kann.


    Ich tippe darauf, dass entweder die IP des Extensions-Directory nicht aufgelöst werden konnte, oder das dort eine Einstellung / Firewall die Verbindung unterbindet. Eventuell ist auch eine Datei defekt oder es gibt einen internen Fehler (500), oder wegen mangelnder Rechte (403), oder so etwas in der Art. Muss man dann schauen.

  • Mir geht es primäre nicht um das installieren neuer Plugins, ich frage mich, ob die Updates auch klappen. Ich habe nicht unbedingt Lust alles händisch nachzusehen und eventuell upzudaten

    Bei deinem Problem geht es zunächst nur um das Funktionieren des Webkatalogs. Das hat mit dem Aktualisieren von Joomla und dessen Drittanbieter-Erweiterungen gar nichts zu tun. Dies machst du unter "Aktualisieren" -> "Aktualisierungen suchen".

    Sobald es eine Aktualisierung gibt, kannst du diese dann installieren, entweder über "Aktualisieren" oder einfach mal das zip vom Anbieter herunterladen und z.B. über "Paketdatei hochladen" installieren.

    Du kannst so auch jederzeit zum Testen irgendeine kleine Erweiterung installieren/deinstallieren. Dann siehst du doch, ob das funktioniert, oder ob beispielsweise die Pfade nicht stimmen oder es dateirechtliche Probleme oder so gibt.

  • Bei deinem Problem geht es zunächst nur um das Funktionieren des Webkatalogs. Das hat mit dem Aktualisieren von Joomla und dessen Drittanbieter-Erweiterungen gar nichts zu tun. Dies machst du unter "Aktualisieren" -> "Aktualisierungen suchen".

    Falsch, wenn sein Joomla bereits auf Ebene des Hostings / Server keine Verbindung zu anderen Servern aufnehmen kann (weil zum Beispiel die bereits von mit angesprochene Auflösung des DNS nicht funktioniert) dann wird auch die Aktualisierung insgesamt nicht funktionieren. Überall dort wo als Quellen die Namen der Domains hinterlegt sind, würde dieser Fehler auftreten. Und da sich IP-Adressen z.B. bei Umzügen eher ändern, werden die Entwickler bevorzugt eben Domains angegeben haben. Woher sollte das Joomla dann wissen das eine neue Version vorliegt? Merkst Du selbst oder? ;)

  • Pest: Deshalb meine weitere Ausführung zum Aktualisierungssystem. Wenn ich das Aktualisierungssystem testen möchte, dann teste ich dies direkt und nicht über das Anzeigen des Webkatalogs. Dieser hat bei mir auch schon des Öfteren gestreikt, dennoch funktionierte das Aktualisierungssystem weiterhin einwandfrei.

    Einfach eine kleine leicht veraltete Erweiterung installieren und auf die Anzeige einer neueren Version überprüfen. Fertig!

  • Also als "Strato-Problem-Interessierter/Löser" würde ich die Sache gerne ergründen.


    Habe einige Seiten bei Strato, dieses Problem aber noch nicht gehabt.


    Wenn du willst, kannst du mir mal Backend- und Strato-Zugang per PN-schicken.


    Dann würde ich sehr gerne mal 'reinschauen'! ;)

  • Zunächst einmal Danke für eure Hilfsbereitschaft.

    Ich tippe darauf, dass entweder die IP des Extensions-Directory nicht aufgelöst werden konnte, oder das dort eine Einstellung / Firewall die Verbindung unterbindet. Eventuell ist auch eine Datei defekt oder es gibt einen internen Fehler (500), oder wegen mangelnder Rechte (403), oder so etwas in der Art. Muss man dann schauen.

    Wie ist denn die Adresse oder IP? Die könnte ich dem Strato-Suport zwecks Verfügbarkeit mal schicken.

    Wenn ich das Aktualisierungssystem testen möchte, dann teste ich dies direkt und nicht über das Anzeigen des Webkatalogs.

    Da aktuell kein Update verfügbar war bzw ich nicht wusste, ob es klappt habe ich gedacht der Katalog ist ein Indiz. Heute habe ich festgestellt dass ein Update gefunden wurde. Also scheint das Updatesystem zu funktionieren.

    Wenn du willst, kannst du mir mal Backend- und Strato-Zugang per PN-schicken.

    Sorry, ich möchte die Zugangsdaten nicht weitergeben

  • Wie ist denn die Adresse oder IP? Die könnte ich dem Strato-Suport zwecks Verfügbarkeit mal schicken.

    Wenn es die gleiche wie beim normalen Extensions-Directory ist, dann sollte es die 72.29.124.148 sein. Das richtigen Stichwörter für Deinen Hoster solltes aber "Nameserver" oder "DNS" sein. Damit werden sie etwas anfangen können.

  • Kurzer Nachtrag: in der error.log steht nichts drin. Alles sauber

    Da stehen auch nur selten wirklich interessante Informationen drin. Gemeint war das Server-log zu Deinem Paket, in dem die Zugriffe und internen Fehler vermerkt werden.


    Unter Plesk schaut das z.B. so aus (Bild 1), existiert keine grafische Oberfläche wie Bild 2...