Backend lässt sich nicht aufrufen

  • Hallo,

    Ende Januar hatte ich das letzte Update eingespielt und wollte mich gestern wieder anmelden. Ich bekomme aber nur folgende Fehlermeldung:


    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at service@webmailer.de to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.



    Ich habe schon Datenbank und Inhalt gelöscht und eine Sicherung eingespielt. Leider ohne Erfolg.

    Hat noch jemand eine Idee, was ich noch tun kann?


    LG Kutsche

  • Moin Kutsche,

    hast du mal in die Server Logs rein geschaut?

    Um den Fehler einzugrenzen würde ich einmal eine index.html mit "Hallo World" in den Root packen.

    Wenn das geht, einfach mal eine : https://www.internetwerk.de/su…d-konfiguration-anzeigen/ erstellen und dann gucken was dein PHP auf dem Server macht.


    WBR,

    deltapapa

  • Frontend der Website funktioniert?


    Außerdem:

    aus:

    Forenregeln

  • Guten Morgen,


    ich möchte eure Fragen hier mal alle zusammen beantworten.


    • Frontend funktioniert fehlerfrei
    • die oben gezeigte Fehlermeldung kommt nur, wenn ich das Backend (http://example.org/administrator) aufrufe
    • Backend hat bis Ende Januar funktioniert. Damit sollten auch alle Zuordnungen funktionieren
    • das Ergebnis aus info.php habe ich beigefügt
    • soweit ich weiß, hat der Provider nichts geändert.
    • htaccess schließe ich aus, weil derzeit deaktiviert


    Noch Vorschläge, was ich testen soll?

    Danke


    Edit by Admin: URL zur Administration korrigiert da Link auf Schmuddelseite.

  • Ende Januar hatte ich das letzte Update eingespielt

    • soweit ich weiß, hat der Provider nichts geändert.
    Zitat

    PHP Version 7.3.14

    Build Date

    Feb 11 2020 13:57:12

    Welche PHP Version war davor im Einsatz?

    Welche Joomla-Erweiterungen sind im Einsatz?

  • ... und außer der geänderten PHP-Version kann auch die deaktivierte .htaccess eine Rolle spielen, sofern sie vorher aktiviert war. Du schreibst, dass sie derzeit aktiviert ist. Wie lange schon?

    In der .htaccess wird z.B. manchmal eine lokale PHP-Version eingestellt, um von der globalen PHP-Version abzuweichen. Steht jedoch beides auf der gleichen Version, führt das beuspielsweise auch zu Serverproblemen.

    Eventuell hattest du in der .htaccess auch andere benötigte Einträge drin stehen, die nun nicht mehr wirksam sind.


    Ist außer den Erweiterungen überhaupt dein Joomla aktuell?

  • siehe daher z.B. auch:

    wie gekommt man die Joomla version raus die installiert war


    Außerdem ist SEO aktiviert ?

    Falls ja:

    Was alles in SEO ist aktiviert:

    https://help.joomla.org/proxy?…inenoptimierung_.28SEO.29

    siehe in configuration.php

  • Hier scheint der Fehler zu liegen. In der htaccess im Ordner Administration mit folgendem Inhalt:

    Code
    1. AuthUserFile "/mnt/webp/a2/49/5330849/htdocs/administrator/.htpasswd"
    2. AuthName "Restricted Area"
    3. AuthType Basic
    4. require valid-user
    5. RewriteEngine On
    6. RewriteRule \.htpasswd$ - [F,L]

    Die Datei habe aber nie angepackt.

  • Bin nicht ganz sicher, aber vermutlich muss es heißen (anhand deiner php_info.php und Angabe für DOCUMENT_ROOT):

    Code
    1. AuthUserFile "/home/strato/http/power/rid/08/49/5330849/htdocs/administrator/.htpasswd"

    Die .htpasswd muss im /administrator/ natürlich liegen.


    Bei der Gelegenheit solltest du dann auch den tmp und logs-Pfad testen mit dem Tool

    "joom-config" vom Provider fc-hosting.de :

    https://www.fc-hosting.de/support/tools.php


    Wäre nicht das erste mal, dass bei Strato diese /mnt/-Pfade plötzlich nicht mehr stimmen.

  • Danke für die Hilfe. Das war es.