php.ini auf joomla 3 Asus NAS ändern

  • Guten Tag,

    immer wieder und leider bisher erfolglos (da Anfänger), versuche ich ein Problem mit "Joomla3" auf meinem Asus NAS 6102T zu lösen.

    Ich habe mit Joomla eine Website erstellt und versuche nun plugins zu ergänzen.

    Beim Hochladen erhalte ich dann häufig die Fehlermeldung:;(

    "Es gibt einen Fehler beim Hochladen dieser Datei auf den Server.

    Maximale PHP-Dateihochladegröße zu klein: Sowohl der Wert für „upload_max_filesize“, als auch für „post_max_size“ muss in der php.ini und/oder der .htaccess-Datei definiert werden."

    Die maximale Hochladegröße beträgt voreingestellt 2 MB!

    (Ich wollte z.B. die Datei "pkg_jce_pro_289" (JCE - A Content Editor for Joomla! hochladen und diese ist 2,531 MB groß!)

    Mit der Suche nach Möglichkeiten die erforderlichen Änderungen vorzunehmen beschäftige ich mich nun schon (erfolglos und frustriert) geraume Zeit.

    Können Sie mir hierbei helfen, eine möglichst einfache Lösung zu finden?

    Wie kann ich auf die php.ini-datei zugreifen und diese ändern?

    Wo setze ich (nach Syteminformation Joomla) die Adresse: "/usr/local/AppCentral/php7/etc/php.ini " oder

    "/usr/local/AppCentral/php7/etc" ein?


    Bitte Hilfe.

    Claudio

  • Grundsätzlich ist damit gemeint, dass man eine php.ini im Joomla-Root erzeugt und dort die entsprechenden Einträge macht, also die beiden Werte einträgt (am besten beide gleich hoch). Standardmäßig liegt diese Datei dort nicht.

    Ob es in deinem Fall weiter Möglichkeiten gibt (davon gehe ich aus), kann ich nicht sagen, da ich mich mit deinem Server nicht auskenne. Manchmal kann man auch die .htaccess für solche Einträge nutzen.


    Diese Dateien bearbeitet man mit einem geeigneten Edito, z.B. Notepad++ ,PSPAD ... und einige mehr.


    Beispiel-Eintrag für php.ini:

    Code
    1. upload_max_filesize = 48M
    2. post_max_size = 64M

    Wichtig: post_max_size >= upload_max_filesize

  • Das eine ist ein Ordner, "/usr/local/AppCentral/php7/etc", das andere die Datei, die das Ziel wäre "/usr/local/AppCentral/php7/etc/php.ini ".


    Kennst du dich da wirklich gut genug aus? Zumal Joomla auf deinem NAS nicht wirklich "rocken" wird und die Dokumentation dazu ziemlich spärlich ist.

  • Vielen Dank für die Informationen,

    von mir das noch dazu:

    nachdem ich mir das Asus NAS gekauft und als Mediencenter zuhause eingerichtet hatte, kam die Idee auf, auch eine Website darauf zu verwalten,, sozusagen alles zuhause unter Kntrolle zu haben, ohne mich an einen Webhoster zu binden. Hat auch alles soweit funktioniert, bis auf die Uploadbeschränkung auf 2 MB. Hier habe ich mich dann erkundigt und festgestellt, dass das auf der Windows-Schiene kein Problem darstellt, mit xampp, filezilla und Co. kann das üblicherweise geregelt werden (wenn der Webhoster sich nicht querstellt).

    Auf dem NAS sieht die Sache anders aus, weil (soweit meine Erkenntnisse, wie gesagt bloody beginner) man in die Tiefen des Systems auf Linux-Basis einstzeigen muss. Und das habe ich sogar bis zur Einrichtung von Ubuntu und der Sichtung gesperrter Rootordner gemacht. Hat alles nichts genützt. Die Nachfrage bei Asus hat ergeben, dass dies eine Sache von Joomla sei. Bei JCE hatte ich den JCE-Editor pro gekauft (wie gesagt uploadpackage mit 2,5 MB Datenvolumen und daher nicht uploadbar) und dort sagte man mir, ich solle mich doch mal bei ASUS erkundigen, sie könnten da nicht helfen. (Übrigens, den Phoca-Editor hätte ich auch sehr gern implementiert, aber gleiches Problem).

    Ich verstehe eine Uploadbeschränkung grundsätzlich, wenn der Sinn ein Schutz des Hosters bzgl. "Webspaceverschwendung" sein sollte, das kann ich aber bei der Benutzung von NAS-Systemen überhaupt nicht verstehen, hier betrifft es doch nur meine eigene Serverkapazität. Also, warum nicht in der Asus-App Joomla von den Entwicklern einen Button einbauen, der eine Änderung der 2MB (die ja nun wirklich häufig bei Plugins oder Modulen überschritten wird) zuließe, zudem das den Umsatz bei Plugin-Käufen sicher erhöhen würde.


    Entschuldigung für meine episch lange Ausführung, aber ich hatte den Gedanken: das musste mal gesagt werden!

    Claudio

  • Schau doch erst mal in den Systeminformationen Joomlas nach, was da im Reiter "PHP" für die beiden Parameter aus Post #2 genannt wird.


    Und hast du denn das schon probiert?

    Grundsätzlich ist damit gemeint, dass man eine php.ini im Joomla-Root erzeugt und dort die entsprechenden Einträge macht

    also eine neue Datei im Joomla-Verzeichnis anlegen.


    Gelegentlich verwendet man dann auch _user.ini statt php.ini. Je nach Server-Konfiguration.


    Original-Konfigurationsdateien sollte man generell nur im Notfall anpassen.


    Zusätzlich gibt es in Joomla die Variante "Aus Verzeichnis installieren", wenn ein Upload zu groß ist.

    https://docs.joomla.org/Help39…ension_Manager_Install/de


    Wobei ich statt

    "Lade den Inhalt dieses Verzeichnisses (einschließlich Dateien und Unterverzeichnisse) mit Hilfe von FTP in ein Verzeichnis auf deinem Server hoch."


    geschrieben hätte


    "Lade den Inhalt dieses Verzeichnisses (einschließlich Dateien und Unterverzeichnisse) mit Hilfe von FTP in einen Unterordner das /tmp/-Verzeichnisses deines Joomlas hoch."


    Weil man den Pfad zum temporären Verzeichnis (tmp) zur Not in der Konfiguration findet und dann nur noch seinen Unterordnernamen dranhängen muss.

  • Hi,

    Zum eigentlichen Problem kann ich leider nichts beitragen, aber was meinst Du mit:

    (Übrigens, den Phoca-Editor hätte ich auch sehr gern implementiert, aber gleiches Problem).

    Wenn damit Phoca Commander gemeint ist, die Komponente ist doch nur 811KB groß...


    Freundliche Grüße,

    Benno

  • Nochmal Danke für die Infos; ich glaube, dass ich es jetzt hinkriege, wenn nicht über die Paketdatei, dann doch über "aus Verzeichnis installieren".

    Benno, ich habe den Phoca Commander mit der Phoca-Gallery verwechselt, die ist größer als 2 MB.


    Grüße!

  • Nochmal Danke für die Infos; ich glaube, dass ich es jetzt hinkriege, wenn nicht über die Paketdatei, dann doch über "aus Verzeichnis installieren".

    Das funktioniert schon, ist nun aber wohl nur eine Notlösung. 2MB sind wirklich sehr wenig. Möglicherweise sind auch andere Werte auf dem Server nicht optimal. Wenn es weitere Probleme geben sollte, immer die Servereinstellungen im Hinterkopf behalten!

  • Moin


    Welche Konfigurationsdatei Dein PHP wirklich verwendet siehst Du hier:

    https://devanswers.co/ubuntu-php-php-ini-configuration-file/


    Bitte nicht vergessen das Änderungen erst nach einem Neustart des Apache eingelesen und übernommen werden.


    Es gibt übrigens nicht nur den Wert...

    Code
    1. upload_max_filesize

    ... sondern auch noch...

    Code
    1. post_max_size

    ... in der php.ini. Damit es rund läuft, auf jeden Fall beide Werte hochsetzen.


    Gruß Jan