Warp Settings Styles Customizer

  • Joomla 3.9.15


    Ich habe mir den Customizer genau angeschaut und es war mir dabei nicht klar geworden, welche Farbeinstellung sich wo im Frontend auswirken würde. Da habe ich einfach mal ein paar Farben stark verändert und dann im Frontend beobachtet, ob es Auswirkungen hat. Vieles hat überhaupt keine Auswirkungen gehabt. Aber irgendwie - ich kann es nicht mehr nachvollziehen - hatte ich dann einen passenden beigen Hintergrund und eine dunkelbraune Menüleiste "kreiert". Da es mir gefiel, habe ich daran nichts mehr geändert. Nach Hinzufügen neuer Menüpunkte verschwindet (nur beim Anwählen dieser Menüpunkte!) die braune Menüleiste. Die möchte ich gern wieder komplett haben.


    Und dann große Überraschung: Ich habe den JCE-Editior installiert. Wenn ich damit meine Beiträge aufrufe (im Editor und in der Vorschau!) dann habe ich den gleichen beigen Hintergrund, wie ich ihn (zufällig) als Hintergrund der Website "kreiert" habe. Im Frontend jedoch sind alle Beiträge mit weißem Hintergrund belegt. Ich hätte aber gern den Hintergrund, den ich mir eigentlich ausgesucht habe.


    Irgendwas ist im "Customizer" wohl falsch gelaufen. Ich komme nur nicht dahinter, was. Für mich sind die EInstellungen dort alles andere als wirklich selbsterklärend. Wer kann mir hier helfen?


    Damit man sehen kann, wie die braune Menüleiste beim Anwählen diverser Menüpunkte kommt und verschwindet, hier die URL zu der Website: https://sumeria.at

  • Bearbeitest du auch die richtige Vorlage? Meist kopiert man ja eine und arbeitet mit dieser?

    Zugegeben: Dieser Customizer ist nicht ganz einfach zu durchschauen. Da arbeite ich selbst oft viel mit der custom.css.


    Bei den Menüpunkten kannst du ja ein Template angeben. Ist da vielleicht bei deinen neuen Menüpunkten etwas anderes eingestellt?

  • Vielen Dank für die Frage. Ich habe es überprüft: Sämtliche Menüeinträge stehen auf "JP-Classic".

    CSS kann ich nicht. Habe ich leider nie gebraucht, da ich von der SAP-Programmierung komme. Ich muss halt zusehen, dass ich diese Website bis Anfang April fertigbekomme. Wenn ich mich erst einmal in CSS, JS oder Html einlesen würde, könnte ich ja mindestens 4 Wochen einplanen, bis ich's kapiere.

  • Auf die Schnelle kann ich nur sagen, dass bei den normalen Menüpunkten folgendes steht:

    (in Website enthaltenes Stildokument)


    Code
    1. .top-outer {background-image:url(https://sumeria.at/images/joomlaplates/bg-image.jpg)}
    2. .top-outer {background-color:#61380B}



    Und bei den "defekten" Menüpunkten:

    Code
    1. .top-outer {background-image:url(https://sumeria.at//images/bg/standarte_leiste.jpg);}
    2. .top-outer {background-color:}

    Da fehlt dann auf jeden Fall das Braun. Vielleicht hilft das bei der Suche nach der richtigen Einstellung weiter. Anaonsten müsste man das direkt im Backend analysieren...


    EDIT: Ich setze grundsätzlich den gewünschten Template-Stile als "Standard" und lasse die Template-Einstellung im jeweiligen Menüpunkt immer auf " -Standard verwenden- ". Dort trage ich nur einen Template-Stile ein, wenn er vom Standard-Stile abweicht.

    Versuche das mal!

  • Vielen Dank für die Analyse. Am Customizer kann es eigentlich nicht liegen. Denn der ändert nur den Stil, der nachweislich überall benutzt wird. Ich lege das mal auf Eis und begebe mich daran, wenn die ganze Website fertig ist; es scheint wirklich kniffelig zu werden. Vielen Dank auch für den Tip mit dem übergreifenden "Standard".


    Was leider nicht mal im Ansatz bisher gelöst werden konnte ist, dass im JCE-Editor un der Vorschau die Beiträge mit beigem Hintergrund erscheinen, im Frontend aber nicht. Rätsel über Rätsel.


    Viele Grüße

    saumhuhn

  • Danke für die anschauliche Führung. Bei mir (deutsche Version) sind die "Menüzugehörigkeiten" unter einem anderen Reiter. Aber es sind die gleichen Felder. Ich habe alle Häkchen herausgenommen. Geändert hat sich leider nichts im Frontend.

  • ..... Die Assignments werden erst sichtbar, wenn du das andere Layout einstellst, sofern vorhanden!


    Nebenbei: Du verwendest übrigens Warp 7.3.34. Aktuell wäre 7.3.37 (glaube ich)! Das hat allerdings mit deiner Problematik nichts zu tun.

    Das kannst du dir aus dem Master2-Template rausziehen und drüberkopieren, also einfach nur das Verzeichnis durchtauschen. Das alte Warp-Verzeichnis sicherheitshalber aber erst einmal nur umbennen.

  • Überraschung: Jetzt sind tatsächlich die Menüzuordnungen unten sichtbar. Ich habe alle Häkchen weggemacht und gespeichert. Ergebnis: Jetzt ist im Frontend der braune Balken nur noch sichtbar, wenn "Therapie" angeklickt wird. Ich hätte aber gern, dass der braune Balken überall besteht...


    Gruss

    Saumhuhn

  • Am 17.03. habe ich vom TE folgende PN erhalten (wahrscheinlich hat der TE eine (private) Konversation und den (öffentlichen) Thread etwas durcheinander gebracht). Ich glaube, dass das eigentlich nicht nur für mich, sondern für alle Beteiligten gedacht war, darum mache ich es hier "öffentlich" ;):

    Zitat

    Ich habe die Menüzugehörigkeit aller Styles jetzt gecheckt. Bei einem Style war korrespondierend zu einem Menüpunkt wirklich noch ein Häkchen gesetzt. Das habe ich erst nicht gesehen, weil man nicht alle Menüeinträge überblickt wegen vorhandener Schiebeleiste. Jetzt stimmt alles und: Ich habe dabei neue Zusammenhänge begriffen. Danke an alle Beteiligten für die Hilfe.


    WEnn ich jetzt noch wüßte, wie ich die Diskussion schliessen kann, täte ich es. So hoffe ich auf einen Blick eines Admins.