Akeeba - default output directory in use

  • Guten Morgen zusammen,


    bei jedem Backup über Akeeba erscheint die im Titel genannte Warnung, obwohl die von Akeeba empfohlene .htaccess-Datei zum Schutz des Zugriffs vorhanden ist. Kann ich die Meldung irgendwie abschalten?

  • Du erhältst diesen Hinweis, weil du das Standard-Verzeichnis als Ausgabeverzeichnis verwendest. Das sollte vermieden werden.

    Lege ein Verzeichnis oberhalb von Joomla an, auf welches nicht per ULR zugegriffen werden kann und stell dieses Verzeichnis in der Akeeba-Konfiguration als Ausgabeverzeichnis ein. Dann wird die Meldung verschwinden.

    Die Sicherungen werden dann ab sofort in diesem neuen Verzeichnis gespeichert. Das gilt als sicherer.


    EDIT: Achte aber darauf, dass keine Domain da drauf zugreifen kann. Oftmals werden vom Hoster irgendwelche Hilfsdomains angelegt, die auf das oberste Verzeichnis auf dem Webspace zugreifen. Solch eine Domain sollte man dann in ein weiteres zu Joomla paralleles Verzeichnis leiten. Sonst erreichst du bzgl. Sicherheit genau das Gegenteil.

  • Zunächst einmal vielen Dank für die Erläuterungen.


    Falls ich das Default directory als Speicherort belasse, bedeutet das doch, dass diese Meldung von Akeeba zwar nach wie vor erscheint; da aber die empfohlene .htaccess-Datei implemtiert ist (mein Hoster unterstützt das), ich vor Zugriffen geschützt bin, oder?

  • Ist ja keine Fehlermeldung. Lediglich ein Hinweis, wenn man auf "Backup Now" klickt. Ich halte den auch für relativ unnötig, zumindest mit der verunsichernden Überschrift.


    Meine Backup-Dateien sehen z.B. automatisch so aus (je nach verwendetem Profil)

    Code
    1. 20200421-183933-example.de_J3.9.16_Default-Backup-Profile-LZDUyxABzp0A_8Sw.jpa

    nach bisschen Spielerei mit weiteren Platzhaltern im Feld "Backup archive name", die man in der Akeeba-Doku findet. Der Postfix ändert sich eh jedesmal durch Akeeba.


    Muss man schon sehr interessiert dran sein, sich das zu erschleichen. Ist also FÜR MICH vernachlässigbar, der externe Pfad.


    EDIT: Außerdem muss man ihn dann jedesmal "kompliziert anpassen", wenn man Seite umzieht, anstatt einfach "[DEFAULT_OUTPUT]" einzutragen. Und, wenn man es vergisst, landen die Backups sonstwo...

  • Ist ja keine Fehlermeldung. Lediglich ein Hinweis, wenn man auf "Backup Now" klickt.

    Das ist mir unlängst auch aufgefallen & hatte dann auch den Link, siehe #2 gesehen & mir gedacht: :huh:


    Hab dann um es zu "entschärfen" die .jpa Datei lokal rüber geschupft.

    nach bisschen Spielerei mit weiteren Platzhaltern im Feld "Backup archive name", die man in der Akeeba-Doku findet. Der Postfix ändert sich eh jedesmal durch Akeeba.

    So Spielereichen mach ich nicht, da mach ich eher was kaputt :-)

    EDIT: Außerdem muss man ihn dann jedesmal "kompliziert anpassen", wenn man Seite umzieht, anstatt einfach "[DEFAULT_OUTPUT]" einzutragen. Und, wenn man es vergisst, landen die Backups sonstwo...

    Beruhigt mich. Danke


    Liebe Grüße

    Christine