Seitenumbruch-Slider: Warum klappen die einzelnen Seiten unterschiedlich oder nicht auf und zu?

  • Hallo,

    ich versuch mich schon den ganzen Nachmittag (incl. Suche im Netz) am Joomla Seitenumbruch als Slider.

    Auf dieser Testseite probiere ich an einem Beitrag mit 4 Seiten herum. Wenn ich "Seite 2/Slider 2" öffne, öffnet sich auch gleich Seite 3. Seite 4 bleibt immer aufgeklappt.

    Meine Frage: Muss man, was mir logisch wäre, jede Seite noch mit einem Code o.ä. abschließen? Habe dazu aber nichts gefunden.


    Danke.

  • Das sieht für mich aus, als wäre irgendwo zwischendrin ein Element nicht geschlossen oder vor dem Umbruch geöffnet und dann geschlossen. Kannst du mal in die Quelltextansicht des Artikels gehen und den Quelltext hier posten (am besten als Code in einem Spoiler, damit es nicht zu unübersichtlich wird)?

  • Hallo,


    setze es mal hier rein:

    & der Kollege guckt weiter :-)


    Liebe Grüße

    Christine


    OT: hatte vorher Spoiler, da war aber mein unterer Text nicht sichtbar.

  • Hier Anleitung zu Spoiler: Wie postet man Codes in diesem Forum, mit und ohne Spoiler

    wobei der Spoiler selbst gar nicht mehr nötig ist.


    Und ein bisschen hilfreich kann im JCE sein der Button "Display/Hide block elements" (keine Ahnung wie auf deutsch). Siehe mein Bild unten . Damit sieht man dann so ungefähr was so alles Unsichtbare im HTML-Code rumschwirren könnte. Bei dir sind es wohl DIVs, wo du den Pagebreak reingeschoben hast, anstatt danach. Das sieht man nun wieder an der "Pfad"-Angabe am unteren Rand des JCE, also deinem Bild in Post #2, dass da welche rumschwirren und Fehlerursache sein könnten.



  • Ich hab's. http://formalien.de/index.php/slidertext-2

    .... irgendwo zwischendrin ein Element nicht geschlossen oder vor dem Umbruch geöffnet und dann geschlossen. ....

    Dieser Satz hat mich dazu gebracht, den Text der Seite in einem Editor erst vom Code zu befreien und damit dann einen neuen Beitrag zu erstellen. Dann die Seitennumbrüche neu eingegeben. Es funktioniert.

    NATÜRLICH kenn ich den bisherigen Fehler nicht. Aber wenn ich eine Seite sauber erstelle, müsste es funktionieren.


    Danke.

  • Danke an alle. Ich hab mir die Fehlerseite als Kopie behalten. Werde jetzt im JCE, den ich nur heute wegen des Fehlers, installiert habe, anschauen. Da ich nicht programmieren kann, wird es für sich nicht viel bringen. Ich erkenne nur den Unterschied zwischen richtig und falsch. Hilft vielleicht, wenn ich die richtige Seite mit Umbruch erstelle.

  • Hallo Frieder! (ich mag den Namen übrigens, hatte einen Großonkel, der so hieß, aber das nur nebenbei ;-))

    Schön, dass sich das Problem in einem neuen Artikel erledigt hat. Als Faustregel: Da ein Seitenumbruch (genauso wie der Weiterlesen-Trenner) bildlich gesprochen den Artikel komplett "durchschneidet", darf er nicht innerhalb eines anderen Bereiches stehen. In deinem Artikelquelltext sehe ich mehrere Fehler, wo wahrscheinlich der Editor irgendwas falsch verstanden und deshalb den Quelltext verschoben hat. Aber ich vermute, es ist einfacher, mit einem neuen Artikel zu starten, als die händisch zu bereinigen. Du kannst dir auch den Quellcode des zweiten Artikels kopieren und in den ersten einfügen, wenn du mit dem weiterarbeiten willst.