1062 / "Duplicate entry" mit Joomla-Update auf 3.4

  • Hallo Zusammen,


    ich versuche seit einigen Tagen eine vorhandene Joomla-Installation (2.5.28) auf 3.4.0 um zu stellen.
    Das Ganze versuche ich auf einem virtuellen Server unter XAMPP (aktuelle Version) zu realisieren.


    Ich habe alle Erweiterungen, PlugIns und Module upgedatet und auf ein Standard-Template umgeschaltet.


    Unter "Komponeten => Joomla-Aktualisierung" bekomme ich das Update auf 3.4.0 angezeigt. Sobald ich aktualisieren möchte, startet die Aktualisierung problemlos. Bei ca. 86% erhalte ich jedoch jedesmal eine Fehlermeldung mit der folgenden Information:


    ======================================
    1062 - Es ist ein Fehler aufgetreten


    Duplicate entry '28' for key 'PRIMARY' SQL=INSERT INTO `rvd6n_extensions` (`extension_id`, `name`, `type`, `element`,
    `folder`, `client_id`, `enabled`, `access`, `protected`, `manifest_cache`, `params`, `custom_data`, `system_data`, `checked_out`,
    `checked_out_time`, `ordering`, `state`) VALUES (28, 'com_joomlaupdate', 'component', 'com_joomlaupdate', '', 1, 1, 0, 1,
    '{"legacy":false,"name":"com_joomlaupdate","type": "component","creationDate":"February 2012","author":"Joomla! Project","copyright":"(C) 2005 - 2015
    Open Source Matters. All rights reserved.","authorEmail":"admin@joomla.org","autho rUrl":"www.joomla.org",
    "version":"2.5.2","description":"COM_JOOMLAUPDATE_ XML_DESCRIPTION","group":""}', '{}', '', '', 0, '0000-00-00 00:00:00', 0, 0);


    Zurück zum Kontrollzentrum
    ======================================


    Das Kontrollzentrum und das übrige Backend funktionieren dann natürlich nicht mehr.


    Ich habe schon diverse Lösungs-Vorschläge ausprobiert, jedoch bisher ohne Erfolg!
    => Anpassungen der PHP.Ini unter Xampp
    => Löschen von 1.7.0-Dateien unter "administrator=>Components=>Com_Admin=>SQL=>Updates=>MySQL
    => Erst eine Update-Installation Joomla 3.3.4
    und diverse andere Vorschläge, die ich jetzt nicht mehr zusammen bekomme.


    Auch habe ich das Upgrade auch auf einem richtigen Webspeicher versucht, damit ich XAMPP als Ursache ausschließen konnte => gleiches Problem wie bei der lokalen Installation.


    Über lösungsorientierte Vorschläge würde ich mich daher sehr freuen.


    Vielen Dank!

  • Hallo Ralf,


    vielen Dank für den Link - leider bringt mich dies nicht weiter, da es nicht an der Einrichtung der XAMPP-Umgebung liegt.
    Ich habe auf meinem lokalen Rechner mehere Joomla-Installationen unter XAMPP laufen.


    Das beschriebene Problem trifft auch bei verschiedensten Providern auf und hat somit wohl nichts mit der XAMPP-Umgebung zu tun.


    Trotzdem vielen Dank!

  • Schaue in die Tabelle rvd6n_extensions und notiere dir die höchste extension_id nummer.


    Dann erhöhe den Wert um eins und führe folgenden Befehl aus
    ALTER TABLE rvd6n_extensions AUTO_INCREMENT = X;
    X ist der ermittelte Wert + 1


    Edit: Aber vor dem Update durchführen.

  • Was wurde von nachfolgender Liste umgesetzt:


    Migration / Upgrade von Joomla / Why migrate


    Warum fehlt der Crosspostinglink dorthin: http://www.joomlaportal.de/joo…mla-update-auf-3-4-a.html


    Zitat


    Für die Fragesteller:


    .......


    Wenn eine Frage in mehreren Foren gestellt wird ist es ein Gebot der Fairness, diese Fragen zu verlinken (Crossposting)


    Forenregeln

  • @ FINWICK

    Schaue in die Tabelle rvd6n_extensions und notiere dir die höchste extension_id nummer.


    Dann erhöhe den Wert um ein und führe folgenden Befehl aus
    ALTER TABLE rvd6n_extensions AUTO_INCREMENT = X;
    X ist der ermittelte Wert + 1


    Edit: Aber vor dem Update durchführen.


    Das werde ich mal ausprobieren - vielen Dank, ich melde mich, ob es geklappt hat.


    ================================
    @ -OJ-
    Ja, habe ich schon gemacht - angeblich ist die Datenbank in Ordnung!


    ================================
    @ Sieger66


    Die beschriebenen Punkte hatte ich bereits umgesetzt und ausprobiert, jedoch ohne Erfolg!
    Zur Verlinkung: Sorry, die Verlinkung hatte ich vergessen!



    Trotzdem erst einmal recht herzlichen Dank für die Tipps!

  • Schaue in die Tabelle rvd6n_extensions und notiere dir die höchste extension_id nummer.


    Dann erhöhe den Wert um ein und führe folgenden Befehl aus
    ALTER TABLE rvd6n_extensions AUTO_INCREMENT = X;
    X ist der ermittelte Wert + 1


    Edit: Aber vor dem Update durchführen.



    Hallo FINWICK,


    ich habe gerade versucht, Deine Anleitung umzusetzen.
    Ich habe in meiner rvd6n_extensions drei "ID-Bereiche" (1-28, 100-103, 200-218).
    Demnach habe ich den Wert 219 gewählt und in die Formel eingebaut (ALTER TABLE rvd6n_extensions AUTO_INCREMENT = 219; )


    Als Ergebnis habe ich folgende Meldung bekommen:
    MySQL lieferte ein leeres Resultat zurück (d. h. null Datensätze). Die Anfrage dauerte 0.0000 Sekunden.


    Die Datenbank hat also keine Änderugen durchgeführt.


    Ich habe den Befehl und PHPMyAdmin über den Reiter SQL ausgeführt (sowohl in der obersten Datenbankebene als auch direkt in der ausgewählten rvd6n_extensions.


    Habe ich da etwas fasch gemacht? - Ich kenne mich leider nicht besonders gut in SQL aus.


    Über weitere Infos/Hilfe würde ich mich daher sehr freuen!


  • Ich empfinde das nicht als Crossposting Sieger. Der User ist hier weil ich Ihn geholt habe. Und er kann nichts dafür das einige wenige in dem Sauhaufen da drüben noch supporten. Weiteres bitte per PN mit mir hier weil wir wollen ja hier nicht das Selbe was wir da drüben ständig hatten.


  • Was hat der Cache mit der Datenbankfehlermeldung zu tun?


    Wenn du so konkret danach fragst könnte ich dir keine genaue Antwort geben.
    Dies wäre meine Logische Schlussfolgerung zu diesem Problem.
    in 2.5.28 hat es wohl funktioniert mit der Datenbank.
    Demnach wird bei der Installation etwas schief gelaufen sein.
    Die Deaktivierung des Cache wurde von @emperor nicht erwähnt.
    daher meine Frage danach..

  • Ah, ok. Die Datenbankreparatur repariert jedoch den Autoincrement nicht in der Datenbank selbst und die Fehlermeldung kommt bei Tabellen mit Autoincrement nur vor, wenn das Autoincrement nicht stimmt.

  • Ich wundere mich.
    Ausgangsversion ist 2.5.28 (auch sicher geprüft unter Erweiterungen > Datenbank??).
    Update ist auf 3.x.
    Obiger MySQL-Insert stammt aus der Update-SQL für Joomla 2.5.4, sollte nach meiner Denke also gar nicht bei diesem Update versucht werden (oder täusche ich mich?).


    Die ID 28 ist auch hart kodiert in der 2.5.4-2012-03-18.sql gesetzt. Ein autoincrement gar nicht "bemüht".


    Hakts bei mir allerdings jetzt vom Wissen her aus. Vielleicht irgendwo in DB falsche Joomla-Version oder so was hinterlegt, so, dass das Update (du verwendest doch ein Update-Package?) beim falschen Update-SQL-Paket startet????


    Für mich: Welches Updatepaket ist das denn exakt? Wo kann ich es downloaden?


    Nur nebenbei:

    Zitat

    Ich habe den Befehl und PHPMyAdmin über den Reiter SQL ausgeführt (sowohl in der obersten Datenbankebene als auch direkt in der ausgewählten rvd6n_extensions.
    Habe ich da etwas fasch gemacht? - Ich kenne mich leider nicht besonders gut in SQL aus.
    Über weitere Infos/Hilfe würde ich mich daher sehr freuen!


    PHPMyAdmin > Wähle die Tabelle > Oben den Tab Operationen wählen > Dort kannst du AUTO_INCREMENT prüfen und/oder ebenfalls per Klicki ändern.

  • Eine Dreckige-Pfui-Lösung könnte doch sein einfach den Eintrag mit ID 28 erstmal zu löschen (vorher DB Backup) und dann das Upgrade zu fahren oder?


    Nach dem Update nochmal gucken ob der Eintrag wieder drin ist. Sonst eben händisch nachtragen.


    Aber ich gebe @Re:Later recht eigentlich dürfte die SQL Anweisung nicht ausgeführt werden. Also wenn 2.5.28 die Ausgangsversion ist.

  • Ich wundere mich.
    Ausgangsversion ist 2.5.28 (auch sicher geprüft unter Erweiterungen > Datenbank??).
    Update ist auf 3.x.
    Obiger MySQL-Insert stammt aus der Update-SQL für Joomla 2.5.4, sollte nach meiner Denke also gar nicht bei diesem Update versucht werden (oder täusche ich mich?).


    Die Datenbank spuckt folgende Info aus:


    Die Datenbanktabellenstruktur ist aktuell!


    Andere Informationen
    Version des Datenbankschemas (in #__schemas): 2.5.28
    Aktualisierungsversion (in #__extensions): 2.5.28
    Datenbanktreiber: mysql
    67 Datenbankänderungen wurden erfolgreich überprüft.
    49 Datenbankänderungen hatten keinen Einfluss auf die Struktur der Datenbanktabellen und wurden deshalb übersprungen.


    Update-Packet bekomme ich von Joomla vorgeschlagen:
    https://github.com/joomla/joom…Stable-Update_Package.zip