Eigenes Template kann nicht hochgeladen werden

  • Hallo zusammen,


    ich versuche gerade ein eigenes Template zu erstellen und es in der Beta 2 dann zu verwenden. Ich bin dieser Anleitung gefolgt https://www.redim.de/joomla-ra…oomla-templates-erstellen. Der Fehler den ich bekomm ist folgender:


    Code
    Warning
    JInstaller: :Install: File does not exist /var/www/html/tmp/install_5f0317d0d56ca/templateHolzmannCFD/images


    Jedoch ist der Ordner »iamges« vorhanden. Was mich etwas irritiert ist, dass hier ein »File« angegeben wird und nicht »Folder«.

    Das Template ist rudimentär und dient mir gerade nur zum Spielen. Die Struktur ist wie folgt:


    Code
    shorty@templateHolzmannCFD: tree
    .
    ├── css
    │   └── template.css
    ├── images
    ├── index.php
    └── templateDetails.xml


    Kann ich überhaupt bei der neuen Joomla Version die oben genannte »Hilfestellung« verwenden oder fehlt mir hier noch etwas essentielles?

    Tobi

  • Die Anleitung gilt für Joomla 3, eventuell noch für Joomla 2.5, aber sehr wahrscheinlich nicht mehr für Joomla 4.

    Die Syntax der XML-Datei wird wahrscheinlich eine andere sein. Vergleiche am besten mal mit dem Cassiopeia-Template.

    Mehr kann ich dazu aber leider nicht sagen.


    EDIT: Eventuell fehlen da irgendwo die Slashes?


    EDIT: Infos zu den Modulpositionen findest du beispielsweise hier: https://www.jug-koblenz.de/blo…standard-modul-positionen

  • Hallo und danke für die schnelle Rückmeldung. Die XML habe ich bereits von dem Cassiopela-Template abgeschaut.


    So sieht derzeit die XML aus. Also nichts weltbewegendes und ist die gleiche Syntax wie beim Cassiopela Template.

  • mmh...

    Es war mal so, dass ein Verzeichnis nicht leer sein durfte, da es der Installer sonst nicht installiert hat. Deshalb lag da dann meist eine leere index.html drin. Ist das Verzeichnis denn leer?

    Eigentlich ist das schon lange nicht mehr nötig, soweit ich weiß. Testen kann aber nicht schaden!

  • Wenn das Verzeichnis /templates/HolzmannCFD existiert, kann ich mir die Meldung auch nicht erklären.

    Leerzeichen werden eigentlich automatisch entfernt. Nur Sonderzeichen sind zu vermeiden.


    EDIT: Das mit dem "Leerzeichen entfernen" habe ich allerdings noch nicht mit J4 getestet.


    Zu langsam....

  • Hallo, ja das Verzeichnis exisitert, allerdings weiß ich nicht ob das hier »Case-Sensitive« ist. Ist nämlich alles klein geschrieben.
    Es kann aber auch an meinem Set-up und dem LAMP liegen. Ich hab hier öfter schon in /var/www/html/ Probleme mit den Schreibrechten gehabt.

  • Hallo, ja das Verzeichnis exisitert, allerdings weiß ich nicht ob das hier »Case-Sensitive« ist. Ist nämlich alles klein geschrieben

    Da habe ich ehrlich gesagt noch nie drauf geachtet, aber die automatische Umwandlung in Kleinbuchstaben scheint doch normal zu sein. Ebenso werden Sonderzeichen und Umlaute wohl einfach entfernt. Demnach müsste die Modifizierung (oder heißt es Modifikation) stimmen.

  • Erklärung hier

    https://github.com/joomla/joom…35#issuecomment-654312290


    Ein html/-Ordner im Templateordner wird nicht gefunden. Müssen jetzt andere klären, ob der in Joomla-4-Templates immer dabei sein muss,

    dass in #4 templateDetails.xml, kein: <languages folder="language"> ist

    Nur zur Info. Keine Erweiterung braucht diese Tags zwingend. Sie installieren dann die Sprachdateien in den /language/-Ordnern, aber wenn man sie weglässt, sucht Joomla im Erweiterungsordner selbst nach einem language-Ordner, wo es dann die Sprachdateien ausliest. Finde ich persönlich viel praktischer zu pflegen, auch(!), weil man in der Manifestdatei nur eintragen muss.

    Code
    <folder>language</folder>

    Man kann auch Sprachdateien komplett weglassen.

  • Habs jetzt selber entschieden ;-) Der krasse Abbruch ist meines Erachtens generell Nonsense hier. Noch dazu ist es ursächlich ein Info-Plugin und gar nicht die Installation selbst: https://github.com/joomla/joomla-cms/pull/30036


    Noch ein Tipp zu deinem Template, generell Erweiterungen, wennst magst. Wenn du die 2. Zeile des Manifests so änderst

    Code
    <extension type="template" client="site" method="upgrade">

    werden erneute Installationen, z.B. wegen Kleinigkeiten, nicht blockiert und man muss nicht jedes mal erst deinstallieren.

  • Ah Danke, ich arbeite mich erst etwas in das Joomla Thema rein. Hätte nicht gedacht, dass ich hier gleich auf "Bug" stoße. Ich bin eher mit OpenFOAM verbandelt. Aber nochmals danke, und auch zum Fix.

    Eine Kleinigkeit noch. Könnten wir den Pfad noch ändern? Ich hab alle in Foren abgelegten Files eigentlich wo anders lokalisiert (auch in Github angegeben). Sollte es nicht gehen, auch kein Problem, dann lass ich das in diesem Ordner.

    Tobi

  • Du kannst alles ändern. Es kann sich ja jeder selbst ein solches Test-Template basteln und Re:Later kann bei Bedarf auch seinen issue Text ändern.


    Ergänzung: Wir sind beta2 - du kannst jederzeit auf Fehler stoßen und verbesserst dein Karma, wenn du diese meldest. Im Zweifelsfall mach eine Mention für Harmageddon. Er ist der Bug-Profi

  • Hallo Christiane,

    natürlich kann man immer auf Fehler stoßen, dass ist mit der Software mit der ich Arbeite auch so. Neu-Strukturierungen bringen ab und an Fehler mit ein. Es kann sogar sein, dass diverse Fehler selbst nicht mal bei der Lauf-Zeit auftreten oder nur ganz selten. Weiß nicht ob das bei Joomla auch so problematisch ist wie in der numerischen Mathematik aber ja :)

    Deinen Vorschlag nehme ich mir zu Herzen. Ich war nur verwundert, weil ich mit Joomla jetzt noch nicht all zu viel gemacht habe.

    Grüße Tobi