Plötzlicher internal server error

  • Hallo,


    ich bitte um eure Hilfe.


    Ich habe bereits vor Monaten unsere alte Feuerwehr Homepage auf Joomla 3.x umgestellt. Die Seite hatte ich in einem Unterverzeichnis am Laufen - bin aber dann leider nicht mehr dazugekommen "weiterzubauen"! Jetzt wollte ich die Seite wieder aktivieren - bekomme aber immter einen "internal server Error"


    Ich habe schon alles versucht - die htaccess zu aktivieren oder zu deaktivieren - mod-rewrite in der config umgestellt usw. aber ich komm nicht hin!


    Die Rechte sollten mit 755 bzw. 644 auch passen!


    Könnt ihr mir bitte helfen!


    es wäre die Seite feuerwehr-westendorf.org/neu/


    Danke!

  • Da die neue Seite 3.9.14 (sollte aktualisiert werden) unter /neu liegt, stellt sich die Frage, ob oberhalb von "neu" eine .htaccess liegt? Diese würde das Vereichnis /neu und alles darunter beeinflussen. In diesem Fall einfach in htaccess.txt testweise umbenennen.


    Ansonsten: Im neuen Joomla auch einfach mal die .htaccess in htaccess.txt umbennen und darauf achten, dass in der SEO-Konfiguration im Joomla-Backend das "mod Rewrite nutzen" nicht aktiviert ist. Letzteres kannst du auch direkt in der configuration.php umstellen.


    Ansonsten: live_site (siehe configuration.php) leer lassen!

    Nutzt du ein SSL-Zertifikat bzw. möchtest du es nutzen?

    Könnte auch sein, dass in der .htaccess in /neu (falls verwendet) irgend ein Eintrag drin steht, der für das Problem sorgt.


    Falls du nicht weiter kommst, poste mal den Inhalt der .htaccess in /neu bzw. auch den der configuration.php.

    Wichtig: Mache die Zugangsdaten zur Datenbank auf jeden Fall unkenntlich!


    Ansonsten könnte ich mir das mal auf dem Webspace anschauen. Melde dich dann einfach per "Konversation"!

  • Danke für die schnelle Antwort!


    ich habe jetzt die Umleitung der Domain direkt geschaltet - ist also unter feuerwehr-westendorf.org erreichbar!


    was mich wundert - es wurde nichts verändert und plötzlich ist die Seite nicht mehr erreichbar!


    hier die config



    hier die htaccess

  • Bei Alfahosting kannst du die # stehen lassen bei RewriteBase / , es sei denn du nutzt ein Unterverzeichnis. Dann wird der Eintrag inkl. Unterverzeichnis benötigt.


    Es deutet alles auf eine falsche Serverkonfiguration hin.

    Welche (globale) PHP-Version hast du im Account eingestellt? Du kannst per .htaccess-Eintrag z.B. von dieser abweichen.

    Stellt man globale und lokale PHP-Version auf den gleichen Wert, so führt das meist zu solch einem Fehler wie bei dir.

    Allerdings hast du keine entsprechenden Einträge in der .htaccess.

    Du könntest mal eine phpinfo.php (Inhalt einfach googeln) ins Joomla-Root legen und aufrufen und dann die angezeigte PHP-Version mit der global eingestellten PHP-Version vergleichen. Wenn die unterschiedlich sind, könnte es sein, dass du noch eine php.ini nutzt, die für Probleme sorgt.


    Ansonsten kämen noch falsche Weiterleitungen in Frage. Man mus ja für mit-www und ohne-www zwei Verzeichnisse haben. In einem liegt Joomla und in das andere kommt nur eine .htaccess mit einer 301-Weiterleitung ins Joomla-Verzeichnis. Hat man SSL aktiviert, dann müssten die Einträge noch erweitert werden. Ansonsten kommt hier auch schnell mal ein 500er. Alternativ im Backend "SSL erzwingen" wählen. Aber das ist bei dir ja eh deaktiviert.

  • Upps... Das ist ja total veraltet.


    PHP 7.2 läuft im Herbst aus und aktuell wäre PHP 7.4. Das müsste man sich dann genauer anschauen. 5.5 wird schon lange nicht mehr unterstützt.


    Aber wie gesagt: Ich vermute, dass hier etwas nicht korrekt "zugeordnet" wurde. Da würde ich ansetzen.


    Möglicherweise hat auch der Hoster aus Sicherheitsgründen etwas geändert.

    Bei einigen Kunden konnte man im Account beispielsweise noch PHP 5.4 einstellen, es lief aber 5.5. So etwas in der Art könnte es auch bei dir sein.


    Wie gesagt: Mehr könnte ich nur sagen, wenn man auf den Webspace schauen könnte.

  • wenn ich jetzt in der htaccess auf php 7.4 switche mit ....(weiß die Befehlszeile nicht auswendig) funkt das dann, oder muss ich den kompletten Account auf 7.4 umstellen und die eine Seite die noch die 5.5 braucht (diese Seite wird grad auch neu gemacht) per htacces auf 5.5 zurückstufen?


    Danke, danke!

  • Du kannst für jedes Verzeichnis eine eigene PHP-Version einstellen:


    Sie darf nur nicht mit der global eingestellten PHP-Version übereinstimmen. Einfach die entsprechende # entfernen!

    Falls du ältere Drittanbieter-Erweiterungen hast, könnte es zu Fehlermeldungen kommen, die es dann aber zu lösen gilt.