Error 500 mit der .htaccess

  • versuch mal die "RewriteBase" Zeile zu aktivieren (Das Rautezeichen davor entfernen).


    liegt dein Joomla direkt im Hauptverzeichnis oder ist z.B. unter /joomla/ erreichbar?

  • @obiwan7


    Versuch mal zuerst diese Zeile:

    Code
    1. Options +FollowSymlinks


    und wenn das nicht hilft auch


    Code
    1. Options -Indexes


    auszukommentieren. Bei manchen Hostern machen die Probleme.


  • Die nicht funktionierende htaccess.txt habe ich aus der neuseten Version 3.4, die man bei joomlaos.de downloaden kann.

  • Zitat

    Die nicht funktionierende htaccess.txt habe ich aus der neuseten Version 3.4, die man bei joomlaos.de downloaden kann.


    Nebenbei: Niemand lädt noch bei joomlaos runter. Nette Leute sagen "Müllhalde" dazu.
    Nur joomla.org für Joomladownloads! Die DE-Sprache kann man ja direkt in Joomla nachinstallieren, falls das die Motivation gewesen sein sollte...


    Egal, das ist die entscheidende Stelle. Du hast seinerzeit das deaktiviert:

    Code
    1. ##Options +FollowSymLinks


    Siehe jeweils Hinweise, auch in der "neuen" htaccess


    Options:

    Code
    1. ## Can be commented out if causes errors, see notes above.
    2. Options +FollowSymlinks
    3. Options -Indexes


    # RewriteBase /
    wurde ja schon oben erwähnt, glaub ich. Das halt gelegentlich bei Providern zu aktivieren. Gatter weg.

  • die .htacceess, die ich da gepostet habe ist von Joomla 2.5.x, und die funktionierte


    Ja, und ich habe dir den Unterschied zur Joomla-3-htaccess genannt, dass in 2.5 diese Zeile von dir oder wem sonst geändert wurde:

    Zitat

    ##Options +FollowSymLinks


    Also änderst du in der Joomla-3-htaccess die Zeile analog und evtl. musst du auch die 2. Options-Zeile analog deaktivieren.


    Und die RewriteBase lässt du wie im Original, also deeaktiviert:

    # RewriteBase /