Seite duplizieren

  • Erstmal im KA bei deinem Hoster eine Subdomain einrichten.

    Z.Bsp. dublikat.example.org


    Dann einen Ordner erstellen. Z.Bsp. /dublikat

    Auf diesen Ordner die Domain zuweisen.


    Dann ein Backup deiner Seite mit Akeeba machen.


    Dieses Backup in den Ordner /dublikat schieben.

    Die Datei kickstart.php (von akeeba.com) in den Ordner schieben.


    Dann die Seite installieren:


    dublikat.example.org/kickstart.php im Browser aufrufen.


    Beim Installieren einen anderen Datenbank-Präfix vergeben.


    Dann hast du eine Kopie deiner Seite mit einer eigenen Datenbank (anderer Präfix).

  • Hallo Raimund,


    du brauchst zum einen deine Webdaten, (=die Dateien, die auf dem Server liegen. z.b. Fotos und php-Dateien) und zu anderen die dazugehörige Datenbank (dort wo z.B. die eingegeben Texte und Einstellungen gespeichert werden).


    Beide "Datenpakete" musst du kopieren und auf den neuen Server laden. Möglicherweise kannst du bei deinem Hoster eine Datensicherung anlegen, herunterladen und auf den neuen Server laden. Eine schöne Anleitung eines Hosters gibt es hier.


    Wenn du alles händisch machen möchtest, findest du hier im Forum Anleitungen.


    Wenn du es einfacher haben möchtest, gibt es die Komponente EasyJoomlaBackup.


    Am einfachsten ist jedoch mit der (mächtigen) Erweiterung AkeebaBackup. Die kostenlose Version sollte reichen. Eine Anleitung dazu findest du hier auf YouTube.



    Viel Erfolg!


    [ EDIT: Mist, zu langsam... ^^ ]

  • Hallo Elwood,

    Was ist ein KA?


    Habe die neue Domain schon kann ich die direkt da drauf legen?

    Muss ich in der PHP dann was abändern?

    Zugangsdaten usw.

    Lg Raimund


    Habe mein Hosting bei 1und1

    Da lege ich im ersten schritt einen Ordner an?

    Die Domaine ist schon da!

    verbinde den Ordner mit der Domain?

    mit Akeeba ein backup machen von der bestehenden Seite? Runterladen und in den neuen Ordner legen?

    dann die Die Datei kickstart.php auch noch in den Ordner packen?

    wo finde ich die Kickstart?


    danke und liebe Grüße Raimund


    Hallo Ihr lieben,
    Beim datenbank Import erhalte ich diese Meldung!

    Fehler

    SQL-Befehl:

    Code
    --
    -- Datenbank: `dbs553371`
    --
    CREATE DATABASE IF NOT EXISTS `dbs553371` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci

    MySQL meldet: Dokumentation

    #1044 - Benutzer 'o731977'@'%' hat keine Zugriffsberechtigung für Datenbank 'dbs553371'

    Einmal editiert, zuletzt von Indigo66 () aus folgendem Grund: 2 Beiträge von PriRai mit diesem Beitrag zusammengefügt.

  • Kickstart.php (mit dessen englischer Sprachdatei) lädst du direkt von der Akeeba-Webseite herunter, da wo du auch AkeebaBackuo findest. Nebenbei: Die Sprachdatei kommt auch mit ins Verzeichnis. Beide Datein müssen erst entpackt werden!


    AkeebaBackup sichert in der Standard-Einstellungen alle Dateien/Verzeichnisse und alle benötigten DB-Tabellen und spielt sie bei der Verwendung von Kickstart genauso ein wie die Dateien und Verzeichnisse. D.h., du darfst die DB-Tabellen nicht mehr ex- und importieren!

    Man legt halt einfach vor dem Einspielen mittels kickstart.php eine neue Datenbank beim Hoster an.


    Also entweder nutz du AkeebaBackup oder EJB oder du machst es halt manuell, auf die alte klassische Art und Weise.


    p.s. Ich gehe nicht davon aus, dass die Fehlermeldung im Zusammenhang mit kickstart.php steht, da du ja gleichzeitig fragst, wo man kickstart.php herbekommt.

  • Hallo,


    geren würde ich mich kurz einklinken, da mein Problem in der gleichen Ecke verortet ist. Beim Backupprozessmit Akeeba kickstart bekomme ich keine Verbindung mit der Datebank, um diese neu zu schreiben. In der Maske habe ich bei localhost auch die längere Variante eingegeben, die man in phpMyadmin findet. Letztendlich bekomme ich immer einen Abbruch. Ein manueller Export/Import der Datenbank war zwar erfolgreich, aber im nächsten Schritt bekommt er dann keine Anbindung an die geschriebene Datenbank.




    Benutzername, Datenbankname, Passwort und Präfix sind augenscheinlich korrekt. Was kann ich an der Stelle noch tun? Der Support von Ionos (1&1) hat mich auf die Hilfeseite verwiesen..


    Vielleicht hat jemand einen Rat für mich.

    Vielen Dank!

    Marc

  • Hallo,


    geren würde ich mich kurz einklinken, da mein Problem in der gleichen Ecke verortet ist.


    Benutzername, Datenbankname, Passwort und Präfix sind augenscheinlich korrekt. Was kann ich an der Stelle noch tun? Der Support von Ionos (1&1) hat mich auf die Hilfeseite verwiesen..


    Da steht unten in der Meldung, dass die Verbindung zur DB nicht möglich ist. Da sind immer zu 99% die Zugangsdaten nicht korrekt. Diese kannst nur du überprüfen, aber:

    Das letzte Mal, dass ich einen Account bei 1&1 hatte, war es so, dass ein externer Datenbankserver genutzt wurde. Dementsprechend musste ich diesen unter 'Database Server Host Name' einsetzen und nicht einfach "localhost". Übrprüfe das mal!

    Oder liegt die DB in deinem Tarif mittlerweile auf dem gleichen Server wie die Dateien?


    Was meinst du mit längerer Variante?


    EDIT: Die richtigen Pfade/Server usw. müssten eigentlich im control-center (heisst das noch so?) irgendwo angegeben sein.

  • Datenbank habe ich geschaft zu kopieren jetzt der zweite Schritt :) mal sehen ob ich es hin bekomme!

    Danke

    Kann es sein, dass du die verschiedenen Umzugsmethoden nun vermischst? Lese dir noch mal die oberen Beiträge genau durch!


    Entweder nutzt du eines der Tools, welches dir Dateien und Datenbank-Tabellen automatisch mitumzieht, oder du machst es auf die klassische Art, also Dateien down- und uploaden sowie DB-Tabellen ex- und importieren.

  • Benutzername, Datenbankname, Passwort und Präfix sind augenscheinlich korrekt. Was kann ich an der Stelle noch tun? Der Support von Ionos (1&1) hat mich auf die Hilfeseite verwiesen..

    Ich bin mir da nicht sicher, aber, wurde auch schon erwähnt, stimmt wohl der database server hostname nicht, und bei den User- und Databasename könnte auch was nicht passen.


    Übrigens, hier die Hilfeseite von Ionos:


  • Hallo Ihr lieben Danke für die Infos

    Habe meine Seite http://www.gardasee-urlaub.eu kopiert und dann auf http://www.europabooking.com komplett aufgespielt über FTP die Daten und die Datenbank neu angelegt.


    Jetzt aber passiert folgendes dass sie nicht stimmen da sicher in irgeneiner Einstellung die Daten geändert werden müssn dass die richtigen Ordner gefunden werden. So auch die Verbindung zu der Datenbank.


    wo uss ich da nachsehen?


    Komme auch nicht in das backoffice ;)


    Lg Raimund