Menu Einträge werden in andere übernommen

  • Hallo Leute,


    ich nutze das aktuelle Joomla und auch seit Jahren schon damit immer wieder meine Seite neu erstellt.


    Nun habe ich ein Template gefunden welches mir sehr gut gefällt und alles fertig gestellt und da fällt mir folgendes auf (und das war vorher nicht)


    Seiten Link : http://www.praxis-hoffmann.de


    Wenn man nun oben in der Menuleiste (oder andere Links aus anderen Menus) zum Beispiel "sektoraler Heilpraktiker" auswählt und danach anschließend ein Link in den Bildern auswählt wird der vorherige Link mit übernommen. Komischerweise nur in diesem Weg. Wenn man nur Menulinks aus dem oberen und mittleren Menu auswählt funktioniert es. Nur sobald man danach auf einen Link im Bild klickt kommt es zu diesem Fehler. Ruft man die Startseite auf und wählt direkt ein Link aus dem Bild dann funktionieren diese auch. Nur wenn vorher irgendein Menu Link ausgewählt wird kommt es zum Fehler.


    Kann da jemand helfen ?


    Gruß

    suschi

  • Jungs Danke schonmal für´s grübeln :-)


    Also wenn Ihr die Seite aufruft und runter zu den 5 Bildern scrollt "Unsere Test und Diagnoseverfahren" und den darunter liegenden "Read More" anklickt öffnen sich die Beiträge. Soweit so gut.


    Ich habe den Fehler lediglich mal bei dem letzten Bild "Spirometrie" gelassen. Der Fehler kommt dann wie folgt :

    Klickt man auf den Link in der oberen Menüleiste "sektoraler Heilpraktiker" öffnet der sich wie geplant in der Mitte und man kann alles schön lesen.


    Jetzt scrollt man wieder zu "Unsere Test und Diagnoseverfahren" und klickt bitte nun auf die ersten 4 Bilder. Dort funktioniert der Link wie gewohnt (ReadMore) .


    Nur wenn man jetzt die Spirometrie anklickt erscheint der Eintrag vom "sektoralen Heilpraktiker" vorweg.

    https://praxis-hoffmann.de/index.php/sektoraler-heilpraktiker/12-diagnostik/38-spirometrie?tmpl=component


    Ich kann das zwar in der Modul Einstellung manuell einstellen aber das ist etwas umständlich.


    Das gleiche Phänomen tritt auch auf bei den Bildern die quer über den Bildschirm gehen. Klickt man hier auf den "Click here" wird auch

    der Link vom sektoralen Heilpraktiker mit eingefügt : https://praxis-hoffmann.de/index.php/sektoraler-heilpraktiker#bottom-a

    Bei diesem Modul kann ich nur den Link so einfügen wie im Screenshot....



  • Zitat

    Jetzt scrollt man wieder zu "Unsere Test und Diagnoseverfahren" und klickt bitte nun auf die ersten 4 Bilder. Dort funktioniert der Link wie gewohnt (ReadMore) .



    Nur wenn man jetzt die Spirometrie anklickt erscheint der Eintrag vom "sektoralen Heilpraktiker" vorweg.

    Kann ich nicht bestätigen.

    Bei allen 'Read More'-Buttons erscheint ein Popup-Fenster mit Bild und Text. :/



  • Kann ich nicht bestätigen.

    Bei allen 'Read More'-Buttons erscheint ein Popup-Fenster mit Bild und Text. :/

    Es geht scheinbar um das Problem, dass bei einem Link der Menüpunkt in der URL "intergriert" ist, und bei den anderen "Read More"-Buttons nicht. Bewege mal den Mauszeiger über die Buttons und betrachte die Links, die aufgerufen werden sollen, sofern man sie anklicken würde! Diese unterscheiden sich.

    Das was dann beim Klicken aufgerufen wird, ist vermutlich genau das, was auch angezeigt werden soll.


    Irgendeine Zuordnung scheint da nicht zu stimmen bzw. anders zu sein?!? Oder wird da irgendetwas bei den Erweiterungen gecacht, so dass Änderungen nicht übernommen werden? Da lässt sich nur spekulieren, solange man keinen Einblick ins Backend hat.


    EDIT: Das betrifft übrigens auch den Menüpunkt "Ihr Weg zu uns".

  • Danke für den Hinweis. Vielleicht habe ich auch das Problem nicht verstanden.


    Was eventuell sein könnte:


    Im Bild 2 aus #6 hast du bei jedem Eintrag beim Link einen echten Link eingetragen.

    Nur bei 'Spirometrie' steht 'Standard':




    Weiß aber nicht, ob es daran liegt.


    Ansonsten müsste man doch mal im BE direkt schauen.