Vorgehensweise bei Umstellung J3 auf J4

  • Hallo,


    einige Fragen sind bei mir noch offen, was die Umstellung von J3 auf J4 angeht:


    1. Sollten Joomlas (produktive Seiten), die erst später mal auf J4 umgestelt werden sollen, auf der letzten 3.9 bleiben oder kann/muss man diese mit Erscheinen von 3.10 auf 3.10 updaten?


    2. Wie verhält es sich, wenn Sicherheitspatches von J3.9 oder 3.10 veröffentlich werden müssen. Werden diese jeweils weiter hochgezählt?

    Wird nur noch 3.10 mit Sicherheitspatches versehen, oder auch noch 3.9?


    Wie ist da die Planung?

  • Hallo Andreas,


    die "Planung" ist so: https://developer.joomla.org/roadmap.html, wobei:

    Zitat

    End of Support for 3.x 2 years after 3.10 is released


    Wenn ich es richtig verstehe: 3.10 und 4.0 wird zeitgleich released werden. Somit dann ja 3.9 wegfällt.


    https://docs.joomla.org/Potent…bility_issues_in_Joomla_4

    Zitat

    Wird nur noch 3.10 mit Sicherheitspatches versehen, oder auch noch 3.9?

    Solange es die 3.9er gibt, werden diese sicherlich mit Sicherheitspatches versehen.


    Mehr und genauer kann uns das zero24 sagen :-)


    So, das war jetzt nur eine Schnell-Guck-Info


    Liebe Grüße

    Christine

  • Das was Joomla 3.10 grundsätzlich macht (Update-Prechecker, Angleichungen an Joomla 4, ... usw.) ist mir bekannt. Ich kenne auch das Video vom letzten Joomla-Day von zero24.


    Bleibt die Frage, ob 3.10 ein Pflichtupdate wird und auf produktiven Seiten genutzt werden kann (Performance-Probeme?), oder nur in Verbindung mit der J4-Umstellung kurzfristig genutzt werden muss.

    Und ferner, wie das mit Sicherheitspatches gehandhabt wird, sollten welche nötig sein. 2 Jahre ist eine lange Zeit.

  • 1. Sollten Joomlas (produktive Seiten), die erst später mal auf J4 umgestelt werden sollen, auf der letzten 3.9 bleiben oder kann/muss man diese mit Erscheinen von 3.10 auf 3.10 updaten?

    Man sollte auf 3.10 updaten, verhält sich wie ein 3.9.xer update nur das die Version angehoben wird und der Pre Upgrade Checker da ist.



    2. Wie verhält es sich, wenn Sicherheitspatches von J3.9 oder 3.10 veröffentlich werden müssen. Werden diese jeweils weiter hochgezählt?

    Wird nur noch 3.10 mit Sicherheitspatches versehen, oder auch noch 3.9?

    Mit dem Release von 3.10 geht 3.9 EOL (so wie immer wenn eine neue Minor raus kommt) d.h. nur 3.10 und 4.x werden mit Patches versorgt.


    Bleibt die Frage, ob 3.10 ein Pflichtupdate wird und auf produktiven Seiten genutzt werden kann (Performance-Probeme?), oder nur in Verbindung mit der J4-Umstellung kurzfristig genutzt werden muss.

    Was für Performance Problem erwartest du denn? 3.10 ist ne 3.9+ Pre upgrade Checker und der ist "nur" im Backend im Updater.


    Und ferner, wie das mit Sicherheitspatches gehandhabt wird, sollten welche nötig sein. 2 Jahre ist eine lange Zeit.

    Wie gesagt nur 3.10 und 4.0 werden dann noch sicherheitspatche bekommen aber das ist das ganz normale vorgehen bei jeder Minor Version. Für 3.10 ist es auch nicht ausgeschlossen das noch Bug Fixes kommen nur wahrscheinlich nicht mehr so häufig wie bei 4.x ;)