"Manifestdatei kann nicht erkannt werden", was ist das Problem?

  • Hallo ich habe ein Problem bei Joomla, denn ich habe alles eingestellt bei Joomla und dann wollte ich ein Template installieren indem ich es hochlade bei Erweiterungen > Installieren aber wie es hochgeladen wurde stand dann "Manifestdatei kann nicht erkannt werden" da aber warum?


    Auch wenn ich bei Erweiterungen > Installieren auf den Button "Fügen sie die Registerkarte vom Web installieren hinzu" klicke steht dann da dort die Fehlermeldung wie oben genannt.


    Beim Datenbanktyp habe ich MySqli und bei der Version habe ich die neuste Joomla Version installiert


    Was kann das Problem sein ?


    Bei weiteren Fragen gerne Fragen

  • Ich finde in meinem Joomla keinen Fehler-Text "Manifestdatei kann nicht erkannt werden". Kann somit also auch die Stelle im Code nicht finden, wo der Fehler ausgespuckt wird.


    Ist das die exakte Meldung?


    Provider/Hoster?

  • Prüfe in Systeminformationen > Dateirechte (oder war's Schreibrechte?), ob das /tmp/-Verzeichnis beschreibbar ist.


    Prüfe generell die Schreibrechte dort.


    Stell mal die Backend-Sprache (installiert, Administrator) auf en-GB um und poste die Meldung auf englisch. Vielleicht kommt man damit weiter. Auf deutsch gibt es die Meldung so nicht im Joomla-Core.

  • wenn du die ordnerrechte meinst die sind alle auf "nicht beschreibbar". ansonst bitte um genau erklärung wo ich das finde mit tmp verzeichnis denn ich sehe keinen punkt dateirechte oder schreibrechte im reiter?


    im anhang ist die fehlermeldung auf englisch

  • (Bei mir heißt der Tabulator "Verzeichnisrechte".)


    In englisch gibt es die Meldung. Ist dann aber auch logisch mit Folgendem.


    Wenn alles rot ist, ist das schlecht. Normalerweise ist nur "configuration.php" rot. Prüfe den Eintrag "PHP-Interface für den Webserver" im ersten Tabulator. Wenn da nichts mit "cgi" steht, sondern was mit Apache-Handler (oder ähnlich) hast ein sog. "www-run"-Problem.


    Wenn der Provider nicht helfen kann, wirst wohl den FTP-Modus in der Konfiguration aktivieren müssen. Nicht empfohlen, aber zur Not...


    Siehe dann auch meinen Post #5 bzgl. Admin Tools und verdrehten Rechten.


    Bleibt natürlich die Frage, wie man so ein Joomla überhaupt updaten/bearbeiten kann, wenn alles rot ist ;-)

  • könnte es an der version liegen von joomla da ich eine webseite habe mit einer älteren joomla version und da kommt die meldung nicht?

    wenn ja wo kann man die version noch ändern?

    Aktuell ist 3.9.22 und da funktioniert auch alles wie immer, sonst hätten sich schon mehr Leute gemeldet. Wenn du beim Provider nicht nachschauen kannst, wie die Grundeinstellungen der Domain sind (z.B. entsprechende PHP-Einstellung, die das www-run-Problem nicht hat... Stichwort "cgi", fast-cgi, f-cgi oder ähnlich genannt).

  • die configuration.php ist auch rot also wie schon oben genannt alles rot. Beim ersten Tabulator "PHP-Interface für den Webserver" steht etwas mit apache handler also habe ich auch ein www-run problem.


    bei joomla hab ich noch nicht viel gemacht ausser benutzer angelegt sowie versucht dateien hochzuladen was das problem halt dann machte durch die fehlermeldung.


    wie kann ich alles von nicht beschreibar auf beschreibar ändern und was muss ich machen, dass das www-run problem behoben wird?


    danke


    Hast du irgendeinen Extension-Manager oder so installiert? So was von JoomlaShine oder ähnlich? Vielleicht auch Akeeba Admin Tools und jemand hat dort die Rechte (Datei und/oder Zugriffe) verdreht.

    nein sowas habe ich nicht installiert denn ich kann ja bei erweiterungen > installieren nichts intallieren da dann immer die fehlermeldung kommt

    Einmal editiert, zuletzt von Indigo66 () aus folgendem Grund: Ein Beitrag von lowly mit diesem Beitrag zusammengefügt.

  • den hoster weiß ich gerade nicht da ich einen auftrag mache und die joomla eingerichtet haben und ich damit die webseite bauen werde

    Dann würde ich bei denen zunächst nachfragen! Dir sollte zumindest ein Joomla zur Verfügung gestellt werden, welches keine solchen Grundprobleme mit sich bringt. Damit lässt sich so nicht arbeiten.

  • Aktuell ist 3.9.22 und da funktioniert auch alles wie immer, sonst hätten sich schon mehr Leute gemeldet. Wenn du beim Provider nicht nachschauen kannst, wie die Grundeinstellungen der Domain sind (z.B. entsprechende PHP-Einstellung, die das www-run-Problem nicht hat... Stichwort "cgi", fast-cgi, f-cgi oder ähnlich genannt).

    ok danke ich werde mit denen reden bezüglich dem provider denn so kann das nicht gehen. was genau muss ich beim provider dann schauen das eingeschaltet/verfügbar ist oder so? und was kann ich machen das die rechte von "Nicht beschreibar" auf beschreibar geschaltet werden?

  • was kann ich machen das die rechte von "Nicht beschreibar" auf beschreibar geschaltet werden?

    Wenns mal nicht mehr "Apache-Handler" ist, sollte sich das von alleine lösen.


    Wie gesagt, das ist ein Problem, das du nur über die Provider-Oberfläche lösen kannst.


    Manche haben ein Tool, wo man die Dateien/Ordner auf "PHP-User" im Sammellauf umstellen kann, wenn es keine Domaineinstellung dafür gibt. Dann hast aber umgekehrt das Problem, dass man nicht mehr per FTP zugreifen kann.


    Bei manchen sind zusätzlich die Rechte Ordner/Dateien nicht auf wie empfohlen 0755/0644 eingestellt. Das ist nicht immer ein Problem, kann es aber sein für einen problemlosen Joomla-Betrieb.


    Ich empfehle Kunden in so einem Fall den Providerwechsel ;-) . Provider, der eben gleich richtig für Blödies wie wir macht. Paar Haus-und-Wiesen-Provider antworten z.B. gerne, dass dieses "cgi" ganz dramatisches Sicherheitsrisiko ist, weil das vor 15 Jahren mal der Fall war...

  • Das ist von Provider zu Provider anders. Eigentlich haben (fast) alle soweiso nur noch Einstellungen/Konfigurationen, die richtig sind für stinknormale CMS wie Joomla, sozusagen.


    Andere sind eben gar nicht ausgerichtet auf so was und bieten komplizierte Lösungen.


    Wieder andere sind komplett dämlich.


    Wende dich am besten an den Provider oder schaue, ob sie eine Hilfe dazu haben, vielleicht sogar spezifisch zu Joomla.


    Bei dieser PHP-Einstellung wäre z.B. der erste ausgegraute Eintrag ein Fehler, nicht nur der Version 7.1 wegen



    Aber das steht nicht bei jedem Provider explizit so da...