PHP-Version 7.2.33

  • Hallo liebe Foris,


    ich bin ganz neu hier.

    Im Rahmen unserer Tierschutzarbeit benutzen wir Joomla.

    Leider hat unser Admin letztes Jahr seine Arbeit eingestellt und ich bekomme es gerade hin,

    Beiträge auf die HP zu stellen.


    Ansonsten bin ich absoluter Laie.


    Nun habe ich folgende Warnungen bekommen:


    1)

    Warnung


    Die verwendete PHP-Version „7.2.33“ erhält, vom PHP-Projekt, nur noch Sicherheitsaktualisierungen. Das bedeutet, dass diese PHP-Version bald nicht mehr unterstützt wird. Es wird empfohlen zeitnah eine Aktualisierung auf eine aktuellere PHP-Version durchzuführen, bevor die verwendete Version zum 30.11.2020 nicht mehr aktualisiert wird. Joomla! wird mit einer neueren PHP-Version schneller und sicherer sein. Der Webhoster kann bei der Aktualisierung unterstützen.


    2)

    Warnung

    Einige Aktualisierungsquellen sind deaktiviert. Bitte diese unter Aktualisierungsquellen überprüfen.

    Vor der Aktualisierung ist zu prüfen, dass diese auch kompatibel mit der eingesetzten Joomla!-Installation ist.

    Es wird dringend empfohlen, vor der Aktualisierung ein Backup der Installation zu erstellen.


    Und dann die Auführungen im angehängten Foto.




    Könnt ihr mir professionelle Hilfe empfehlen, an wen könnte ich mich diesbezüglich wenden.



    Herzlichen Dank


    Sabine




  • Die PHP-Version lässt sich üblicherweise in der Verwaltungsoberfläche des Web-Hosters einstellen - bei manchen Hostern kann das durchaus sehr versteckt sein, so dass man da gerne auch den Support belästigen darf.

    Die Warnung bei den Aktualisierungsquellen kannst Du erstmal ignorieren. Die darunter angezeigten Aktualisierungen solltest Du einzeln anklicken und dann rechts oben den "Aktualisieren" Button betätigen.


    Ganz unten am rechten Rand siehst Du die installierte Joomla-Version. Die ist mit 3.9.5 reichlich veraltet - aktuell ist die 3.9.22. Unter Komponenten > Joomla-Aktualisierung kannst Du den Update machen.

  • Leider hat unser Admin letztes Jahr seine Arbeit eingestellt und ich bekomme es gerade hin,

    Beiträge auf die HP zu stellen.

    Hallo Sabine,

    ich kenne eure Seite. Ich habe euch damals geholfen, die Seite neu aufzusetzten.


    Schade, dass du nicht von deiner Vorgängerin eingewiesen worden bist.


    Bevor du aber Updates oder andere Änderungen an der Seite machst, empfehle ich dringen ein Backup

    der Seite und Datenbank zu machen. Steht ja auch in der Meldung.


    Empfehlen könnte ich Akeeba-Backup. Gibt aber noch andere Backupextensions.

  • Erledigt!


    Ich habe:

    - erstmal mehrere Backups angefertigt, heruntergeladen und gesichert

    - Joomla upgedatet.


    Allerdings altes, bekanntes Problem: Es ist bereits die aktuellste Version installiert:



    Für Ungeübte recht verwirrend. Man muss wissen: Auf 'Auf Aktualisierungen prüfen' klicken.

    Dann erscheint die richtige Zuordnung:



    Dann alle Extensions upgedatet. Beim ersten Anzeigen war Akeeba nicht dabei.

    Erst beim Klick auf Überprüfen wurde auch Akeeba angezeigt.


    Dann noch beim Hoster die PHP-Version auf 7.4.12 gestellt.


    Dann die .htaccess entsprechend den Hinweisen angepasst.

    Und die Filter eingestellt.


    Nochmals Backups angefertigt.

    Bisher läuft die Seite ohne Probleme, keine Meldungen mehr:






    Vielleicht noch einige Tipps:


    - Benutzerkonten von ehemaligen Mitgliedern würde ich löschen

    - Als Verantwortliche musst du die Seite regelmäßig auf Updates überprüfen

    (Im Plugin 'System-Joomla!-Aktualisierungsmitteilung' deine EMail-Adresse eintragen):




    - Dann bekommst du automatisch eine Mail bei einer neuen Joomla-Version.


    EDIT: Bin ja blöd! Habe ja deine Mail vom Benutzerkonto.

    Habe ich gerade eingetragen!

    Also erledigt! ;)



    - Vor Updates immer Backups anfertigen


    Es ist schon eine verantwortungsvolle Aufgabe!


    Kannst dich aber melden, wenn es irgendwo hakt! ;)

  • Hallo Elwood,


    vielen Dank, am Interesse fehlt es mir nicht, nur leider an der Zeit. :rolleyes:


    Neben meinem Beruf füllt mich das Ehrenamt im Tierschutz schon vollkommen aus, deshalb hoffe ich auch,

    dass sich bald ein anderes Teammitglied von Verein hier einarbeiten wird.


    Ich habe nun noch folgende Mitteilung erhalten:


    "Joomla! ‎3.9.23 ist verfügbar:

    und

    2 Erweiterungsaktualisierung(en) verfügbar"


    Denke, da müssen dann auch wieder die Backups erfolgen.


    Wäre ganz toll, wenn du es dir nochmal anschauen könntest.


    Herzliche Grüße und 1000 Dank


    Sabine

  • So sollte es sein und funktionieren. Bin froh, dass ich es selbst durchgeführt habe.


    Mir ist es tatsächlich gelungen, dass das Update abgeschmiert ist. Dann ging nix mehr.

    Akeeba-Backup hat offline funktioniert, habe es aber beim Hoster nicht zum laufen gebracht.


    Zwischenzeitlich habe ich es auf meinem Testserver ohne Probleme installiert, damit die Seite

    wieder erreichbar ist.


    Letztendlich habe ich es mit dem Backup des Hosters probiert. Damit war die

    (alte) Seite wieder erreichbar.


    Nochmals Backup angefertigt und Update angestoßen.


    Jetzt lief es problemlos durch.


    Seite ist wieder erreichbar und aktuell! :)


    Zum Glück der Hunde :!: