Seite offline im Frontend mit Fehlermeldung: 0 - Call to undefined method IconicModLatestView::getModuleHeader()

  • Hallo Foris,

    erstmal weiß ich r nicht nicht ob das Thema hier richtig ist - bitte sonst verschieben??!!

    Ich bekomme eine für mich unverständliche Fehlermeldung beim Aufrufen der Seite https://www.dvg-s-h.de/

    Ich habe vor kurzem die PHP Version von 7.3 auf 7.4 umgestellt. Ich meine eigentlich hat alles danach einwandfrei funktioniert,
    Heute morgen habe ich dann JEvents upgedatet und seit dem bekomme ich beim Aufrufen der Seite nur noch diese Fehlermeldung:

    0 - Call to undefined method IconicModLatestView::getModuleHeader()


    Ob das allerdings mit dem Update zusammenhängt kann ich nicht sagen.
    Ich habe dann in der Konfiguration unter Server Fehler berichten auf Maximum gestellt und unter System Fehlersuche auf ja.
    Dort habe ich diese Infos erhalten:

    Call to undefined method IconicModLatestView::getModuleHeader()

    Call stack
    #FunctionLocation
    1()JROOT/modules/mod_jevents_latest/tmpl/iconic/latest.php:95
    2IconicModLatestView->displayLatestEvents()JROOT/modules/mod_jevents_latest/mod_jevents_latest.php:54
    3include()JROOT/libraries/src/Helper/ModuleHelper.php:200
    4Joomla\CMS\Helper\ModuleHelper::renderModule()JROOT/libraries/src/Document/Renderer/Html/ModuleRenderer.php:98
    5Joomla\CMS\Document\Renderer\Html\ModuleRenderer->render()JROOT/libraries/src/Document/Renderer/Html/ModulesRenderer.php:47
    6Joomla\CMS\Document\Renderer\Html\ModulesRenderer->render()JROOT/libraries/src/Document/HtmlDocument.php:501
    7Joomla\CMS\Document\HtmlDocument->getBuffer()JROOT/libraries/src/Document/HtmlDocument.php:793
    8Joomla\CMS\Document\HtmlDocument->_renderTemplate()JROOT/libraries/src/Document/HtmlDocument.php:567
    9Joomla\CMS\Document\HtmlDocument->render()JROOT/libraries/src/Application/CMSApplication.php:1044
    10Joomla\CMS\Application\CMSApplication->render()JROOT/libraries/src/Application/SiteApplication.php:778
    11Joomla\CMS\Application\SiteApplication->render()JROOT/libraries/src/Application/CMSApplication.php:202
    12Joomla\CMS\Application\CMSApplication->execute()JROOT/index.php:49


    Und oben auf der Sete erscheint noch diese Meldung:
    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgSystemTabulizerCSS has a deprecated constructor in /homepages/42/d32724779/htdocs/Joomla/jupgrade/plugins/system/tabulizercss/tabulizercss.php on line 22

    Da ich schnöder "Verwalter" der Seite bin übersteigt das mein Wissen - kann mir jemand weiterhelfen?!
    Das backend funktioniert einwandfrei.


    Hier noch die Systeminformationen

    EinstellungWert
    PHP erstellt fürLinux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux
    Database Typemysql
    Datenbankversion5.5.62-log
    Datenbankzeichensatzutf8_general_ci
    Datenbankverbindungszeichensatzutf8mb4_general_ci
    PHP-Version7.4.13
    WebserverApache
    PHP-Interface für den Webservercgi-fcgi
    Joomla!-VersionJoomla! 3.9.23 Stable [ Amani ] 24-November-2020 15:00 GMT
    Joomla!-Plattform-VersionJoomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
    BrowsererkennungMozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36


  • Ich habe vor kurzem die PHP Version von 7.3 auf 7.4 umgestellt. Ich meine eigentlich hat alles danach einwandfrei funktioniert,

    Ich gehe davon aus, dass es an der PHP Version liegt. Zunächst hat es wahrscheinlich funktioniert, weil noch etwas im Cache war.


    Gibt es bei dir das Modul "IconicModLatest" und was passiert, wenn du das deaktivierst?