Problem beim Update von Komponenten bei lokaler Joomla Website

  • Ein freundliches Hallo in die Runde!


    Zur Weiterentwicklung und zu Testzwecken habe ich eine lokale Joomla Website auf meinem Mac eingerichtet. Ich habe hierfür MAMP PRO genutzt und meine Online Website 1 zu 1 gespiegelt. Bisher lief hierbei alles ohne Probleme. Die lokale Version hat sich zum Testen bewährt.


    Auf meiner Online Website habe ich gestern einige Updates für mehrere Komponenten durchgeführt. Lief alles prima und ohne Probleme. Auf meiner lokalen Website kann ich die Updates leider nicht durchführen. Sie brechen alle ab. Ich erhalte hierbei folgende Fehlermeldung von MAMP PRO:



    Im Server Fehler Log von MAMP PRO werden die folgenden Nachrichten angezeigt:


    Zitat
    [Mon Jan 04 07:57:19.279278 2021] [fastcgi:error] [pid 7883] [client ::1:49896] FastCGI: comm with server "/Applications/MAMP/fcgi-bin/php7.3.24.fcgi" aborted: idle timeout (30 sec), referer: http://localhostaddress/website_address ... iew=update

    [Mon Jan 04 07:57:19.279548 2021] [fastcgi:error] [pid 7883] [client ::1:49896] FastCGI: incomplete headers (0 bytes) received from server "/Applications/MAMP/fcgi-bin/php7.3.24.fcgi", referer: http://localhostaddress/website_address ... iew=update


    Woran kann dies liegen und was kann ich tun?


    Vielen Dank für Eure Hilfe!!!


    Beste Grüße

    Schiko


    Zusätzlich habe ich dies hier im PHP error log gefunden:


    Zitat

    [04-Jan-2021 08:19:51 Europe/Berlin] PHP Notice: Undefined index: extractdir in /Users/xxx_user_name_xxx/Sites/xxx_localhost_name_xxx/xxx_website_name_xxx/administrator/components/com_installer/models/update.php on line 501