1142 SELECT command denied to user

  • Hallo

    Ich bin neu im Forum, arbeite aber schon sei Jahren mit Joomla und habe schon viele Seiten damit erstellt.


    Nun habe ich ein Problem beim Aufruf der Globalen Freigabe im Backend einer Seite. Ich erhalte ich die Fehlermeldung:

    1142 SELECT command denied to user 'xxx'@'localhost' for table '01'

    In der Konsole sehe ich einen "500 Internal Server Error".


    Alle anderen Seiten im Backend kann ich aufrufen.

    Ich habe die com_checkin angesehen und festgestellt, dass die meisten Dateien am 11.4.2021 aktualisiert wurden.

    Bei anderen Seiten, die ich betreue, ist das ebenfalls so, doch die Globale Freigabe lässt sich dort aufrufen.


    Kann mir jemand weiterhelfen?


    Vielen Dank im voraus.

    LG Vreni

  • Danke Elwood und sorry für die Anfängerfehler.

    Hier die weiteren Angaben:


    Joomla 3.9.26

    PHP 7.3.27

    Template: protostar kopiert und ein custom-Template gemacht

    Komponenten:

    • accordeon menu ck
    • acy mailing
    • chronoforms6
    • jce editor
    • jdownloads
    • osmap free

    Danke an @admin für's Verschieben!


    Gruss Vreni

  • Eventuell mal komplett und überall ausloggen, Caches usw. leeren und erneut einloggen!

    Hat nichts gebracht.


    Vielleicht wäre ein Klick auf 'Datenbank reparieren' auch hilfreich:


    Hat auch nicht funktioniert.


    Der User xxx darf in der Datenbank localhost in der Tabelle 01 nicht den Befehl Select ausführen. Mehr sagt der Fehler nicht, und der hat auch nichts mit Joomla zu tun. In Joomla gibt es keine Tabelle 01. Vielleicht ist da etwas in der DB gecrasht, kannst du dir in phpMyAdmin ansehen.

    Habe die DB angeschaut. Es gibt keine Tabelle 01 und ich sehe auch sonst nichts Auffälliges. Warum wird denn ein SELECT auf diese Tabelle gemacht?

  • Läuft die Webseite lokal oder auf einem Webserver? Wenn lokal: Starte Apache/MySQL mal neu!

    Hast du über phpmyadmin etwas geändert?

    Kannst du ausfindig machen, wozu die Tabelle gehört (über phpmyadmin)?

    Hast du irgendwo etwas an den Usern geändert oder an der Datenbank?

  • Zuerst Backup anfertigen mit zB Akeeba. Wenn das geht.


    Versuche mal, die DB in der Tabellenansicht (also in phpMyAdmin links oben auf die DB klicken, in der das Joomla ist, die Tabellen sollten dann in der Mitte untereinander stehen), zu exportieren.


    Dann eine neue DB anlegen, Daten notieren, dort die Joomla DB importieren, und die geänderten Daten in die configuration.php im Joomla Root eintragen.