Kein Zugriff auf Inhalte der Seite

  • Hallo,


    ich habe ein größeres Problem mit meiner Webseite und hoffe, das hier unter den Profis mir jemand ein paar Empfehlungen geben kann.

    Da es mich schon lange störte, das in der Adresse bei den Browsern immer die Meldung erscheint das die Seite nicht sicher ist. Im Browser von Safari wird diese Meldung auch noch in roter Schrift angezeigt was natürlich auch Besucher abschreckt.

    Mein Provider stellt seinen Kunden ein Zertifikat zur Verfügung.

    Nun habe ich im Backend meiner Seite unter SYSTEM ---> Konfiguration----> Server den Eintrag

    HTTPs erzwingen ---Gesamte Webseite eingestellt.

    Als PHP Version war zuvor PHP 7.4 installiert und vom Provider wurde diese Version auf PHP 7.3

    zurückgesetzt, da ich dummerweise unter „Fehler berichten“ Maximum eingestellt hatte und somit keinerlei Zugriff mehr auf die gesamte Seite hatte. Nun funktioniert die Seite nicht wirklich.

    Die Homeseite lässt sich starten und bekomme da auch die Fehlermeldung ausgegeben, jedoch ist es nicht möglich auf die Inhalte im Frontend der Seite zuzugreifen, dann wird eine weitere Fehlermeldung ausgegeben: Server 443.

    Wenn sich jemand diese Fehlermeldung gern mal ansehen möchte, hier mal die Adresse zur Seite.

    „ schnitzen-hr.de “


    Gruß Herbert63

    PS: An der PhP.ini und an der htaccess.txt habe ich nichts geändert.

  • Hast du im Backend in der SEO-Konfiguration die beiden ersten Haken gesetzt oder nur den ersten Haken?

    Solltest du den zweiten Haken gesetzt haben, dann müsstest du die htaccess.txt umbenennen in .htaccess.

    Wichtig bei der Benennung ist: Voranstehender Punkt und keine Dateiendung


    Oder du entfernst den zweiten Haken, dann brauchst du die htaccess.txt nicht umbenennen.


    Falls das nicht korrekt konfiguriert ist, können keine Unterseiten aufgerufen werden, meist ein 404. Bei dir ist es allerdings etwas anders. Überprüfe das dennoch als erstes!


    Joomla 3.9.5 ist alles andere als aktuell. Möglicherweise hast du Erweiterungen installiert, die auch nicht aktuell sind. Das führt dann häufig zu Fehlern, die man durch aktualisieren beheben kann. Das ist besser als die PHP-Version zurückzusetzen.


    Wichtig: Vor Aktualisierungen und größeren Änderungen immer ein funktionsfähiges Backup erstellen (Dateien und Datenbank)!


    Nebenbei: Wenn du gewisse Einstellungen in der Konfiguration im Backend nicht mehr ändern kannst, weil dir der Zugriff verweigert wird, dann kannst du das direkt in der configuration.php im Joomla-Verzeichnis ändern.

    Zum Speichern musst du in der Regel die Dateirechte der configuration.php ändern, was Joomla sonst automatisch macht, wenn du die Änderungen direkt im Backend vornimmst. (Sicherheitsmaßnahme)

    Und wenn du mal in der configuration.php drin sein solltest, schau auch gleich nach, ob bei $live_site='' eventuell eine Domain eingetragen ist. Diese dann entfernen! Also nur $live_site='' stehen lassen!

  • Du kannst mal Fehler berichten auf keine stellen.


    Das Problem ist das Template. Es ist wohl nicht PHP 7.4 tauglich.


    Es ist auch ein Artisteer-Template.


    Aaaaber, sehe gerade:


    Deine Joomla-Version ist 3.9.5!


    Deshalb auch die Zurücksetzung auf PHP 7.3


    3.9.5 ist von April 2019. Da gab es PHP 7.4 noch nicht.

    Vielleicht deshalb die Probleme.


    Aktuell ist 3.9.26.


    Ich würde ein Backup machen und dann erstmal die Seite auf 3.9.26 und alle Extensions auf den neuesten Stand

    bringen.


    Und https auch zurück auf keine stellen.


    Nach dem Update erneut versuchen.



  • In der functions.php in der Zeile 194 ist «continue» geschrieben. Schreibe einfach noch eine 2 dahinten, also « continue 2 »


    Ich hatte früher mal einen Artisteer Template und bin mir eigentlich sicher, dass dies die Lösung ist, da ich dieses Problem auch hatte.

    Betrifft die Fehlermeldung auf der Seite.


    Hast du es schon versucht ?

  • Hallo Ihr lieben,


    herzlichen Dank für Eure Empfehlungen und Hinweise. Ich werde mir Eure Antworten auf meiner Seite noch mal in Ruhe ansehen was da falsch gelaufen sein könnte.

    Joomla und auch alle anderen installierten Module sind auf dem neusten Stand und die Seite lief ja bisher ohne Einschränkungen. Wenn ich es nicht hin bekomme, kann ich ja immer noch eines meiner gespeicherten Backups wieder aufspielen und die einzelnen Schritte durchlaufen bis ich die Fehlermeldung erhalte. So sehe ich vermutlich am besten, durch was die Fehlermeldung hervorgerufen wird.


    Gruß Herbert63

  • Joomla und auch alle anderen installierten Module sind auf dem neusten Stand und die Seite lief ja bisher ohne Einschränkungen.

    Vielleicht werden die Aktualisierungen bei dir aus irgendeinem Grund nicht angezeigt.

    Joomla 3.9.26 ist die derzeit aktuelle Version. Du nutzt Joomla 3.9.5. Diese Version ist start veraltet (April 2019).


    Eventuell mal im Aktualisierungsmanager auf "Leeren" klicken! Werden dann mögliche Updates angezeigt?

  • Hallo,

    habe den Fehler gefunden. In der SEO war die Option „URL Rewirte nutzen „aktiviert jedoch die htaccess nicht mit einem Punkt vorweg gekennzeichnet. Habe die Datei auch so gelassen und nur die Option deaktiviert.

    War mit Sicherheit ein Fehler den ich selbst verursacht hatte.

    Das Frontend steht nun in vollem Umfang wieder zur Verfügung und habe auch gleich einen neues Backup erstellt.

    Noch mal besten Dank an Alle.


    Gruß Herbert63

  • jedoch die htaccess nicht mit einem Punkt vorweg gekennzeichnet.

    Beachte, dass du das .txt am Ende der htaccess auch weg nimmst.


    Geht z.B. mit dem FileZilla sehr gut. Sieht dann so aus:




    Das Frontend steht nun in vollem Umfang wieder zur Verfügung und habe auch gleich einen neues Backup erstellt.

    Vergiss auch nicht das Joomla-Update zu fahren.


    Du kannst auch über 'Komponenten'-'Joomla-Aktualisierung':



    die Joomla-Paketdatei Joomla_3.9.x_to_3.9.26-Stable-Patch_Package.zip

    nachinstallieren.


    Ggf. dann noch vielleicht auf 'Datenbank reparieren' klicken.

  • Hallo Elwood,


    habe mal nachgesehen. Wie auch immer, habe ich 2 mal diese htaccess Datei einmal ohne Endung und Punkt vorweg und einmal als txt Datei. Ich kann nicht einmal sagen, wie das mit den beiden Dateien zustande gekommen ist. Sicher habe ich da mal was probieren wollen. hmm

    Das Joomla-Update werde ich natürlich machen.


    Gruß Herbert63

  • Ich kann nicht einmal sagen, wie das mit den beiden Dateien zustande gekommen ist.


    Die htaccess.txt wird bei einem Joomla-Update aktuallisiert bzw. "überschrieben".


    Die .htaccess hast du vermutlich "selbst erstellt" bzw. ist z.B. eine von dir umbenannte htaccess.txt

  • Hallo Elwood,

    habe die Aktualisierung auf die Version 3.9.26 durchgeführt. Funktioniert allesund brauchte an der Datenbank nichts zu machen.

    Muss jetzt nur noch ein frisches Backup machen.


    Gruß Herbert63


    Hallo,

    mit dem Joomla Update 3.9.26 bin ich darauf aufmerksam gemacht worden einige Anpassungen vorzunehmen, die ich hier auch anzeigen möchte. Denn es ist mit irgendwie nicht nachvollziehbar das man von einer Joomla Version 3.9.5 ein Update zu einer Version 3.9.26 macht.


    .htaccess Aktualisierung in Bezug auf Verzeichniseinträge

    Seit Version: 3.9.22

    Vor 3.9.22 enthielt die Standarddatei htaccess.txt fehlerhaften Code zum Deaktivieren von Verzeichnisauflistungen. Das Sicherheitsteam empfiehlt, die notwendigen Änderungen manuell auf jede bestehende .htaccess-Datei anzuwenden, da diese Datei nicht automatisch aktualisiert werden kann.

    Alter Code:

    Code
    <IfModule autoindex>  IndexIgnore *
    </IfModule>

    Neuer Code:

    Code
    <IfModule mod_autoindex.c>  IndexIgnore *
    </IfModule>

    Hinweis ausblenden
    Zusätzlicher XSS-Schutz für die Verwendung von SVG-Dateien

    Seit Version: 3.9.21

    Seit 3.9.21 wird Joomla mit einer zusätzlichen Sicherheitsregel in der Standard htaccess.txt ausgeliefert. Diese Regel schützt Benutzer von svg-Dateien vor potentiellen Cross-Site-Scripting (XSS)-Schwachstellen.

    Das Sicherheitsteam empfiehlt, die notwendigen Änderungen manuell auf die bestehende .htaccess-Datei anzuwenden, da diese Datei nicht automatisch aktualisiert werden kann.

    Änderungen für .htaccess

    Code
    <FilesMatch "\.svg$">  <IfModule mod_headers.c>    Header always set Content-Security-Policy "script-src 'none'"  </IfModule>
    </FilesMatch>

    Zurzeit ist uns keine Methode zur bedingten Konfiguration dieser Regel auf IIS-Webservern bekannt, bitte kontaktieren Sie Ihren Hosting-Provider für weitere Unterstützung.

    Hinweis ausblenden


    Gruß Herbert63

  • In der SEO war die Option „URL Rewirte nutzen „aktiviert jedoch die htaccess nicht mit einem Punkt vorweg gekennzeichnet. Habe die Datei auch so gelassen und nur die Option deaktiviert.

    Wenn du die Option (zweiter Haken in der SEO-Konfiguration) sowieso deaktivert hast, und gar keine .htaccess nutzt, dann brauchen dich allerdings die Nachinstallationshinweise bzgl. der .htaccess gar nicht zu interessieren.

    Denn die Vorlage htaccess.txt wird immer mitaktualisiert. Und solltest du mal die .htaccess nutzen wollen bzw. müssen, dann einfach die htaccess.txt zu .htaccess umbenennen! Dann stehen die Änderungen ja eh schon mit drin.


    Die Hinweise betreffen nur .htaccess-Dateien, die bei der entsprechenden Joomla-Aktualisierung bereits existierten. Denn diese können nicht über ein Update aktualisiert werden und wären dann manuell zu ergänzen.

  • Hallo,


    habe nun alle Änderungen in der htaccess vorgenommen, wie es das System vorgeschlagen hat, da diese Datei nicht automatisch aktualisiert werden kann.


    Ferner habe ich die htaccess.txt umbenannt in .htaccess und im Sytem (SEO)

    „URL-Rewirte nutzen“ aktiviert.


    Das Ergebnis war, das ich mit dieser Einstellung wiederum keinen Zugriff auf die Inhalte der Seite habe. Es wird mir lediglich nur die Homeseite angezeigt. Ist mir irgendwie ein Rätsel.

    Sobald ich den Punkt vor der Datei entferne, geht alles wieder.


    Nun habe ich noch das Problem in der URL das index.php auszublenden. Das geht, jedoch nur wenn ich die htaccess umbenenne und in der SEO Rewirte nutze.

  • Nun habe ich noch das Problem in der URL das index.php auszublenden. Das geht, jedoch nur wenn ich die htaccess umbenenne und in der SEO Rewirte nutze.

    Wie gesagt, es gibt die Vorlage als Textdatei:

    htaccess.txt


    Und es gibt die Datei, die vom Webserver abgearbeitet wird:

    .htaccess


    Hast du auch die ersten beiden Haken gesetzt oder ev. nur den zweiten Haken?

    Dann sollte es funktionieren.


    Ansonsten könnte ich mir noch eine Cache-Problematik vorstellen. Die Caches mal leeren nach einer Änderung.


    Bei einigen Webhostern wird der EIntrag RewriteBase / in der .htaccess benötigt, auch dann, wenn man nicht mit Unterverzeichnissen arbeitet. Entferne also mal die # vor dem EIntrag! (ansonsten ist es lediglich ein Kommentar)