amp Format Problem bei Indexierung

  • Hallo Zusammen,

    ich habe eine Website erstellt, diese wollte ich nun bei Google über die Webmaster Tools indexieren. Sitemap wird erfolgreich eingelesen mit allen Links.

    Dann kommt allerdings das Problem, dass beim Indexierungsversuch ein Serverfehler 500 kommt.

    Das liegt daran, dass Google an den Link der Hauptseite https://nostalgie-entertainment.de/de (mehrsprachige Seite) das ?format=amp anhängt.

    Diese Seite existiert natürlich nicht...

    Wie kann ich das beheben. Google hat selbständig den Mobilen Trawler bevorzugt, liegt hier das Problem?

    Ich arbeite mit einem Template auf Helix Ultimate Basis und Pagebuilder Quix Pro. Habe in den Optionen amp auf enanbled gestellt.


    Habe anbei mal die Fehlerseiten aus Google Webmastertools angehangen als auch die Fehlermeldung die angezeigt wird, wenn man die URL mit dem amp-Zusatz aufruft.


    Wäre super, wenn ihr eine Lösung für mich habt.

  • Probier mal das hier aus, damit man sieht, wo das format=amp überhaupt durchläuft:

    Google hat selbständig den Mobilen Trawler bevorzugt, liegt hier das Problem?

    Das ist normal. Machen die schon seit einiger Zeit so.

    Das liegt daran, dass Google an den Link der Hauptseite https://nostalgie-entertainment.de/de (mehrsprachige Seite) das ?format=amp anhängt.

    Das macht die Suchmaschine, weil sich in deinem Quelltext die Zeile

    Code
    <link href="https://nostalgie-entertainment.de/de?format=amp" rel="amphtml" />

    befindet.

  • Vielen Dank für Deine Hinweise.

    War leider in Urlaub, daher kann ich mich erst jetzt melden.


    Der Quelltext <link href="https://nostalgie-entertainment.de/de?format=amp" rel="amphtml" />

    wird entweder im Helix oder im Template erzeugt (gehe ich mal von aus) . Ich habe nur noch nicht herausgefunden wo... in der Index.php im Template sehe ich jedenfalls nix...

    Kannst Du mir da auch noch einen Tipp geben? Dann werde ich die Zeile löschen - das sollte mein Problem beheben.

  • ch habe nur noch nicht herausgefunden wo... in der Index.php im Template sehe ich jedenfalls nix...

    Da gehört es ja auch eigentlich nicht hin.


    Man kann nur vermuten, dass es in der Datei components\com_quix\views\page\view.html.php stattfindet. Zumindest in Quix Free Version 2.7.8 mit PHP8.0.1

    Code
    $uri = JUri::getInstance(true);
    $uri->setVar('format', 'amp');
    $document = JFactory::getDocument();
    $document->addHeadLink(htmlspecialchars($uri->toString()), 'amphtml');

    Aber es macht doch gar keinen Sinn die Zeile(n) zu entfernen. Dann kannst doch gleich AMP wieder deaktivieren.


    Viel sinnvoller wäre doch, den eigentlichen Fehler zu finden, wo das dann kollabiert. Als ersten Ansatz siehe Post#2 "Fehler finden durch ..."


    Schon das "RawDocument" in der Fehlermeldung kommt mir "komisch" vor.


    Mir scheints auch so, dass in der Free Version das AMP gar nicht vorgesehen ist. Da wird das format=amp an einer Stelle im Code wieder entfernt (aber, nicht zu verwechseln(!), nicht im HEAD).

  • Ich arbeite mit der Quix Pro Version, also sollte es ja eigentlich funktionieren.

    Habe amp in Quix auch mal disabled aber das gleiche Problem...

    Habe jetzt mal an den Support von Themexpert geschrieben, mal schauen, was die mir sagen...


    Danke für Deine Mühe

  • Steht dir natürlich frei. Aber was hinderte dich jetzt daran, mal eben den Test aus Post #2 zu machen, weil es ist natürlich für Helfer ebenso unbefriedigend, wenn man Zeit aufgewendet hat, wenn dann der TE Lösungsfindung blockiert.


    Dann hättest doch gleich da anfragen können.


    Ist immer so vergeudete Zeit...

  • Hallo GHSVS.de,

    Dein Hinweis, dass es mit Quix zu tun hat, war tatsächlich der entscheidende Hinweis. deswegen hatte ich mich ja dann an Themexpert gewendet. Die haben jetzt folgende Antwort geschickt:

    Please go to Quix - Options and disable AMP, it is no longer going to be mantained and it will be removed from Quix soon.


    Das habe ich jetzt gemacht und damit ist die Zeile Format=amp jetzt Geschichte…

    Dann muss ich für amp wahrscheinlich ein separates Plugin nutzen…

    Nun habe ich die Sitemap nochmal eingereicht und müsste jetzt auch ohne Probleme indexiert werden.


    Ich möchte Dir nochmals für Deine Mühe danken, deine Zeit war nicht verschwendet, denn Du hast es erst auf den richtigen Weg gebracht.