Front- und Backend nicht erreichbar

  • Liebe Forenmitglieder,

    ich hoffe, dass mir jemand weiterhelfen kann oder einen Tipp parat hat.
    Zuerst habe ich nur eine weiße Seite mit "Error" erhalten.

    Daraufhin habe ich nach einer Anleitung folgende Änderungen vorgenommen:
    1. In der configutation.php: $error_reporting = 'maximum';
    2. In der index.php: error_reporting (E_ALL);


    Beim Aufruf meiner Joomla-Seite erhalte ich jetzt diese Fehlermeldung:
    Error: Failed to start application: Unable to load session storage class: localhost

    Außerdem findet sich im error.log von mysql dieser Hinweis:
    Table './jooml_3/jq8sp_phocadownload_user_stat' is marked as crashed and should be repaired

    Wie würdet ihr jetzt vorgehen?

    Viele Grüße
    Al

  • Erst mal in die Datenbank gehen und das machen, was die Meldung sagt. Zur Sicherheit Datenbank exportieren. Dann in der Ansicht, wo man alle Tabellen aufgelistet sieht, alle Tabellen mit Häkchen versehen. Gibt es ein Sammelhäkchenfeld, das alle zugleich anhakt.

    Dann in dem Auswahlfeld (meistens unter der Tabellenliste): Reparieren wählen und ausführen.

    Zahlreiche Meldungen, dass das nicht geht, wo auf einen Tabellentyp verwiesen wird, kann man meist ignorieren.

  • Danke für die Rückmeldung.
    Die Datenbanken habe ich inzwischen repariert. Trotzdem bleibt die Fehlermeldung.

    Nun habe ich versucht eine Akeeba-Sicherung, die ich von der Website habe, in Xampp zu installieren.
    Sollte der Fehler nicht einfach zu beheben sein, wäre das Einspielen eines Backups eine weitere Möglichkeit.


    Soweit so gut. Das Backend ist lokal damit auch wieder erreichbar.

    Aber das Frontend zeigt einen Blackscreen mit einer Grafik "No GD".


    Habt ihr eine Idee, was da dahintersteckt?

    Viele Grüße

    Al

  • Erst nach dem Wiederherstellen des Backups funktioniert das Frontend nicht. I

    Du verwendest halt ein Template oder eine Erweiterung die auf die PHP GD library zugreifen will.

    Prüfe mit PHPinfo ob die GD aktiv ist. Welche PHP-Version hat Dein XAMPP? Sicherheitshalber solltest da unter PHP 7.4 arbeiten.

  • Die PHP Version wird mit 8.0.2 angezeigt.

    PHP 8 ist schon etwas mutig, da viele Erweiterungen damit noch nicht laufen!


    GD Support : enabled

    GD Version...

    usw.

    sollte da schon zu finden sein.


    Bzgl. PHP 7 und PHP 8 gibt es da wohl aber auch einen Unterschied. Habe da was gefunden, was ich auch nicht wusste: https://write.corbpie.com/how-…h-xampp-php-8-on-windows/

    (Seite braucht etwas länger zum Laden)

    Vielleicht hilft es weiter

  • Ok! Ich habe mir jetzt eine XAMPP 7.3. installiert.

    Jetzt erhalte ich folgende Fehlermeldung:


    Fatal error
    : Allowed memory size of 536870912 bytes exhausted (tried to allocate 20971520 bytes) in Q:\xampp\htdocs\http://www.test.de\libraries\joomla\database\driver.php on line 1711


    Kann ich da einfach die Werte tauschen? Und wenn ja - wo?


    Und nach dem Abschalten von SEO:


    atal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) in Q:\xampp\htdocs\http://www.test.de\libraries\joomla\database\driver\mysqli.php on line 894



    Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) in Q:\xampp\htdocs\http://www.test.de\libraries\vendor\joomla\registry\src\Registry.php on line 89

  • Versuche mal, für die Online DB ein neues Passwort zu erstellen, und dieses per FTP in die configuration.php einzutragen, nachdem du diese Datei mit Chmod 644 beschreibbar gemacht hast.


    Mit dem Lokalkram machst du dir nur eine unnötige zweite Baustelle auf. Besser ist, online mit einer Kopie der Seite in einer Subdomain zu arbeiten, wenn es denn nötig ist. Dafür auch eine neue DB anlegen.

  • Xampp 8 ist tatsächlich ohne GD nach Installation. Man aktiviert es in der php\php.ini durch Zeilenänderung. Strichpunkt vor Zeile

    Code
    ;extension=gd

    entfernen und Xampp neu starten.


    Andere Werte wie memory_limit, max_execution_time usw. usf. ebenfalls in der Datei.


    Allerdings hat j!-n schon recht. Zur Fehlersuche mag XAMPP mit uferlos hochgeschraubter Konfiguration, auch für die DB, schon OK sein. Aber, wenn die Seite das verbraucht, was du da andeutest, kannst das bei einem normalen Provider eh nicht so hoch schrauben.

  • Habe die Xampp-Version von Heise geladen und installiert.

    Ich nehme immer direkt von apachefriends.org


    Ich habe mit Xampp PHP 8 einige Seiten getestet.

    Viele liefen ohne Probleme durch, sodass ich sie dann auch Online auf PHP 8 umgestellt habe.


    Einige hatten Fehler, die konnte ich hier im Forum beseitigen.


    Deinen Fehler habe ich aber nicht gehabt.

    Ich würde mal auf das Template Protostar umschalten, ob der Fehler bleibt.


    Aber wurde auch schon erwähnt, dass es am Template und/oder an Extensions liegen kann.


    Ich würde auch immer auf C: installieren und nicht auf Q:

  • Danke für euere Beiträge.
    Das Problem besteht seit dem Update auf die neueste Joomla-Version Anfang Juli, das hatte ich noch nicht erwähnt. Zuvor lief die Seite ohne Probleme.


    Ich habe inzwischen auch ein Akeeba-Backup von Mai lokal (XAMPP mit PHP- Version 7) wiederhergestellt, aber auch da gibt es Probleme.
    Warum benötigt das System so viel Speicher?


    Elwood
    Q: verwende ich, weil das eine SSD mit genügend Platz ist.
    Wenn ich das Template wechsle, bleibt die Fehlermeldung.
    @j!-n
    Das kann ich leider selber nicht, da ich dort keinen Zugriff habe. Werde aber den Admin bitten das auszuprobieren.
    Die Idee wäre, wenn ich eine Sicherung zum Laufen bringen würde, könnte man sie online doch auch wiederherstellen können.
    Damit würde die Fehlersuche entfallen.

    @Re:Later

    Das werde ich auf alle Fälle versuchen. Mal sehen, ob ich das finde.


    Eins ist mir jetzt noch aufgefallen. Die Komponente Ark Editor Version 2.6.15 möchte auf 2.8.0 upgedatet werden.
    Das Update schlägt aber fehl.


    Jetzt hat sich etwas getan, in der php.ini habe ich memory_limit=1024M eingetragen.

    Nun startet auch das Frontend.
    Bringt aber nun folgende Fehlermeldung:


    Warning: Illegal string offset 'session.counter' in Q:\xampp\htdocs\http://www.test.de\plugins\system\jvcounter\jvcounter.php on line 63
    und

    Only variables should be assigned by reference in Q:\xampp\htdocs\http://www.test.de\modules\mod_cookiesaccept\mod_cookiesaccept.php on line 24

  • Die Frage ist halt, ob du diesen Jvcouner überhaupt bauchst. Im JDE ist er rausgeflogen, und ehrlich gesagt, Counter sind sowas von out. Dein Fehler steckt ja in diesem Counter. Ist zwar jetzt nur eine Warnung, man sollte das aber dennoch ernst nehmen. Wenn du den Counter unbedingt weiter verwenden willst, musst du die Anzeige der PHP Fehler ausknipsen (Fehler berichten: keine in Global Konfig, Srver Tab).

    Item: Bis und mit PHP 7.0 war es so, dass man ein array nicht explizit deklarieren musste, das hat sich jetzt geändert. Dein Counter wurde 2014 zuletzt aktualisiert, da gab es PHP 7 noch nicht.

  • @CurlY BracketS

    Nein, brauche ich natürlich nicht, habe das Modul lokal deaktiviert und die Fehlermeldung verschwindet.
    Auch das Modul CookiesAccept habe ich abgeschaltet.
    Leider muss man aber immer diesen Hinweis aber immer noch einblenden.
    Mal sehen, ob ich eine andere kostenlose Erweiterung finde.

    Was meint ihr? Wenn man das Memory-Limit auch online erhöht und ich die "problematischen" Module entferne, funktioniert dann auch die Website wieder?

  • Wenn dieser Counter in der Online-Version noch aktiv ist, würde ich ihn da mal deaktivieren. Solche Counte sind in der Regel richtige Speicherfresser. Meiner Ansicht nach müsste ein Memorylimit von 512M für eine normale Seite reichen (Cache löschen nicht vergessen)