Protostar zu Cassiopeia

  • Meine Neuinstallationen und updates haben alle auf Anhieb geklappt.

    Neue Systeme sind immer ein Umgewöhnungsprozess.
    Und die neue Version hat viele "hidden secrets" wie Brian Teeman das nennt, die erst mal entdeckt werden wollen.
    Die Quickicons auf dem Dashboard zum Beispiel könnten dir auch einen Button für den direkten Zugang zum Template erzeugen, wenn dir das wichtig ist.


    Nimm dir halt Zeit, das ganze zu erforschen und zu entdecken.

    Einen Zurück-Button gab es auf J3 auch nicht .. oder habe ich den nie bemerkt? Und die Rechteübersicht beim Benutzer kommt unverändert aus J3. Aber auch ich habe in J3 nicht alle Funktionen gekannt .. überall "hidden secrets"

    Ich benutze als Template protostar, das es in der 4.0 Version nicht gibt. Wie sieht da die Umstellung bei einem Update von 3.10 auf 4.0 aus, wenn das neue Default-Template benutzt wird?

  • Grds. passiert dass, was bei jeder Templateumstellung passiert. Da im neuen Template die Positionen anders heißen, wird nicht alles dargestellt. Man muss also die benutzten Module den neuen Positionen zuweisen.

    Benutzt man inkompatible Extensions, hat man dann Fehlermeldungen.

    Ist halt ein testen, bis alles j4 tauglich ist.

  • Danke für die Reaktionen. Ich werde den Fork zu protostar einmal testen. Momentan kann ich aber meine Website nicht auf die Version 4.0 updaten. Ich habe meine Webseite lokal geklont und und unter XAMPP laufen. Der Update auf die 3.20.1 Version hat prima funktioniert. Aber wenn ich auf 4.0 upgrade erhalte ich folgende Fehlermeldungen:


    Backend: Call to undefined method Joomla\CMS\Application\AdministratorApplication::isAdmin()

    Frontend: Es ist ein Problem aufgetreten.

    The server returned a "500 - Whoops, looks like something went wrong."


    Warum das so ist, ist mir nicht ersichtlich. Vielleicht hat einer von euch das auch mal ausprobiert und eine entsprechende Lösung für mein Problem.

  • Ebenso danke für eure Beiträge. Hier eine kurze Anmerkung zur Installation des Protostar Forks: Man kann es nicht normal installieren, daher habe ich den Ordner in den Joomla 4 Template Ordner kopiert. Ich musste es dann im Joomla 4 Backend folgenderweise aktivieren:


    System > Install > Discover > Template anklicken > oben auf Install klicken > Discover install successful :)


    Etwas stutzig machte mich, dass die Template Dateien vor 7 Monaten zuletzt verändert wurden…


    Edit: Spontan würde ich sagen, Installation kann man sich sparen…


    Backend: Call to undefined method Joomla\CMS\Application\AdministratorApplication::isAdmin()

    Frontend: Es ist ein Problem aufgetreten.

    The server returned a "500 - Whoops, looks like something went wrong."

    Nach meiner Beobachtung kommt der Fehler von nicht kompatiblen Komponenten/Plugins/Templates. Normal müsstest du beim Update genau vor diesen gewarnt werden. Ich habe ein neues J4 installiert und dann einige Erweiterungen installiert, so dass ich gut sehen konnte wer den Fehler verursacht haben muss. Ich konnte dann im Plugins Ordner das Plugin umbenennen und dann funktionierte zumindest der Seitenzugriff erstmal wieder…. Ich vermute, bei dir liegen da noch irgendwelche Leichen im Keller ;)

    Einmal editiert, zuletzt von Indigo66 () aus folgendem Grund: Ein Beitrag von Macjoomla mit diesem Beitrag zusammengefügt.

  • Danke Macjoomla. Ich habe zwar auf einer Testseite in CludAccess.net überprüft, ob die Plugins, Module oder Komponenten alle für 4.0.x installierbar sind und hier keine Schwierigkeiten entdeckt. Aber es stimmt, dass ich bei meiner Testinstallation auf die Hinweise nicht geachtet habe. Werde es noch einmal versuchen.


    Ich habe heute die lokale Testmigration beendet. Die Komponenten und Plugins Phocagallery, Sigplus konnte ich nicht installieren. Ich habe auf meiner Website noch das Plugin Zufallsbild, was in der neuen Joomlaversion fehlt. Die Migration meiner Website ist doch umfangreicher als ich vorher dachte. Zwar kann man im neuen Template durch ein paar Änderungen, das alte Erscheinungsbild meiner Website bis zu 90 % wiederherstellen, aber das Editieren der CSS-Datei ist sehr schwierig, weil dort alle CSS-Deklarationen in einer Zeile stehen.


    Was die Kategorien und Beiträge betrifft, hatte ich keine Schwierigkeiten die Daten aus der alten Datenbank zu importieren. Allerdings hat das nicht für die Benutzer funktioniert. Die musste ich neu manuell anlegen.


    Den Vorschlag von Macjoomla muss ich noch testen, da die von mir erstellte ZIP-Datei nicht installiert werden konnte.


    Vielen Dank für eure Hilfe und eure Anregungen.

    Einmal editiert, zuletzt von Indigo66 () aus folgendem Grund: Ein Beitrag von gopitzohlsen mit diesem Beitrag zusammengefügt.

  • Meine Joomla 4.0.3 Migration von 3.10.3 hat soweit funktioniert. Allerdings bin ich mit dem Kontakformular in Cassiopeia nicht zufrieden. Stelle ich im Kontakt beim Formular <Kopie an Absender ein>, so erscheint dieses Feld nicht im Formular, wenn man den Kontakt aufruft. Außerdem fehlt das ReCaptcha. Das Layout des Kontaktformulars ist ebenfalls sehr minimalistisch. Wie kann man es verändern?


    Zu Indigo66: Den Fork habe ich soeben installiert. Allerdings klappt das Kontaktformular nicht. Alles andere lief soweit.

    Einmal editiert, zuletzt von Indigo66 () aus folgendem Grund: Ein Beitrag von gopitzohlsen mit diesem Beitrag zusammengefügt.

  • Stelle ich im Kontakt beim Formular <Kopie an Absender ein>, so erscheint dieses Feld nicht im Formular, wenn man den Kontakt aufruft. Außerdem fehlt das ReCaptcha.

    Möglicherweise lässt sich das an verschiedenen Stellen einstellen. In J3 beispielsweise auch im Menüpunkt. J4 weiß ich gerade nicht, vermutlich aber auch. Eventuell ist da bereits etwas verstellt?!?

    Da gibt es dann eine bestimmte Reihenfolge bzgl. der Prioritäten. Einfach mal testen! (die Rehenfolge kann ich mir nie merken)


    Wie bereits erwähnt, kann durch diese Option Joomla schnell zur Spam-Schleuder werden. Ich würde das auch besser sein lassen.


    Und bzgl. ReCaptcha: Ist es denn korrekt eingerichtet und aktiviert?

  • Hallo,

    auch ich versuche mich an Cassiopeia und habe ein mainmenu auf der Position 'Menu' erstellt.
    Dabei stoße ich auf Probleme, die items mit user.css zu ändern. Ich finde die .Klassen nicht.


    Bevor ich jetzt lostexte frage ich lieber, ob ich in diesem Thread richtig bin.


    vG