Fehler 503 auf der public- und admin-Seite

  • Hallo zusammen


    Lang ists her; so lange, dass meine Benutzerdaten zum schönen Forum hier gelöscht wurden und ich mich neu registrieren musste...


    Ich hab seit vermutlich 2016 nicht mehr in mein Joomla eingeloggt (Asche auf mein Haupt). Seit einigen Wochen bekomme ich eine 503 Fehlerseite angezeigt wenn ich auf die public- und admin-seite zugreifen möchte. Daher meine Frage: Gibts noch ne Möglichkeit, zumindest auf die Administration zugreifen zu können?


    Vielen Dank!


    Edit: Ich habe Joomla 3 installiert (das Prefix der Tabellen ist jo3). Wäre jemand so lieb und würde meinen Beitrag in den Joomla 3 Bereich verschieben?

  • Wahrscheinlich passt die PHP-Version nicht mehr. Jooml 2.5 läuft nur mit PHP 5.6 und die meisten Hoster verwenden mind. 7.3.

    Vielleicht kannst Du mit Deinem Hoster was vereinbaren oder eine Kopie lokal auf einer XAMPP-Version mit PHP 5.6 zum Laufen bringen.

  • Vielen Dank für euren Input. Also nach neusten Erkenntnissen läuft mein Webserver noch auf PHP 5.4.45 (das kann ich selbst hochstellen bis 8.0.9).


    Aber was ich gesehen hab ist, dass alle Daten auf dem Webserver fehlen (der ganze joomla 3 Ordner im httpdocs). Die Datenbank inkl. der 68 Tabellen ist noch vorhanden. Bin gerade mal am Abklären, ob da was bei meinem Webhoster schief gelaufen ist. Dann werde ich vermutlich nicht um eine harte Installation einer aktuellen Version herumkommen...

  • Aber was ich gesehen hab ist, dass alle Daten auf dem Webserver fehlen (der ganze joomla 3 Ordner im httpdocs). Die Datenbank inkl. der 68 Tabellen ist noch vorhanden. Bin gerade mal am Abklären, ob da was bei meinem Webhoster schief gelaufen ist.

    Hatte dir der Hoster vielleicht mal mitgeteilt, dass aufgrund einer PHP-Versionsänderung ein Umzug auf einen anderen Server stattfindet. Eventuell musst du da noch ein paar Anpassungen vornehmen.

    Dennoch: Die PHP-Version muss natürlich zu deinem Joomla passen.

  • Ich habe nun Sicherheit: alle Ordner aus dem httpdocs-Ordner sind weg. Die Datenbank ist komplett vorhanden. Zudem habe ich ein .jpa File als Sicherung erstellt. Nun ist meine Frage, ob das .jpa auch mit einer neuen Joomla-Version kompatibel ist und welches Vorgehen empfohlen wird.

  • Ich würde die Backupdatei kopieren.

    Dann Xampp mit PHP 5.6 installieren und versuchen, die Seite zu laufen zu bringen.


    Dann schauen, welche Joomla-Version es ist und hier dann auch mal posten.

    Dann könnte man genauer vorgehen.


    Weiter schrittweise oder Versionsweise Joomla, Extensions und Template/Framework aktualisieren und immer mal wieder zwischendurch ein Backup anfertigen.

    Vielleicht Dann auch mal ein Backup mit Xampp für PHP 7 versuchen.

    Alle Infos und weitere Tipps findest du auch hier in den Anleitungen.

  • Ich bin hier wohl nicht ganz richtig bzw. hab ich wohl noch ein ganz anderes Problem:


    Ich habe joomla 3.10 runtergeladen und auf meinem Webserver hochgeladen ins Verzeichnis httpdocs/test sowie die Domain auf dieses Verzeichnis umgestellt. Wenn ich nun domain/test aufrufe, bekomme ich direkt einen Fehler 503. Wenn ich per https aufrufe, gibt Chrome einen NET::ERR_CERT_COMMON_NAME_INVALID Fehler aus.


    Das ist doch Sache meines Hosters - oder ist das mein Fehler?

  • Das scheint ein Problem mit dem Zertifikat zu sein. Kann jedoch einige Ursachen haben: https://kinsta.com/de/wissensd…cert_common_name_invalid/


    Vielleicht erst einmal ohne Zertifikat, also über http, versuchen! (egal ob neue Installation oder Einspielen eines Backups)


    Zudem habe ich ein .jpa File als Sicherung erstellt. Nun ist meine Frage, ob das .jpa auch mit einer neuen Joomla-Version kompatibel ist und welches Vorgehen empfohlen wird.

    Was genau enthält denn dieses .jpa. In der Regel alle Dateien und die DB-Tabellen. Könnte man mit kickstart.php in ein leeres Verzeichnis einspielen. Da darf also kein Joomla drin sein. Deshalb verstehe ich die letzte Frage nicht.

    Wenn es ein älteres Joomla ist, empfiehlt sich PHP 5.6. Wie gesagt, erst ab Joomla 3.5 kann man PHP 7.x nutzen.

  • Ich kann hier Feedback geben. Das Problem ist verschwunden, nachdem ich die PHP-Version von 5.5.38 auf 5.6.40 erhöhte. Allerdings habe ich nun ein neues Problem, für welches ich ein anderes Thema eröffnen werde.

    Da könnten aber noch weitere Probleme auftauchen.

    Wäre die Frage, ob man die Seite nicht gleich mit J4 und PHP aufsetzen sollte: