Update von 3.10.2 auf Joomla 4 bricht ab mit "invalid ajax data"

  • Hallo,

    ich habe versucht, meine Seite 3.10.2 auf Joomla 4.0.3 über die Update Funktion in Joomla - Komponenten hoch zu leveln. Bei ca. 90% brach die Installation ab mit dem Hinweis "in valid ajax data". Wenn ich jetzt die Administration aufrufe, erhalte ich den Fehler "Class 'JRequest' not found".

    Was habe ich gemacht?

    Ich habe XAMPP 7-4-12 als Basis genutzt und darauf ein Akeeba Backup installiert. Dies war erfolgreich, dort teste ich so immer meine Updates.

    Danach habe ich erstmal einige nicht mehr notwendige Erweiterungen gelöscht, so auch das Akeeba-Paket.

    Und dann habe ich das Update aufgerufen.

    Leider kann ich euch nicht auf die Seite lassen, da es eine lokale Installation auf meinem PC ist. Hat trotzdem jemand eine Idee, wo mein grundsätzlicher Fehler liegt?

    Hätte ich vorher ein PHP 8 Update machen müssen oder die XAMPP 8.0.9 nehmen sollen?

    Danke für eure Hilfe!

    Hans

  • Die Pfade hattest du nach dem Umzug zu Xampp angepasst?

    Das Akeeba-Plugin "Sicherung vor Update" war deaktiviert?

    Hallo JoomlWunder,

    ich hatte das gesamte Paket von Akeeba deinstalliert. Anpassungen der Pfade musste ich nicht vornehmen. Die stellt Akeeba automatisch bei der Rücksicherung richtig ein. Das zeigen ja auch die Logs, die ich angehängt hatte. Ich sehe nur in den Logs keine Einträge nach dem Start des Updates. Das hatte mich schon gewundert.

    Trotzdem Danke für deine Tipps.

    Hans


    Und was hat die Installationsprüfung für Joomla 4.0.3 ergeben?


    Datenbank und PHP Einstellungen?
    Drittanbieter Erweiterungsprüfungen?

    Es waren diverse Module unter "Update Informationen nicht verfügbar". Die ich soweit geprüft und größtenteils einfach deinstalliert.

    Bei PHP und SQL war die Prüfung ok

    Viele Grüße

    Hans

    Einmal editiert, zuletzt von Indigo66 () aus folgendem Grund: Ein Beitrag von sappie_hans mit diesem Beitrag zusammengefügt.

  • Ich nutze ganz viele .htaccess in verschiedensten Verzeichnissen, war mal in irgendeinem Forum empfohlen.

    Wenn es keinen besonderen Grund gibt, würden eigentlich zwei .htaccess reichen.


    Einmal die .htaccess im Root von Joomla, die sowieso als htaccess.txt mitinstalliert wird,

    und eine .htaccess als Verzeichnisschutz für das Backend im Ordner /administrator.


    Bei Xampp-Installationen habe ich immer alle .htaccess-Dateien deaktiviert, bis die Seite

    eunwandfrei läuft.

  • 2021-10-06T13:29:59+00:00 INFO ::1 update Datei Joomla_4.0.3-Stable-Update_Package.zip erfolgreich heruntergeladen.

    2021-10-06T13:29:59+00:00 INFO ::1 update Neue Version wird jetzt installiert.


    Hier wird doch das Update gestartet, kommt aber nicht zum Ende.


    Es waren diverse Module unter "Update Informationen nicht verfügbar". Die ich soweit geprüft und größtenteils einfach deinstalliert.


    Sicher, dass du keine systemrelevanten Erweiterungen deinstalliert hast?

  • Genau, bei 90% kommt dann die Fehlermeldung "in valid ajax data". Ich bin jetzt soweit, dass ich den Upgrade nochmal starten kann, Diesmal schreibe ich mal mit, welche Komponenten ich deinstalliere.


    So, ich habe jetzt das Update nochmal neu gestartet und vorher die .htaccess.txt auf .htaccess geändert. Außerdem alle bestehenden .htaccess gelöscht.

    Vor Start des Updates habe ich folgende Erweiterungen gelöscht:

    a. J2XML

    b. JCOMMENTS

    c. Akeeba Backup package

    d. Xmap

    e. System - Add Custom CSS

    f. System – Autologin

    g. manage.myJoomla.com Secure Plugin

    h. System – JCE

    i. System - Mobile Template

    j. System - Regular Labs Bibliothek

    Danach den Update gestartet:


    Dann kam bei 90,2% der Abbruch:

  • Wie ist der Stand in der joomla_update.php?


    Nachtrag: Nachdem du diese Erweiterungen gelöscht hast, läuft da die 3´er Version noch korrekt?

    Die Version 3 lief noch ohne Probleme, sowohl die Administration, als auch die Seite selbst.

    Der Inhalt der Update.php ist:

    #Date: 2021-10-07 18:15:51 UTC

    #Software: Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT


    #Fields: datetime priority clientip category message

    2021-10-07T18:15:51+00:00 INFO ::1 update Update wurde vom Nutzer Hans Goris (62) gestartet. Die frühere Version war 3.10.2.

    2021-10-07T18:15:53+00:00 INFO ::1 update Updatedatei von https://downloads.joomla.org/c…Stable-Update_Package.zip wird heruntergeladen.

    2021-10-07T18:16:11+00:00 INFO ::1 update Datei Joomla_4.0.3-Stable-Update_Package.zip erfolgreich heruntergeladen.

    2021-10-07T18:16:11+00:00 INFO ::1 update Neue Version wird jetzt installiert.

  • Bevor du mit Kickstart das Akeeba Backup einspielst, löschst du wahrscheinlich auch das Joomla Root-Verzeichnis und im PhpMyadmin die entsprechende DB, bzw. deren Tabellen?


    Versuche mal folgende Änderung in der PHP.INI


    max_execution_time=60

    memory_limit=128M


    Gruß Jürgen

    Einmal editiert, zuletzt von Indigo66 () aus folgendem Grund: Ein Beitrag von jsc_01 mit diesem Beitrag zusammengefügt.

  • Hallo Jürgen, bevor ich das Backup restore lösche ich das root Verzeichnis meiner Seite und lösche auch die Datenbank komplett. Danach erstelle ich wieder eine neue, leere DB.

    Die beiden Werte in meine PHP.INI sind

    max_execution_time=120

    memory_limit=512M

    Soll ich die auf deine Werte reduzieren?

    Viele Grüße, Hans


    Hallo Elwood, nachdem meine Seite gehackt wurde, habe ich vor ein paar Jahren im Forum eine Anleitung gefunden, in sehr viele Verzeichnisse entsprechende .htaccess-Datein einzufügen. Dies hat mich damals gestört, und das stört mich eigentlich auch jetzt noch.

    Du nutzt die .htaccess, die als .txt mitgeliefert wird? Und zusätzlich erstellst du im Administrator-Verzeichnis eine weitere .htaccess? Oder legst du die in das Verzeichnis administrator/compopnents?

    Könntest du mal den Inhalt dieser .htaccess hier rein popsten?

    Vielen Dank, Hans

    Einmal editiert, zuletzt von Indigo66 () aus folgendem Grund: Ein Beitrag von sappie_hans mit diesem Beitrag zusammengefügt.

  • Nein, nicht reduzieren, das ist gut so. Und unter Xampp rename ich auch alle .htaccess Dateien, wie Elwood schreibt.

    Hast du in deiner php.ini Funktionen disabled? Suche mal nach disabled_functions, da sollte nichts stehen. Ansonsten bin ich ratlos.

  • Ich habe jetzt nochmal alle .htaccess gelöscht, dabei hatte ich eine Datei im FOF-Ordner beim Renamen übersehen. Einen Eintrag in der php.ini für disabled_functions habe ich nicht. Ich starte jetzt nochmal den Update, aber ich habe auch wenig Hoffnung. Trotzdem danke für deine große Mühe!

    Liebe Grüße, Hans

  • Trotzdem danke für deine große Mühe!

    Der Vorschlag von Lui_brempt ist richtig, damit schließt du schon mal eine mögliche Fehlerquelle aus. Und dann bei Xampp nur Apache, Mysql und PHP installieren. Filezilla, Mercury und Tomcat installiere ich nie.


    Was ich noch machen würde: Unter Xampp eine neue 3.10.2 Version (von der offiziellen Quelle) installieren, keine Erweiterungen, Protostar als Default-Template und dann das Update auf 4.0.3. Installationsprüfung beachten.

    Wenn das klappt, kann´s nicht am localhost und am jungfräulichen Joomla liegen.

    Danach Update deiner Webseite, nachdem du sie mit Kickstart wiederhergestellt hast. Vorher "Datenbank reparieren", Cache leeren.
    Wenn es nicht funktioniert musst du dir deine Webseite und Erweiterungen noch mal anschauen.

    Gruß Jürgen

    Einmal editiert, zuletzt von Indigo66 () aus folgendem Grund: Ein Beitrag von jsc_01 mit diesem Beitrag zusammengefügt.

  • Genau, also: Erweiterungen - Verwalten - Datenbank - Reparieren.
    Sollte dann ungefähr so aussehen:

    • Version des Datenbankschemas (in #__schemas): 3.10.0-2021-05-28
    • Update-Version (in #__extensions): 3.10.2
    • Datenbanktreiber: mysqli
    • 189 Datenbankänderungen wurden überprüft.
    • 218 Datenbankänderungen hatten keinen Einfluss auf die Struktur der Datenbanktabellen und wurden deshalb übersprungen.