Generelles Problem mit Links

  • Moin,


    ich habe ein generelles Problem mit Links auf meiner Joomla 4-Testseite.

    Auf meiner Seite mit Joomla 3.10 setze ich für die Startseite eine Kopie meines Standtardtemplates ein,

    wo die Darstellung der Komponenten ausgeschaltet ist und ausschließlich Module angezeigt werden.

    Das gleiche habe ich jetzt auch auf der Testeite so eingerichtet. Die Links aus dem Menü funktionieren auch einwandfrei,

    aber alle Links, die aus den Modulen oder den verschiedenen Menülinks angewählt werden, landen auf der Startseite.

    Ich habe das mit Helix Ultimate, Astroid und Templates von Joomlart probiert, jedesmal mit demselben Ergebnis.

    Meine Testseite ist hier zu finden https://www.svdoerpum.de/joomla/

    Vielleicht hat ja jemand eine Idee, wie ich das hinbekommen kann.


    Gruß svdoldie

  • ... die Darstellung der Komponenten ausgeschaltet ist und ausschließlich Module angezeigt werden.

    Das gleiche habe ich jetzt auch auf der Testeite so eingerichtet.

    Wie hast du dies im Detail in Joomla4 umgesetzt?


    Da die Links ja z.B. zu einzelnen Beiträgen ja durchaus offensichtlich richtig sind.


    Sieht man z.B. wenn man einen dieser Links, die wohl zur Starseite umgeleitet werden, per tmpl=component ausgibt:


    https://www.svdoerpum.de/jooml…it-reichte-nicht&catid=91


    https://www.svdoerpum.de/joomla/index.php?tmpl=component&view=article&id=807:tolle-erste-halbzeit-reichte-nicht&catid=91


    https://www.svdoerpum.de/jooml…fan-hansen?tmpl=component


    Warum nicht z.B. einen leeren Dummy-Beitrag für die Startseite und diesen per CSS enfernen und die "Komponentendarstellung" nicht ausschalten.

  • Es ist aber immer eine schlechte Idee wenn man ein Joomla! in einen Dateiordner unterhalb einer anderen Joomla!-Website macht !


    Nie Dateiordnerstruktur:


    /webspace/joomlaA/joomlaB


    Bessere Dateiordnerstruktur :


    /webspace/joomaA/

    /webspace/joomlaB/


    Die Domain muß dann z.B. auf den Dateiordner joomlaA zeigen.

    Und eine Subdomain kann dann z.B. auf den Dateiordner joomlaB zeigen, insbesondere falls du bei deinem Webhoster keinen direkten Link zum Dateiordner joomlaB hast.

  • Hallo Sieger66,


    vielen Dank für die schnelle Antwort. Ich werde mal versuchen,

    das mit einer Subdomain umzusetzen.


    Leider hat das Umstellen auf eine Subdomain nichts gebracht. Liegt da evtl. ein Bug bei Joomla 4vor,

    da es ja mit Joomla 3 einwandfrei funktioniert hat?


  • Leider hat das Umstellen auf eine Subdomain nichts gebracht. Liegt da evtl. ein Bug bei Joomla 4vor,

    da es ja mit Joomla 3 einwandfrei funktioniert hat?

    Ich würde das zunächst mal mit Cassiopeia testen!
    Gibt es einen Link zur aktuellen J4-Installation?


    Nebenbei: 3.10.3 RC1 ist auf einer produktiven Seite nicht unbedingt empfehlenswert! Eventuell den Aktualisierungsserver mal umstellen!?!

  • Ich habe jetzt mal Cassiopeia für die Startseite gesetzt. Nun verhält es sich so, dass alle Menülinks mit dem als Standard gesetzten Template angezeigt werden. Alle anderen Links, auch diejenigen, die man auch über das Menü benutzen kann, werden mit Cassiopeia angezeigt. Dann werden auch die nur für die Startseite gesetzten Module angezeigt. Ich kann mir irgendwie nicht vorstellen, dass das so gewollt ist.

  • Ist diese Komponente "Sports Management" aktuell? Eventuell müssen da bzgl. J4 weitere oder andere Einstellungen vorgenommen werden?


    Es ist nicht ganz einfach, die Thematik zu überblicken, da ja auch noch nicht alle Seiten zur Verfügung stehen (404).

    Vielleicht muss auch einfach nur ein bestimmter Menüpunkt angelegt werden, damit das reibungslos funktioniert.

    Das sind alles nur so Ideen...


    Ich würde das Ganze mal testen mit einfachen Menüpunkten zu einem Beitrag und einfachen Modulen mit Links, ohne dass diese Sports-Komponente da irgendwie im Spiel ist, um diese als Ursache mal auszuschließen!


    Bzgl. Module und Menüs: Vielleicht hast du bei manchen Menüpunkten ein bestimmtes Template angegeben. Ev. müssen die Module neu zugeordnet werden nach dem Umswitchen.


    EDIT: So ganz groß finde ich den Unterschied zwischen deinem J3-Template und Cassiopeia gar nicht.

  • Mittlerweile teste ich nur mit dem Cassiopeia als Standardtemplate für alles. Die Menüpunkte stehen alle auf "Standard verwenden". Ich habe mittlerweile bis auf ein Module alle anderen abgeschaltet. Auch wenn ich aus einem Content in die Kategorieübersicht gehe, bleibt das Modul (keines vom SM) stehen, obwohl es eigentlich nur auf der Startseite angezeigt werden soll.

  • Auch wenn ich aus einem Content in die Kategorieübersicht gehe, bleibt das Modul (keines vom SM) stehen, obwohl es eigentlich nur auf der Startseite angezeigt werden soll.

    Das geht jetzt ein wenig in eine andere Richtung. Oder ich habe dich bisher missverstanden.

    Um welches Modul geht es?

    Module werden über die Menüpunkte gesteuert. Möglicherweise gibt es bei deinem Problem keinen Menüpunkt, der das steuert. Bzgl. Startseite kann es auch grundsätzlich Probleme geben. Hier hilft meist der "Advanced Module Manager". Diesen gibt es aber (noch) nicht für J4, soweit mein Kenntnisstand.

  • Die Links im Menü gingen schon immer und da werden auch nie die Module von der Startseite angezeigt. Aber wenn man z.B. aus einem Modul eine andere Seite aufrufen möchte oder wie oben erwähnt aus einem Beitrag, werden die Module von der Startseite auch mit angezeigt. Bei anderen Templates sogar nur ausschließlich die Module der Startseite. Sehen kann man das auf meiner Seite z.b. wenn man auf den Link im Modul "Meldungen" klickt, dann bleibt das Modul sichtbar. Es soll dann aber nur der Artikel angezeigt werden.

  • Sehen kann man das auf meiner Seite z.b. wenn man auf den Link im Modul "Meldungen" klickt, dann bleibt das Modul sichtbar. Es soll dann aber nur der Artikel angezeigt werden.

    Ah ok!
    Der Link (URL) im Modul beinhaltet die Itemid=101, und das ist die Startseite. Deshalb werden die Module der Startseite da mitangzeigt:


    ...index.php?option=com_content&view=article&id=807:tolle-erste-halbzeit-reichte-nicht&catid=91&Itemid=101


    Eventuell müsstest du einen (unsichtbaren) Menüpunkt für den Beitrag anlegen. Das Modul darf diesem dann nicht zugeordnet werden. Oder halt den AMM verwenden, den es aktuell noch nicht für J4 gibt: https://regularlabs.com/advancedmodulemanager

    Der unterscheidet die echte Startseite.


    Was anderes fällt mir da jetzt auch nicht ein.