PHP-Fehler beim Anzeigen von Modulen im Frontend.

  • Hallo liebe Joomla-Gemeinde,

    gerade erst registriert, komme ich auch schon mit einem Problem, das ich leider alleine nicht lösen kann (habe es versucht).

    Ich habe mir heute verschiedene Content-Slider (Module) die für Joomla4 ausgeschrieben sind, gekauft und installiert.
    Nach der Platzierung des Moduls durch eine Position kommt es bei diesen Erweiterungen zu fatalen PHP-Fehlern:

    Beim Aufruf über die helper.php der Module kommt es zur Fehlermeldung:

    "... /components/com_content/helpers/route.php): failed to open stream: No such file or directory"


    Und es stimmt, diese Dateien sind dort tatsächlich nicht, es gibt in diesem Joomla-Ordner nur eine "icon.php".
    Was kann ich jetzt tun, damit dies klappt? Gibt es die fehlenden Dateien irgendwo?

    Ich würde mich sehr freuen, wenn jemand hierzu Rat weiß.

    Viele Grüße
    Oli

  • Diese Erweiterungen sind dann mit Sicherheit NICHT Joomla-4-ready. Eventuell hast du die falsche Version installiert? Passiert schon mal.


    Wenn nicht falsch installiert, verlange dein Geld zurück! Ich wäre jedenfalls bei einer Bezahl-Erweiterung, hätte ich sie gekauft, nicht bereit, solcherlei Fehler selbst zu reparieren, weil sie zeigen, dass die Erweiterung nie unter Joomla 4 getestet wurde. Auch, weil es ja bei jedem Update wieder überschrieben wird.


    Um welche Erweiterungen geht es eigentlich? Und welche davon funktioniert nicht? Bekommst du heraus, indem du die Module halt wechselweise deaktivierst.

  • Hallo,

    danke für deine Antwort. Es handelt sich um folgende Erweiterungen/Module
    (beide haben diesen Fehler):

    Du hast recht. Wenns nicht tut ist man wahrscheinlich schneller drann, selber einen Content-Slider zu bauen. Ich habe früher hierzu immer das "Compago Blank Modul" verwendet. Das gibts natürlich auch nicht mehr für Joomla 4.

    Ich suche eigentlich einen unter Joomla4 funktionierenden Content-Slider, bei dem ich Beiträge einer Komponente mit Bild und Teaser-Text zeigen kann.

  • Danke für eure Antworten.
    Ich hatte gehofft, ich könnte für dieses Modul ein paar include-Pfade umschreiben und dann funktioniert alles. Es ist so, dass zB. in der "helper"-Datei des Moduls eine Datei aufgerufen wird, die es an dieser Stelle in Joomla 4 nicht mehr gibt:


    require_once JPATH_SITE . '/components/com_content/helpers/route.php';

  • Ich hatte gehofft, ich könnte für dieses Modul ein paar include-Pfade umschreiben und dann funktioniert alles.


    Ich habe mir heute verschiedene Content-Slider (Module) die für Joomla4 ausgeschrieben sind, gekauft und installiert.

    Warum versuchst du Pfade umzuschreiben?


    Da du sie gekauft hast, würde ich mal den Support der Erweiterung kontaktieren.