Per FTP werden nicht alle Dateien übertragen ...

  • Moin in die Forumsrunde,


    nach einer längeren Nutzung meiner Joomla-Installation plane ich die Neuaufsetzung einer Website mit der aktuellesten Joomla 3.x-Version mit der Joomlaplates-Umgebung. Um mich in die Funktionen einzuarbeiten, habe ich das Quickstart-Paket mit Demodaten entpackt und per FTP in das vorgesehene Verzeichnis kopiert. Allerdings wurden 6 Dateien nicht übertragen mit dem Hinweis "Übertragung konnte nicht gestartet werden". Ein einzelnes Kopieren der Dateien vom Quellordner in den Zielordner funktionierte ebenfalls nicht.


    Woran kann es liegen? Wie kann ich das Problem beheben? hmm


    Gruß Chris

  • Welches Quickstart-Paket (mit welchen Demodaten) meinst du?

    Link zum QS-Paket?

    Um welche Dateien handelt es sich?


    Du kannst auch das QS-Paket auf den Server schieben (nur 1 Datei) und dann dort entpacken. Das geht viel schneller und ist auch weniger fehleranfällig. Das Entpacken geht teils über den Hoster oder halt mit einem entsprechenden kleinen Skript.

  • Danke für die prompte Reaktion ... Ich meine das von joomlaplates für J3 zur Verfügung gestellte Quickstart-Paket mit den kompletten Dateien (Joomla, Template, Astroid, Demodaten, Module, etc.). Welchen Link zum QS-Paket meinst du? Entweder liegt das Paket über ein Login bei joomlaplates bzw. jetzt auch bei mir auf meinem Rechner bzw. in meinem Webspace-Verzeichnis.


    Ja, die Antwort im joomlaplates-Forum auf die nicht übertragenen Dateien war nicht, warum sie nicht übertragen wurden und wie ich es erreichen kann, sondern auch der Hinweis, die quickstart.zip sowie die unzip.php in das leere Verzeichnis zu kopieren und das entpacken über die Eingabe der Domain/unzip.php zu starten. In dem minimalistischen Screen kann ich die Zip-Datei zum entpacken auswählen (gibt nur die QS.zip) und "unzip" starten. Ich habe das mit 3 verschiedenen Versionen der unzip.php probiert und erhalte jedesmal den Fehler


    Error : PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file ''


    Ich interpretiere diese Fehlermeldung so, dass die unzip.php keine Zip-Datei zum entpacken findet ... ?


    Daraufhin habe ich zwei unterschiedliche Quickstart.zip für unterschiedliche Template-Designs in das Verzeichnis gelegt, um eine Auswahl zu haben ... mit der gleichen Fehlermeldung.


    Ich bin in der Bucht gerade auf der Suche nach einem Beissholz ... fie

  • Teste mal diese:

    ($filename an den Namen des Zips vorher aber anpassen)

  • Ich habe 3 angeblich unterschiedliche Versionen von unzp.php über das Forum per Link erhalten. Ich habe eben die php-Dateien in Note geöffnet, dass es sich bei den 3 Dateien scheinbar um den gleichen Stand aus 2006 handelt:


    $Id: pclzip.lib.php,v 1.44 2006/03/08 21:23:59 vblavet Exp $


    Die oben genannte Fehlermeldung kommt aus dem PHP-Script ... möglicherweise schon veraltet!? Ich habe diese Erkenntis gerade im joomlaplates-Forum eingegeben in der Hoffnung, dass es tatsächlich noch eine aktuellere, funktionierende Version gibt ... hmm


    Die quickstart.zip für Joomla4 habe ich auch probiert mit dem gleichen, negativen Ergebnis. Ich werde aber erstmal bei J3 bleiben, da ich zur Zeit mit Seblod mehrere Sites auf 1 J-Installation betreibe. Mit Joomla4 warte ich, bis die Multidomain-Version stabil läuft. Ich werde mit allerdings Joomla4 zum kennenlernen und testen installieren.


    kickstart.php > okay, das werde ich checken ...


    Bei dem QS.zip handelt es sich um den aktuellen Stand und Download mit einem Joomla 3.9.x und Astroid-Framework ...


    JoomlaWunder,


    beer danke für die php-Datei! Das Entpacken hat funktioniert! Also lag es bei den anderen unzip.php-Dateien wohl tatsächlich an einer veralteten Version!?


    Jetzt habe ich eine Test- und Lernbasis für das Astroid-Framewerk mit Beispieldaten. Mir macht es das Erlernen und Verstehen einfacher! :thumbup:


    Gruß Chris