Shodowbox vs. Mainmenu

  • Moin.

    Ich suche Hilfe bei einem Darstellungsproblem.

    In meiner Phoca Gallery (Bildergalerie) nutze ich die Shadowbox (Nur Bild). Diese wird aber teilweise durch mein Mainmenu verdeckt. Um die Bilder störungsfrei zu sehen, muss man die HP. im Hintergrund nach oben scrollen.

    Wie kann ich entweder die Shadowbox ganz nach vorne holen, oder das Mainmenu eine Ebene nach hinten stellen? In den Einstellungen vom Mainmenu klappt das über die Ebenensteuerung nicht. Ich stoße hier an meine Programmierergrenzen.

    Ich nutze:
    Jommla 3.10.6. (Aktuell)
    Die Phoca Gallery hat die Version: 4.4.3
    PHP-Version: 7.4.27
    Theme: pjo_astora_free
    Firefox: 98.0 (Standard+aktuell)
    MS-Edge: (Version 99.0.1150.39 (Offizielles Build) (64-Bit)) ausprobiert, aber ohne Erfolg.
    Homepage: https://www.der-raumgestalter.de/
    Unter Referenzen findet man die Bildergalerie
    Gehostet bei: Strato

    Falls noch Fragen sind, oder noch mehr Angaben benötigt werden, dann bitte hier nachfragen. evilgrin

    MfG
    ZeroG

  • Hallo Kitepascal.

    Danke für die schnelle Antwort.

    Leider funktioniert das nicht. Die CSS-Datei (hor_nav.css) sieht folgendermaßen aus:

    hor_nav.css

    /*GENERAL*/

    #hor_nav_outer

    {

    background-color: #FFFFFF;

    }

    #hor_nav

    {

    z-index: 1000;

    position: relative;

    min-height: 50px;

    background-repeat: repeat;

    margin-left: 10px;

    margin-right: 10px;

    }

    #hor_nav UL

    {

    margin: 0;

    }

    #hor_nav LI

    {

    list-style: none;

    float: left;

    padding-left: 0;

    height: 50px;

    position: relative;

    }

    #hor_nav LI A

    {

    display: block;

    padding: 0 10px;

    line-height: 50px;

    color: #FFFFFF;

    border-right: 0px;

    font-size: 12px;

    background-image: none;

    background-repeat: no-repeat;

    background-position: center right;

    text-transform: uppercase;

    font-weight: inherit;

    text-decoration: none;

    }

    #hor_nav LI.active A

    {

    background-color: transparent;

    color: #855F38;

    background-image: none;

    background-repeat: no-repeat;

    background-position: center right;

    }

    #hor_nav LI A:hover, #hor_nav LI:hover A, #hor_nav LI.sfHover A

    {

    background: #000000;

    }

    /*TRANSITION*/

    #hor_nav LI A:hover, #hor_nav LI:hover A, #hor_nav LI.sfHover A

    {

    color: #999999;

    }

    #hor_nav LI UL

    {

    position: absolute;

    width: auto;

    left: -999em;

    margin-left: -1px;

    border: 0;

    border-top: 0;

    z-index: 20000;

    }

    #hor_nav LI UL UL

    {

    margin: -31px 0 0 100%;

    }

    #hor_nav LI:hover UL UL, #hor_nav LI:hover UL UL UL, #hor_nav LI:hover UL UL UL UL, #hor_nav LI.sfHover UL UL, #hor_nav LI.sfHover UL UL UL, #hor_nav LI.sfHover UL UL UL UL

    {

    left: -999em;

    }

    #hor_nav LI LI

    {

    padding: 0;

    height: auto;

    background: #FFF;

    min-width: 100%;

    white-space: nowrap;

    width: auto;

    z-index: 1100;

    }

    #hor_nav LI LI A, #hor_nav LI LI.active A, #hor_nav LI LI A:hover

    {

    margin: 0;

    height: 30px;

    line-height: 30px;

    background: #000000;

    color: #FFFFFF;

    border-top: 1px solid #0C0C0C;

    border-right: 1px solid #0C0C0C;

    }

    #hor_nav LI LI A, #hor_nav LI.active LI A

    {

    font-weight: normal;

    }

    /*TRANSITION*/

    #hor_nav LI:hover UL, #hor_nav LI.sfHover UL

    {

    left: 1px;

    }

    #hor_nav LI LI:hover UL, #hor_nav LI LI LI:hover UL, #hor_nav LI LI LI LI:hover UL, #hor_nav LI LI.sfHover UL, #hor_nav LI LI LI.sfHover UL, #hor_nav LI LI LI LI.sfHover UL

    {

    left: 0;

    }

    /*PARENT DROPDOWN ITEMS*/

    #hor_nav .deeper.parent .dropdown-toggle .caret

    {

    border-top-color: #333333;

    border-bottom-color: #333333;

    margin-top: 21px;

    margin-left: 3px;

    }

    Stelle ich von 1.000 auf 1 inkl. speichern und neu laden, sehe ich keinen Unterschied. Muss ich evtl. noch mehr ändern?

  • Hallo WM-Loose.

    Hat sich erledigt, jetzt funktioniert es mit der Einstellung von kitepascal. Danke euch beiden. Hatte es noch mal umgestellt, gespeichert, alle Fenster geschlossen, Cache gelöscht und dann noch mal FF neu aufgemacht und viola, es funktioniert. Super und so einfach evilgrin