Error-Meldungen wegen Systempfaden bei Joomla

  • Hallo Filmdoc,

    ich Betreibe auch ein paar Seite bei Strato und bei mir steht folgendes drin.


    Protokollverzeichnis :

    /mnt/rid/17/23/52221723/htdocs/handwerker/logs


    Tempverzeichnis:

    /mnt/rid/17/23/52221723/htdocs/handwerker/tmp


    Cache:

    leer


    Vielleicht hilft es dir weiter.


    Versuche es doch mal das du nur das Cache Verzeichnis leer lässt.

  • Das sind ja die relativen Pfade, die bei einem Serverumzug Probleme bereiten!

  • Hallo NTM, hallo Elwood,


    ja, wie Elwood schon geschrieben hat, die mnt Adresse hatte ich früher, dann hat Strato einfach den Server umgezogen und eine neu mnt Adresse vergeben, die habe ich auch eingetragen, doch seitdem kommt es immer wieder zu Blank Pages.


    Danach habe ich die absoluten Pfade eingegeben, das hat die Häufigkeit des Problems reduziert. Trotzdem wird in der Fehlermeldung immernoch nach dem alten mnt Pfad gefragt.


    Beim Cache habe ich den richtigen Pfad eingetragen, wenn ich ihn leer lasse, befürchte ich weitere Warnungen.


    #Elwood - Ich hatte ja, wie von Dir vorgeschlagen die Debug-Stack Infos gepostet,- ist denn da alles okay gewesen?


    Danke für Eure Mühe,

    Filmdoc

  • Nachtrag- vielleicht hilft es bei der Fehlersuche- ich wollte gerade ein Akeeba Backup anwerfen und es wurde empfohlen, in ein anderes Verzeichnis als Default zu speichern. Beim Umstellen kam dann eine Warnung dass sich der von mir gewählte Ordner direkt im Root befände und dass Akeeba diese Sicherheitslücke beheben könne.... Was an der Fehlermeldung interessant war ist der angezeigte Pfad:


    /mnt/web021/e3/73/5199273/htdocs/ordner-der-seite/ordner-für-backup/


    also ebenfalls der alte Pfad bevor Strato den Server umzog, auf den sich die Fehlermeldungen der Blank Pages beziehen.

    In den Einstellungen bei Akeeba (Output Directory) wird der Pfad angezeigt, lässt sich aber nicht ändern. Einmal mehr frage ich mich, wo der alte Pfad in Joomla hinterlegt sein könnte.


    Habt Ihr eine Idee?


    Danke, Filmdoc

  • Ich habe ja auch einige Seiten noch bei Strato und habe die configuration.php mal verglichen.


    Muss jetzt nicht das Problem lösen, aber warum steht bei dir als Server immer rdbms.strato.de bei folgenden Einträgen:


    public $memcache_server_host

    public $memcached_server_host

    public $redis_server_host

    public $session_memcache_server_host

    .........


    usw.......


    Dort steht bei mir überall 'localhost'


    Kann bei mir aber auch falsch sein.


    Allerdings laufen meine Seiten seit 2003 (fast) ohne Probleme.


    Wenn du ein Backup mit Akeeba von der aktuellen Seite mit den richtigen Pfaden machst, sollte er auch ein Restore mit

    den korrekten Pfaden machen.


    Das Backup kannst du erstmal im Root speichern.


    Ansonsten müsste man mal in den KA und in das Backend schauen können.

  • Hallo Elwood,


    vielen Dank für Deine Gedanken, rdbms.strato.de steht da drin, weil ich das sowohl auf der Strato Seite als auch in Foren gelesen habe, dass das für eine stabile Seite auf Strato wichtig sei.

    Ich bilde mir auch ein, mich zu erinnern, dass die Seite mit "lokalhost" nicht funktionierte, aber ich kann das gerne mal nachts irgendwann noch mal testen.


    Das Backup kriege ich hin, Akeeba speichert einfach eine htaccess in den Ordner und dann ist das ausreichend sicher. Es ging mir nur darum, Euch mitzuteilen, dass auch an dieser Stelle noch nach dem alten Pfad gefragt wird.

    Der Durchlauf mit dem Forum Post Assistant zeigt A = 100%, reklamiert aber das die Erlaubnis auf 770 stand, ich habe sie auf 755 herabgesetzt.

    Außerdem wird bei den "Core Folders Permissions"

    angezeigt, dass der Ordner /logs im Root fehlt, doch den habe ich ja entfernt und stattdessen auf administrator/logs gerootet, welcher auch angezeigt wird.


    Was bedeutet in den "KA" schauen?


    Danke und beste Grüße,

    Filmdoc

  • Hallo Elwood, hallo Alle,


    Danke für die Erklärung, ich verstehe.


    Bei der Fehlersuche bin ich auf einen weiteren Ort gestoßen, wo der alte Pfad noch hinterlegt war, nämlich in VirtueMart. Hier gab es beim "sicheren Pfad" noch den alten Eintrag. Interessanterweise zeigte das Programm an, dass die Ordner vorhanden und beschreibbar seien. Obwohl die Seite ja von Strato umgezogen wurde... seltsam. Als nach dem Umzug von Strato noch Reste der Installation an dem alten Ort vorhanden wären...


    Ich habe den absoluten Strato-Pfad eingetragen, nun sind diese Ordner auch korrekt, verweisen auf den neuen Speicherort und werden ebenfalls als vorhanden und beschreibbar gekennzeichnet.


    Leider hat das an den Blank Pages mit der bekannten Fehlermeldung nicht viel verändert. Vielleicht sind sie noch seltener geworden, aber sie sind noch da.


    Habt ihr noch eine Idee, wo ich den falschen, alten Pfad in Akeeba ändern kann? (siehe Post #24)


    Danke und beste Grüße,

    Filmdoc

  • ... vielen Dank für Deine Gedanken, rdbms.strato.de steht da drin, weil ich das sowohl auf der Strato Seite als auch in Foren gelesen habe, dass das für eine stabile Seite auf Strato wichtig sei.

    Ich bilde mir auch ein, mich zu erinnern, dass die Seite mit "lokalhost" nicht funktionierte, aber ich kann das gerne mal nachts irgendwann noch mal testen.

    Zumindest solltest du "localhost" verwenden und nicht "lokalhost." (Vermutlich nur ein Schreibfehler)
    Ob das für eine stabilere Seite wichtig ist, weiß ich nicht. Von anderen Hostern kenne ich das zumindest nicht, und die Seiten laufen dort trotzdem stabil.


    Warum kannst du das Ausgabeverzeichnis in AkeebaBackup nicht ändern? Wie macht sich das bemerkbar. Und natürlich steht da noch der alte Pfad drin, solange du ihn nicht änderst.
    Ist dein AkeebaBackup aktuell? (Version 8.1.4, da du noch Joomla 3 verwendest)

  • Hallo JoomlaWunder,


    vielen Dank für Deine Antwort. Also das localhost war nur ein Tippfehler, sorry.

    Nun wenn ich bei Akeeba in die Einstellungen gehe und gebe den neuen Pfad in das Eingabefenster ein und klicke auf use und speichere danach Akeeba so wird der Pfad nicht übernommen. Wenn ich die Einstellung wieder öffne ist wieder der alte Pfad da drin.


    Im übergeordneten Fenster steht dann zwar [SITEROOT]administrator/components/com_akeeba


    statt DEFAULT, doch wenn ich da auf Browse klicke erscheint wieder der alte falsche Pfad.

    Und ich finde nichts, wo ich den manuell ändern kann. Wenn ich bei dem falschen Pfad in höhere Ebenen klicke, lande ich nie bei einem alternativen Root.

    Es ist wirklich zum Verzweifeln, was diese Strato Aktion für Probleme ausgelöst hat...


    Beste Grüße,

    Filmdoc


    Ja und es handelt sich natürlich um die neueste Version von Akeeba

  • Noch etwas ist mir aufgefallen,- ich konnte mich in Akeeba in dem alten Pfad durch alle Unterordner bewegen, obwohl dieser mnt Pfad doch eigentlich gar nicht mehr existieren sollte.


    Und auch bei VirtueMart wurden die Verzeichnisse in dem falschen alten Pfad als beschreibbar gekennzeichnet.


    Für mich klingt das so, als wenn diese Speicherorte noch existieren, Strato aber den Webspace verschoben und einen anderen neuen Pfad vergeben hat. Müsste Strato dann nicht den alten Pfad auch löschen oder alles umziehen? Irgendwie ist das doch seltsam...


    Bin noch immer am rätseln...


    Filmdoc

  • Hallo Elwood,


    das hatte ich überlesen, das ist sehr freundlich. Wie kann ich Dir denn Zugangsdaten zukommen lassen ohne sie hier zu posten?

    Oder hilft es wenn Du die Strato Logfiles siehst,- da sind zahlreiche Angriffe auf die Seite dokumentiert [data "/images/stories/indoxploit.php"] [severity "CRITICAL"].


    Liebe Grüße,

    Filmdoc

  • Hallo JoomlaWunder,

    hallo Elwood,


    danke für Eure Nachrichten. Also es gibt aktuelle Backups im Prinzip über Strato, da sind etwa bis 1. Mai vorhanden. Ich ziehe mal eines, was 15 Tage alt ist runter. Was meinst Du mit "in einer sicheren Umgebung einspielen?"


    Was die Warnungen im Log angeht, so existieren die Dateien wie /images/stories/indoxploit.php aber auch andere wie evil.php, hack.php, etc. nicht auf dem Webspace. Habe in die jeweiligen Verzeichnisse geschaut.


    Es sind offenbar Versuche, die Seite anzugreifen, weshalb und durch wen, weiß ich nicht. Es scheint auch, als wenn die Angreifer davon ausgehen, dass es eine Wordpress Seite ist, wenn man vergleicht, auf welche php Dateien man versucht, zuzugreifen. Die error-LOGs reichen nur vier Tage zurück und in den vier Tagen gabe es immer wieder Angriffsversuche.


    Auch beziehen sich diverse Warn-Meldungen in den LOGs mehrheitlich auf andere Domains, die ich zwar gesichert habe, aber für die gar keine Joomla Installation existiert. Diese führen aber über Weiterleitung zur Hauptseite.


    Das Problem mit dem falschen alten Pfad ist davon aber unabhängig und besteht, wie gesagt schon länger, ist also nicht durch den Angriff ausgelöst.


    Danke für Eure Mühe,


    Beste Grüße,

    Filmdoc

  • Aktuell stehen ja einige Updates an:



    Die Pfade für /logs und /tmp sind richtig eingetragen.


    BTW: Es ist aktuell kein Backup bei Akeeba vorhanden.

    Die Erstellung eines Backup bricht nach einiger Zeit ab.


    Das letzte, nicht mehr vorhandene, Backup ist vom 05.07.2021 mit einer Größe von 30 GB!


    Da ich nicht zu Hause beim NoLimit-Anschluß bin, kann ich kein manuelles Backup

    dieser Größe i.M. ziehen.

  • Hallo Elwood,


    danke für Deine Nachricht. Die drei Apps die aktualisiert werden wollen, sind eigentlich deaktiviert, deshalb dachte ich, das sollte kein Problem sein. Mindestens eine kann (Acy) ich auch deinstallieren-


    Akeeba Backups gibt es von September 21, habe ich aber vom Webspace runtergenommen und lokal gespeichert.

    Wie schon geschrieben, ziehe ich aktuell eines von Strato per FTP herunter.


    Tut mir Leid, dass die Seite so umfangreich ist. Ich schaue auf jeden Fall, dass ich Backups ziehe.


    Nochmals Danke.

    Beste Grüße,

    Filmdoc