user.css kann nicht bearbeitet werden

  • Hallo,


    habe soeben von 3.10.11 auf 4.2.2 unter PHP 8.0.23 umgestellt (siehe https://migration.ig-lilienthal.de/index.php) auf Basis Cassiopeia. Parallel existiert noch Xenon von RocketTheme, ist aber nicht aktiviert (soll vollständig ersetzt werden)


    Leider ist dabei die Anlage eniner user.css fehlgeschlagen (siehe Anhang) und nichts geht mehr mit dieser Datei - selbst das Löschen geht nicht.


    Konnte die Datei zwar über FTP wieder löschen, aber die Frage ist, was ist da meinerseits oder systemseitig schief gelaufen?


    Habe gerade festgestellt, dass auch keine der vorhandenen Dateien geöffnet werden kann - es kommt immer die Meldung "Es ist ein Fehler . . . ."

  • Tinymce, mit anderen (z.B. Code Mirror) tritt das Problem aber auch auf.


    Danke übrigens für den Link: da schent es also ein ganz aktuelles Problem mit PHP 8 zu geben, dass offfenbar noch nicht gelöst ist. Da wird natürlich schwierig, da überall angeraten wird sobal als möglich auf PHP 8 umzusteigen.


    Ich werde wohl meinen Administrator bitten müssen auf PHP 7 zurückzugehen - oder ?


    Übrigens: auf einer anderen Seite unter PHP 7 und Joomla 4 tritt das Problem nicht auf, was die Beiträge aus dem anderen Forum bestätigt.

    Gruß

    Heinz


    "Wer es nicht versucht schafft es auch nicht."

  • Sehr merkwürdig: auch mit PHP 8.1.10 und J 4.2.2 geht nichts. Auf einer anderen Webseite geht es mit den gleichen Versionen problemlos. Auch der Editor ist in beiden Fällen der gleiche: Tinymce.


    Liegt die Ursache dann doch woanders ?

    Gruß

    Heinz


    "Wer es nicht versucht schafft es auch nicht."

  • Bei der anderen Installation ist RocketTjeme nicht installiert - aber wir haben gerade auf PHP 7 umgestellt und jetzt funktioniert es trotz RocketTheme.


    Wir werden jetzt erst einmal auf J 4 migrieren, u.a. mit dem Ziel RocketTheme und Gantry komplette zu ersetzen, und dann erst auf PHP 8 umstellen.

    Gruß

    Heinz


    "Wer es nicht versucht schafft es auch nicht."

  • Nach der Löschung von RocketTheme und dem Update auf J 4.2.3 kann auch wieder unter PHP 8.1.10 auf die user.css und andere Dateien zugegriffen werden. Ob die Löschung von RocketTheme oder der Update auf J 4.2.3 die Lösung gebracht hat, kann ich allerdings nicht nachvollziehen.


    Es liegt aber nahe, das die Ursache bei RocketTheme lag, da bei einer anderen Seite ohne Rockettheme das beschriebene Problem nie aufgetaucht ist. Insofern hat Dirk (#9) mit seiner Anmerkung sehr wahrscheinlich den Punkt getroffen.

    Gruß

    Heinz


    "Wer es nicht versucht schafft es auch nicht."

  • Die o.g. Fehlermeldung habe ich auch auf verschiedenen Sites. Gerade ist mir aufgefallen, dass diese Meldung weg war, nachdem ich die Sprachdateien aktualisiert hatte (hier von 3.8 auf 4.1.5). Könnten veraltete Sprachdateien möglicherweise auch die Ursache bei dir sein?

  • nachdem ich die Sprachdateien aktualisiert hatte (hier von 3.8 auf 4.1.5). Könnten veraltete Sprachdateien möglicherweise auch die Ursache bei dir sein?

    Die Sprachdateien sollten man doch mit dem entsprechenden Joomla-Update aktualisieren!


    Werden ja auch im BE als Update angeboten!?


    BTW: Aktuell ist 4.2.3!

  • Die Sprachdateien sollten man doch mit dem entsprechenden Joomla-Update aktualisieren!


    Werden ja auch im BE als Update angeboten!?


    BTW: Aktuell ist 4.2.3!

    Hallo Elwood,

    ich war auch irritiert, aber ich musste die Sprachdateien händisch aktualisieren. Kommt selten vor, aber ist nichts Neues für mich. Wenn diese Info auch nur einem weiteren Nutzer hilft, dann hat es sich gelohnt ;)

    Hattest du die oben genannte Fehlermeldung noch nie?

  • Habe die gleiche Erfahrung gemacht: die Sprachdatei wird leider nicht immer automatisch aktualisert - offenbar insbesondere dann nicht, wenn sie später geliefert wird als der entsprechende Joomla-Update.


    Und noch zum ursprünglichen Thema:

    Könnten veraltete Sprachdateien möglicherweise auch die Ursache bei dir sein?

    Kann ich nicht ausschließen: vielleicht ist die Löschung von RocketTheme mit der Aktualisierung der Sprachdatei zusammengefallen. Genaueres weiß ich aber nicht mehr.

    Gruß

    Heinz


    "Wer es nicht versucht schafft es auch nicht."

  • Habe die gleiche Erfahrung gemacht: die Sprachdatei wird leider nicht immer automatisch aktualisert - offenbar insbesondere dann nicht, wenn sie später geliefert wird als der entsprechende Joomla-Update.

    Das verstehe ich auch nicht. Aktualisierungen der Joomla-Sprachdateien werden angezeigt, sobald sie verfügbar sind. Diese werden per Klick installiert.
    Was meinst du mit Automatik? Nutzt du irgendein entsprechendes System zur Aktualisierung von Joomla-Seiten?

    Die deutschen Sprachdateien werden relativ zeitnah erstellt, bei anderen Sprachen dauert es auch mal etwas länger und mache Sprachen werden sehr unregelmäßig aktualisiert.

  • Habe die gleiche Erfahrung gemacht: die Sprachdatei wird leider nicht immer automatisch aktualisert - offenbar insbesondere dann nicht, wenn sie später geliefert wird als der entsprechende Joomla-Update.

    In letzter Zeit war es sogar so, dass das Sprachpaket mit dem Core Update (oft) gleich da war. Nicht immer.

    Und ja, früher oder manchmal gibt es diese halt z.B. erst am nächsten Tag.

    Störte und stört mich nicht.


    War schon mal Thema, worauf zero24 dazu erklärte: RE: Joomla 4.2.3 - deutsche Sprachdateien werden teilweise nicht als Update im Backend angezeigt


    Liebe Grüße

    Christine

  • Vielleicht irre ich mich ja: aber ich hatte den (falschen?) Eindruck, dass bei einem Joomla-Update die Sprachdatei automatisch aktualisert wird sofern vorhanden.

    Vielleicht einfach nur verwechselt mit der englischen Sprache "en-GB", die ja zum Core gehört und deren neue Version sofort nach einem Joomla-Update angezeigt wird.