Zus. Feld in User Profile

  • Ich habe ein Problem.

    Ich will zusätzliche Felder im UserProfil einbauen. Dazu habe ich mich an die Anleitung von Brad Markle gehalten und verschiedene Felder mit Erfolg eingetragen.

    Bei einem habe ich aber auch nach vielen Versuchen kein Erfolg gehabt. Kann mir jemand von der Community helfen?


    Folgendes habe ich im profil.xml eingetragen:

    Code
      <field
                    name="vers"
                    default="Nein"
                    type="radio"
                    id="vers"
                    label="Verzicht auf Postversand:"
                    description="Verzicht auf Postversand">
                    <option value="Ja">Ja</option>
                    <option value="Nein">Nein</option>
            </field>

    Das ist das Resultat auf der Frontseite: statt 2 Radios ist nur ein sichtbar


    Was ich will ist aber sowas:



    Kann mir jemand auf die Sprünge helfen?

    NB: Ich weiss dass man seit J3.7 auch sonst eigene Felder eintragen kann. Ich möchte aber die Einträge in der -User.profile Tabelle zusammen mit den anderen Profildaten haben.


    Danke für die Hilfe

  • Ich habe es kurz nachgestellt und bei mir geht es. Es werden zwei Radio-Buttons im Formular ausgegeben.

    Es liegt wohl an deinem Template

    Hast du z.B. auch schon mal per anhängen von

    &template=protostar

    an die URL,

    geschaut ob es dann korrekt angezeigt wird ?


    Kenne die Anleitung von Brad Markle nicht(Link?), aber die Datei

    /components/com_users/models/forms/profiles.xml

    wird normalerweise wohl bei jedem Update überschrieben mit dem Inhalt der Original-CoreDatei.