Fehlermeldung "Unbekanntes Joomla...", "Unbekannte Erweiterungen,,,", "Es gab einen Fehler bei Überprüfung der Overrides"...

  • Hallo zusammen,

    ich hoffe ich bin hier im richtigen Forum, falls nicht, bitte verschieben. Ich habe jetzt bei ein paar wenigen Joomla Installationen offensichtlich ein Problem. Betroffen sind J4 und auch J3 Installationen mit den PHP Versionen 7.4 und PHP 8.0. Die Seiten haben bis vor wenigen Tagen einwandfrei funktioniert. Meine Vermutung wäre nun dass der Webhoster ein Update eingspielt hat, dieses aber nicht überall das Problem verursacht.

    Es scheint auf etwas mit JSON zu tun zu haben. Zumindest sprechen die Fehlermeldungen bei einer J3 Installation dafür. Ich hänge ein paar Screenshots an... Bilder sagen mehr als 1000 Worte.

    Als Editor verwende ich JCE, hier funktioniert z.B. das Einfügen eines Bildes nicht mehr. Oder ich kann z.B. kein Backup mit Akeeba machen. Screenshots habe ich alle eingefügt.

    Auch der Reinstall der Core-Files funktioniert nicht mehr.

    Kennt jemand von euch diese Problematik und kann mir hier auf die Sprünge helfen?

    Danke schon Vorab!!

    Manfred

  • Ist noch ausreichend Webspace vorhanden?

    Poste mal deine Systeminformationen zu deinen PHP-Einstellungen .

    Dann sehen wir weiter...

    Gefunden in der Forensuche und könnte dir auch schon weiterhelfen:

    simnowski
    24. Juni 2020 um 14:29
  • Hallo Dirk,

    Danke für deine Hilfe!

    Hier die PHP-Einstellungen:

    Bei deinem Link wurde empfohlen die PHP Version auf 7.2 herunter zu setzen. Bei mir lief die Seite aber mit PHP 8.0 einwandfrei. Es wurde da auch nichts geändert. D.h. es wurden keine neuen Plugins o.ä. installiert.

    BG

    Manfred

  • Er forscht auch auf seiner Seite. Aber da der Fehler ja nur bei wenigen Installationen auftaucht und da bei unterschiedlichen Joomla-Versionen mit unterschiedlichen PHP-Versionen, macht das die Fehlersuche natürlich extrem schwierig. Sowohl für ihn als auch für mich.

    Ich versuche ihn da zu unterstützen und vielleicht den richtigen Weg zu finden. Oder vielleicht ist doch irgendwas bei den Installationen im Vorfeld schief gegangen und das macht sich jetzt erst bemerkbar. Stichwort: Probleme bei Updates von Erweiterungen o.ä.

  • Shit... ich habe den Fehler gefunden... also so gesehen nicht shit... aber doch schon, weil der Fehler lag bei mir. :-/

    Es ist das NO SCRIPT-Plugin von Firefox. Ich habe jetzt testweise eine Installation auf dem betroffenen Paket versucht. Mit Firefox klappte nicht einmal die Installation. Das gleiche nochmals mit Chrome probiert, hier konnte ich Joomla plötzlich problemlos installieren.

    Bei Firefox das NO SCRIPT deaktiviert und siehe da... es funktioniert wieder alles.

    Es tut mir leid wenn ich deine Zeit hier vertrödelt habe!!

  • Dann informiere noch schnell deinen Provider.

    Die sind bestimmt dankbar dass Sie die Ursachensuche beenden können.

    dann noch das hier:

  • Schönen Abend!

    Ich habe leider das gleiche Problem. Die Migration unserer Webpage von Joomla 3 auf 4 habe ich auf meinem Notebook erfolgreich durchgeführt. Hier läuft alles zufriedenstellend. Das vom Notebook mit der aktuellen Version gezogene Akeeba-Backup habe ich mittels ftp auf unseren Webspace transferiert und mit kickstart auch ohne Fehlermeldungen in ein neues Verzeichnis mit neuer Datenbank installiert. Im Frontend läuft auch alles. Allerdings im Backend habe ich dieselben Probleme wie MySigma:

    • Fehlermeldung "Unbekanntes Joomla...", "Unbekannte Erweiterungen,,,", "Es gab einen Fehler bei Überprüfung der Overrides"...
    • Serverfehler beim Versuch des Re-installs der Core-Dateien usw.
    • Akeeba-Backup kann ich aber machen...

    Die Installation erfolgte zwar mit dem FF-Browser, allerdings habe ich kein No Script-Plugin.

    Auf meinem Notebook läuft PHP Version 8.1.17, auf dem Webserver ebenfalls.

    Jetzt bin ich etwas ratlos...

    Soll ich versuchen, das vom Notebook gezogene akeeba-Backup mit einem anderen Browser nochmals zu installieren?

    Liebe Grüße

    Gerhard

  • Ich habe jetzt im Forum die Lösung für mich gefunden.


    In der configuration.php war bei $live_site meine Homepage eingetragen.


    Ich habe das gelöscht und nur $live site =' ' hingeschrieben und schon ging wieder alles.


    Ist vielleicht auch für andere mal interessant.


    Dankeschön jedenfalls.

  • [… Kann vielleicht einer erklären, was es mit dem Parameter $live site in der configuration.php auf sich hat. Bisher hatte ich dort immer den Link zur Homepage eingetragen. Also nach dem Schema 'https://domain.de']

    Diese Frage beschäftigt mich ebenfalls.

    Warum wird ausnahmslos empfohlen, die Variable leer zu lassen? Meiner Meinung nach ist die korrekte Angabe immer vorzuziehen? Natürlich muss man daran denken, diese Variable zu ändern, wenn man umzieht. Zum Beispiel, wenn man unter einer anderen URI entwickelt und die live URI später anders ist. Oder wenn man ein Backup unter einer anderen URI testet. Das ist lästig.

    Wenn ich den Code richtig lese, wird mit der korrekten Angabe von $live_site allerdings die Basis-URI für die Erstellung der relativen Routes in Joomla aus der Konfiguration und nicht aus dem HTTP-Header gelesen und somit ist ein HTTP-Host-Header-Angriff schwieriger. (Die Joomla-Doku empfiehlt den Eintrag für non-vhost environment)

    Für mich ist die einzige Erklärung für die Empfehlung, die Variable leer zu lassen, dass das Risiko eines Angriffs in einer modernen, verantwortungsbewussten Serverkonfiguration als ausgeschlossen angesehen wird und daher der Vorteil des automatischen korrekten Auslesens aus dem Header überwiegt.

    Sehe ich das falsch? Übersehe ich etwas? Gibt es Umgebunden, bei denen die korrekte Angabe der $live_site falsch ist und die Variable leer sein muss?

    Wenn meine obige These stimmt, dann wäre es sinnvoller zu klären, warum die Variable live_site Probleme verursacht? gerhard_n  JoomlaDev war die Angabe der Variablen bei euch tatsächlich korrekt?

  • Seit Jahren macht die Varable Probleme, ohne das man sofort auf diese als Verursacher kommt. Daher raten Proktiker diese zu leeren, wenn man ein Problem hat, dass nicht direkt auf die Ursache weist. Läuft's nach dem Leeren, hatte man den vermeintlichen Verursacher.

    Weiter hat mn dann nie geforscht.

  • Für mich ist die einzige Erklärung für die Empfehlung, die Variable leer zu lassen, dass das Risiko eines Angriffs in einer modernen, verantwortungsbewussten Serverkonfiguration als ausgeschlossen angesehen wird und daher der Vorteil des automatischen korrekten Auslesens aus dem Header überwiegt.

    Korrekt. Host Header Injections sind in der Praxis, insbesondere im Kontext des Massenmarkts nicht praktikabel da Webserver in der Regel mit vhosts konfiguriert werden.

  • Hallo Leute,

    ich hatte ein ähnliches Problem, als ich Joomla 3 auf 5 auf einer Subdomain installiert habe.

    Nach der Installation tauchte das gleiche Problem auf. Als ich in der configuration.php nachschaute, stellte ich fest, dass im Eintrag public $live_site = 'https..........de'; noch die Subdomain angegeben war. Nachdem ich diese durch die richtige Domain ersetzt hatte, funktionierte alles wieder einwandfrei.

    Danke für das tolle Forum. Ihr seid Spitze.

    Viele Grüße,

    Harry :)

    Es gibt nicht so viel Tag im Jahr - als der Fux am Schwanz hat Haar

  • Hallo Leute,

    ich hatte ein ähnliches Problem, als ich Joomla 3 auf 5 auf einer Subdomain installiert habe.

    Nach der Installation tauchte das gleiche Problem auf. Als ich in der configuration.php nachschaute, stellte ich fest, dass im Eintrag public $live_site = 'https..........de'; noch die Subdomain angegeben war. Nachdem ich diese durch die richtige Domain ersetzt hatte, funktionierte alles wieder einwandfrei.

    Ich denke public $live_site sollte am besten leer sein.

  • Hallo Leute,

    ich hatte ein ähnliches Problem, als ich Joomla 3 auf 5 auf einer Subdomain installiert habe.

    Nach der Installation tauchte das gleiche Problem auf. Als ich in der configuration.php nachschaute, stellte ich fest, dass im Eintrag public $live_site = 'https..........de'; noch die Subdomain angegeben war. Nachdem ich diese durch die richtige Domain ersetzt hatte, funktionierte alles wieder einwandfrei.

    Wie in #18 bereits geschrieben: $live_site muss in 99% aller Fälle leer sein. Ansonsten hast du bald das nächste Problem. Das ist einer der häufigsten Gründe, warum es zu Problemen kommt. Schreibe ich diese Woche schon zum dritten Mal! :)

    Aber auch wieder schön, wenn sich Probleme so einfach lösen lassen. Meist sucht man sich aber einen Wolf bzgl. Ursache, weil man an diesen Eintrag einfach nicht denkt.