Eigenes Template - ein paar Fragen

  • Joomla Version
    4.3.1
    PHP Version
    PHP 8.1.x
    Hoster
    Strato

    Hallo Zusammen,

    Ich habe mir ein eigene Template für Joomla 4 gebaut

    Nun habe ich es auf meiner Webseite installiert

    Da sind mir 2 Probleme aufgefallen

    1. Das Thumbnail wird leider nicht angezeigt (ich kann es aber direkt im Browser aufrufen)

    2. Wenn ich unter "Templates: Anpassen" bekomme ich folgende Meldung

    Code
    Das Template-Verzeichnis ist nicht beschreibbar. Einige Funktionen werden nicht funktionieren.

    Wenn ich habe mit Filezilla nach den Berechtigungen schauen sind diese auf "755" gesetzt

    Diese Problem hab ich aber nur bei meinem Template

    Wenn ich mir ein Template downloade z.B. Helix dann habe ich das Problem nicht

    Hier mal die Ordnerstruktur meines Template

    in der templateDetails.xml habe ich es wie folgt eingefügt

    Kann mir jemand sagen was ich falsch gemacht habe?

    Danke im Voraus

    Gruß

    Marcel

  • Lui_brempt

    Hier mal der komplette Inhalt

    was ich mich auch frage ist wie es jetzt nun richtig ist

    Code
    <filename></filename>

    der

    Code
    <file></file>
  • was ich mich auch frage ist wie es jetzt nun richtig ist

    Code
    <filename></filename>

    oder

    Code
    <file></file>

    Ich bin zwar nur Laie aber warum schaust du dir nicht einfach das Joomla!4-Core-Template oder andere Templates an?

    Siehe z.B.:

    github.com/joomla/joomla-cms/blob/4.3.1/templates/cassiopeia/templateDetails.xml#L11-L19

    github.com/drmenzelit/nature-j4-template/blob/master/templateDetails.xml#L15-L24

    codeberg.org/astrid/j4examplecode/src/branch/t41a/src/templates/facile/templateDetails.xml#L14-L22

  • ...Filename ist wohl ab J4 zu verwenden.

    ist aber z.B. auch schon bei Joomla 2.5 genutzt worden:

    github.com/joomla/joomla-cms/blob/2.5.28/templates/atomic/templateDetails.xml


    Außerdem eventuell nützlich:

    blog.astrid-guenther.de/der-weg-zu-joomla4-erweiterungen/#template


    Was steht den im Backend bei:

    System-> Systeminformationen im Tab Systeminformationen ->PHP-Interface für den Webserver ?


    Eventuell wwwrun-Problem. Siehe z.B. auch:

    Fehler beim Kopieren eines Template

    Joomla! und das wwwrun Problem

  • Hier mal Systeminformationen -> PHP-Einstellung

    Zitat
    Upload Max Filesize128M
    Post Max Size128M
    Speicherlimit512M
    Open-BasedirKeine
    Fehler anzeigenAus
    Kurze Open-TagsAn
    Datei-UploadsAn
    Ausgabe zwischenspeichernAus
    Sitzungsspeicherpfad2;/var/tmp
    Sitzungsautostart0
    XML aktiviertJa
    Zlib aktiviertJa
    Natives ZIP aktiviertJa
    Deaktivierte FunktionenKeine
    Fileinfo VerfügbarJa
    Mbstring aktiviertJa
    GD VerfügbarJa
    iconv VerfügbarJa
    intl VerfügbarJa
    Maximale Eingabevariablen4000
  • Obiger "Screenshot" von System-> Systeminformationen ist der Tab PHP-Einstellung

    und ist nicht die Information vom benötigten Tab, sondern es wird zuerst benötigt wie oben in #6 bereits genannt den Wert von:

    System-> Systeminformationen im Tab Systeminformationen -> PHP-Interface für den Webserver

    und am besten auch die restlichen Angaben aus diesem Tab.

  • Wenn du

    Code
        <inheritable>1</inheritable>

    in der templateDetails setzt, deklarierst su das Template als Child-fähig.

    Dann musst du auch so was in der Art in der templateDetails haben (Beispiel aus dem Cassiopeia):

    Code
    <media destination="templates/site/cassiopeia" folder="media">
    <folder>js</folder>
    <folder>css</folder>
    <folder>scss</folder>
    <folder>images</folder>
    </media>

    Damit landen die Asset-Dateien bei der Installation im Ordner

    Code
    /media/templates/site/cassiopeia/

    Und da kommt deine Meldung her, weil sie da bei dir nicht sind.

    Willst du das nicht, darf der Tag

    Code
        <inheritable></inheritable>

    gar NICHT vorkommen!. Auch nicht mit 0 oder so. EDIT: Leider war mein diesbzgl. Fix damals ein Flopp und musste wieder entfernt werden: https://github.com/joomla/joomla-cms/pull/39329

    WOher ich das weiß? Weil ich über die Meldung auch schon gestolpert bin und nat. wegen dem verlinkten PR ;)

  • Danke genau das war das Problem