Prepared statement needs to be re-prepared

  • Joomla Version
    4.4.3
    PHP Version
    PHP 8.1.x
    Hoster
    Hoststar

    hallo, ich habe mal folgende Frage:

    Mein Hoster hat seit kurzem die DB-Version upgegradet. Wenn ich nun eine Seite auf welchem das Plugin "Sigplus" integriert ist aufrufe, wird folgender Fehler ausgegeben:

    Prepared statement needs to be re-prepared

    kennt da jemand den Zusammenhang? beim Hoster wirft das Rätselraten auf .....

    Danke für Tips

    Stefan


    Vielleicht noch folgender Zusatz: Bei Joomla-Version 3.10.12 (gleicher Hoster) läuft es problemlos .... :(

    Einmal editiert, zuletzt von Indigo66 () aus folgendem Grund: Ein Beitrag von runner.one mit diesem Beitrag zusammengefügt.

  • Du solltest Dich definitiv nochmal an Deinen Hoster wenden.

    Ziehe Dir ein Backup und teste es mal lokal mit XAMPP unter PHP 8.1 und MySQL 8.0.

    Der Hoster ist immer noch am "Suchen" ......
    Allerdings speziell ist die Situation, dass es bei Joomla-Ver. 3.10.12 kein Problem gibt, mit demselben Plugin und gleichen Hoster, gleichen DB-Version, nur gerade mit Joomla 4. xx, erscheint dieser Fehler ...

    Stefan

  • Läuft auf J!4 auch die Sigplus Version für 4?

    https://bitbucket.org/hunyadi/sigplus/downloads/

    Sigplus ist jetzt keine unbekannte Erweiterung und Dein Fehler ist bis jetzt hier nicht aufgeschlagen.

    Vielleicht mal beim Entwickler nachfragen?

    ja, bei anderen Hoster bislang keine Probleme, aber auch bei HOSTSTAR habe ich noch Installationen, wo es problemlos läuft, einfach nur kein Update des Plugins Sigplus machen, denn danach derselbe Fehler ...... (auch wenn ich wieder eine ältere Version von Sigplus drüberbügle ...) schon sehr seltsam.
    Habe auch schon beim Entwickler nachgefragt, aber keine Antwort erhalten.

    Stefan

  • Hoi Stefan


    Ist bei mir aufgetreten und folgende Massnahme hat geholfen:


    Letztes funktionierendes Backup eingespielt, das neuste sigplus 1.5.0.300 ohne das alte zu deinstallieren manuell (nicht über die Update-Funktion, sondern das ZIP selber hochgeladen) darüber installiert. Dann kam die Fehlermeldung nicht mehr.

    (trat nur bei einem Hoster auf)


    Gruss

    Urs

  • Hallo Urs, habe zwar leider kein Backup, aber wie meinst du "ZIP selber hochladen" ?


    Aber wie auch immer, wenn ich eine völlig neue, frische Joomla 4.4.3 mache, das Plugin installiere, kommt der Fehler sofort ....
    das ist doch nicht normal ...? so langsam drehe ich durch :)

  • Hoi Stefan


    Der Fehler trat auf, als ich von J! 4.4.3 auf 5.0.3 updaten wollte. Ich hatte noch sigplus 1.5.0.299 laufen. Deinstallieren von sigplus, updaten auf J! 5.0.3 und danach installieren von sigplus 1.5.0.300 hat nichts genützt, der Fehler trat wieder auf. Update auf 1.5.0.300 vor dem Update hat ebenfalls nichts genutzt.


    Dann habe ich herumexperimentiert und mit folgendem Vorgehen hat's geklappt:


    • Ich habe das letzte funktionierende Backup wieder eingespielt (Akeeba) ohne die Datenbank vorher zu löschen (einfach Ersetzen für existierende Tabellen angegeben).
    • Dann habe ich (J! 4.0.3) im Menü 'System', in der Gruppe 'Installieren' auf 'Erweiterungen' geklickt und dort das Tab 'Paketdatei hochladen' gewählt.
    • Dann die vorher heruntergeladene ZIP von sigplus Version 1.5.0.300 reingezogen
    • Der Fehler trat nicht mehr auf, und ich konnte auf J! 5.0.3 updaten und es lief immer noch.

    Meine Daten beim Hoster (hoststar: Datenbankversion 8.0.36-0ubuntu0.20.04.1, PHP-Version 8.1.27).


    (Anmerkung: Fehler trat nur bei diesem Hoster auf)


    Versuche doch mal zuerst die 1.5.0.299 zu installieren, dann die 1.5.0.300 wie beschrieben darüber zu installieren.


    Ich hoffe, das hilft Dir.


    Viele Grüsse

    Urs

  • Ich habe leider das gleiche Problem
    Seit der Datenbankaktualisierung des Hoster, funktioniert SigPlus nicht mehr.
    Vorher konnte ich noch den {gallery} Eintrag eines bestehenden Artikels in den neuen Artikel kopieren, und dann hat es (meist) noch funktioniert.
    Seit ich diverse Tipps hier ausprobiert habe, geht gar nichts mehr.

    Hoster: Hoststar,

    Datenbank : 8.0.36-0ubuntu0.20.04.1
    Joomla: Joomla! 4.4.3 Stable
    PHP : 8.3.6

    Momentan bin ich auf Simple Image Gallery gewechselt, da der den selben Eintrag im Content auswertet {gallery}pfad_zu_den_Bildern{/gallery}

    Interessanterweise habe ich noch eine 2. Website laufen mit haargenau der selben Konfiguration.
    Bei der läuft SigPlus tadellos.

  • Hoststar ist - na sagen wir mal - ein sehr spezieller Hoster. Die haben in den letzten Wochen den Update auf MySQL 8 gewagt, und seit dem klagen immer wieder Kunden über solche Dinge wie 'läuft nicht mehr'. Der Support beim Hoster ist etwas überfordert, deucht mich, schieben die doch prinzipiell die Fehlerursache auf Joomla.