Login im Backend nicht mehr möglich

  • Joomla Version
    5.1.0
    PHP Version
    PHP 8.3.x
    Hoster
    mkd.de
    Link (URL) zur Seite mit dem Problem
    https://arkaden-buchhandlung.de/administrator/

    Moin,

    mein letztes erfolgreiches Login im Backend war am 06.05.2024, danach wollte ich mich im Backend anmelden und erhalte keinen Zugang mehr.

    In der DB sind meine Userdaten als Superuser enthalten. Das Passwort habe ich noch mal in der Tabelle eingetragen mit md5.

    Schicke ich meine Anmeldedaten ab wackelt das Bild hin und her, sonst passiert nichts.

    Public-html gelöscht und aus dem Backup vom 05.05.2024 wieder hergestellt - keine Änderung!

    Fehleranalyse wie in KEIN Login als Admin möglich beschrieben habe ich ohne Erfolg durchgeführt.

    Browser-Cache gelöscht.

    DB mysql Version 10.11.6-MariaDB-0+deb12u1

    In der configration.php ist $error_reporting = 'maximum';

    Fehler werden beim Backend Login nicht angezeigt.

    Debug und error-reporting habe ich inzwischen wider zurück gesetzt.

    Wer kann helfen?

    Mfg

    Jörg

  • Schau in die configuration.php, ob dort $cookie_domain auch wirklich leer ist. Das wäre typisch für einen Login-Loop, wenn du dort was eingetragen haben solltest.

    Und überprüfe bei der Gelegenheit auch gleich $live_site ! Sollte auch leer sein!

    Ansonsten:
    Was hast du seit dem letzten erfolgreichem Login geändert? Hast du was installiert in Joomla oder was aktiviert bzw. deaktiviert, z.B. bei den Login-Plugins?

    Hat sich am Server etwas geändert, z.B. die PHP-Version oder irgendwas an der Datenbank?

    Nebenbei: Am Passwort in der DB hätte ich jetzt nicht gleich rumgespielt, nicht dass da nun ein weiteres Problem entstanden ist. Das hat sicher eine andere Ursache, es sei denn, du hättest das Passwort vergessen gehabt.

  • Schau in die configuration.php, ob dort $cookie_domain auch wirklich leer ist. Das wäre typisch für einen Login-Loop, wenn du dort was eingetragen haben solltest.

    Und überprüfe bei der Gelegenheit auch gleich $live_site ! Sollte auch leer sein!

    Ansonsten:
    Was hast du seit dem letzten erfolgreichem Login geändert? Hast du was installiert in Joomla oder was aktiviert bzw. deaktiviert, z.B. bei den Login-Plugins?

    Hat sich am Server etwas geändert, z.B. die PHP-Version oder irgendwas an der Datenbank?

    Nebenbei: Am Passwort in der DB hätte ich jetzt nicht gleich rumgespielt, nicht dass da nun ein weiteres Problem entstanden ist. Das hat sicher eine andere Ursache, es sei denn, du hättest das Passwort vergessen gehabt.

    $cookie_domain, $cookie_path und $live_site sind leer.

    Änderunen an der PHP-Version oder der Datenbank gab es bis zum ersten Login-Fehlversuch nicht, danach wie oben beschrieben..

    In welcher Tabelle werden Benutzeraktivitäen gespeichert? Da müsste ich nachsehen ob ich etwas am 05.05. aktiviert bzw. deaktiviert habe.

    Danke schon mal für die Rückmeldung.

  • Versuche es mal mit PHP 8.1 und 8.2

    Top! Danke für den den Tipp. Ich bin auf die PHP 8.2.18 zurück gegangen und Login klappt.

    Du bist gut!!


    Versuche es mal mit PHP 8.1 und 8.2

    Im Frontend hatte J2Store 4.0.4. Pro mit der 8.3. auch Probleme. das ist mit der PHP 8.2.18 auch erledigt.

    Einmal editiert, zuletzt von Indigo66 (21. Mai 2024 um 06:28) aus folgendem Grund: Ein Beitrag von mkd-technik mit diesem Beitrag zusammengefügt.

  • Ich bin auf die PHP 8.2.18 zurück gegangen und Login klappt.


    Im Frontend hatte J2Store 4.0.4. Pro mit der 8.3. auch Probleme. das ist mit der PHP 8.2.18 auch erledigt.

    Das Login ins Backend von Joomla 5.1.0 sollte mit PHP 8.3 aber funktionieren. Am besten suchst du weiterhin die Ursache.

    Falls es mit J2Store zu tun haben sollte, empfehle ich zunächst eine Aktualisierung auf 4.0.5!

    Überprüfe auch alle anderen Drittanbieter-Erweiterungen auf Kompatibilität zu J5 und PHP 8.3!

  • Das Login ins Backend von Joomla 5.1.0 sollte mit PHP 8.3 aber funktionieren. Am besten suchst du weiterhin die Ursache.

    Falls es mit J2Store zu tun haben sollte, empfehle ich zunächst eine Aktualisierung auf 4.0.5!

    Überprüfe auch alle anderen Drittanbieter-Erweiterungen auf Kompatibilität zu J5 und PHP 8.3!

    Moin und Danke für die Hinweise!

    :thumbup: