Cassiopeia - Einstellungen immer wieder weg

  • Datenbank-Version und Manifest-Version sind aktuell.

    Ich würden nun zuerst im Tab System das "System debuggen" auf "Ja" einstellen und speichern:

    /administrator/index.php?option=com_config

    Dann zuerst testen ob der Fehler weiterhin vorhanden ist.

    Falls der Fehler weiterhin vorhanden dann im Tab Server das "Fehler berichten" auf "Maximum" einstellen und speichern.

    Dann testen ob der Fehler weiterhin vorhanden ist und berichten ob nun Meldungen oder Fehler angezeigt werden.

  • Der Wert steht auf 1000

    Dieser Wert erscheint mit sehr gering. Soweit ich mich erinnern kann sollte die max_input_vars am besten auf 8000 oder höher stehen. Bei mir sind es beispielsweise 20.000. Gut möglich das dies bereits Deine Fehlerquelle ist.

  • Der Wert steht auf 1000

    Kann mich da nur anschließen. Der Wert ist allgemein zu niedrig. Beim Speichern der Konfigurationseinstellungen in Joomla dürfte dieser ein Problem darstellen. Mit 2000 selbiges Problem. Mit 4000 war das Problem (zumindest) bei meinen Installationen immer behoben.
    Setze den Wert auf jeden Fall höher! Ob er Auswirkungen auf die Template-Einstellungen hat, weiß ich aber nicht.

    Viele Grüße!
    JoomlaWunder

  • Kann mich da nur anschließen. Der Wert ist allgemein zu niedrig. Beim Speichern der Konfigurationseinstellungen in Joomla dürfte dieser ein Problem darstellen. Mit 2000 selbiges Problem. Mit 4000 war das Problem (zumindest) bei meinen Installationen immer behoben.
    Setze den Wert auf jeden Fall höher! Ob er Auswirkungen auf die Template-Einstellungen hat, weiß ich aber nicht.

    Werde ich ausprobieren. Ich habe mir gerade andere Seiten auf dem gleichen Server angesehen, die ich schon auf J6 umgestellt habe. Bei allen ist die Einstellung 1000.

  • Sehr unwahrscheinlich, dass nur das Speichern des Templates Probleme macht ... aber, wer weiß ...

    Das ich Weihnachten vor einem Kamin verbringe... nackt... auf einem Bärenfell.... DAS ist unwahrscheinlich Fräulein Menzel.
    Aber ja, eigentlich sollte es dann auch beim Speichern von längeren Artikeln oder anderen Konfiguration Probleme geben.

    Eventuell könnte noch eine Regel in Mod_Security anspringen und den Vorgang abbrechen. Also wenn der Hoster eine Application-Firewall laufen hat. Sollte aber eine Meldung in den Protokollen geben.

  • Sehr unwahrscheinlich, dass nur das Speichern des Templates Probleme macht ... aber, wer weiß ...

    Ich habe noch keine anderen Probleme feststellen können, aber habe ja schon in #26 geschrieben, dass ich wohl besser neu aufbaue. Interessieren tut es mich trotzdem, ob der Fehler zu finden ist. Wird man ja nicht dümmer durch.

  • Ich habe noch keine anderen Probleme feststellen können, aber habe ja schon in #26 geschrieben, dass ich wohl besser neu aufbaue. Interessieren tut es mich trotzdem, ob der Fehler zu finden ist. Wird man ja nicht dümmer durch.

    Sollte es an diesem Wert liegen, würde das Problem auch bei jedem anderen frisch installierten Joomla wieder auftreten. Bei mir auf dem Server kann ich ihn nicht einfach so ändern, sonst hätte ich es schon selbst getestet. Aber vielleicht hast Du ja die Möglichkeit mal schnell auf einer Subdomain ein neues Joomla aufzusetzen und zu schauen ob es dort funktioniert?

  • Mich interessiert die Ursache auch sehr. Beispielsweise bin ich seit Jahren mit 1000 max input vars als Default mit vielen Kunden gut gefahren und der Thread brachte mich dazu, mich mit dem Thema zu beschäftigen - der Wert war allerdings schon immer durch den Kunden einstellbar.

    Wenn ich mal dazu komme, werde ich auch mal testen, wie weit ich den Wert runter schrauben kann, bis Fehler auftreten und ob dann komische Effekte auftreten oder Fehlermeldungen/Log-Einträge.

    Ich kann Euch gern einen Test-Webspace mit Zugriff auf alle gewünschten PHP-Parameter (per Webinterface, kein php.ini-Gefrickele) bereitstellen, wenn das hilft

  • Lokal kann ich nicht. Da habe ich mich noch nie mit beschäftigt. Auf dem Server laufen mehrere J6 Installationen. Alle problemlos. Nur diese eine macht Probleme. Eine Seite war eine Neuinstallation. Ich habe auch schon mehrfach hier frische J6 zum Rumspielen installiert. Immer ohne Probleme. Zwei Seite habe ich hochgerüstet auch problemlos.

    Die Seite, die Probleme macht, habe ich auch schon in ein anderes Abo kopiert (auf dem gleichen Server). Auch hier die gleichen Probleme. Ich werde die Seite mal auf einen anderen Server kopieren, aber das schaffe ich frühstens Freitag.